fa fa icons replaced by blinking question and exclamation mark in Kunena Topic is solved

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
User avatar
fabio42
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Tue Aug 20, 2019 2:39 pm

fa fa icons replaced by blinking question and exclamation mark in Kunena

Post by fabio42 » Sat Mar 13, 2021 7:17 pm

Hello !
I have the latest joomla version, the latest Gantry version (5.4.37) and I have the following problem : some of the fa fa icons (Font Awesome) associated to the menu names blink on some pages of my websites.They are replaced by a blinking question mark followed by an excalamation mark.
Any idea ?
Thanks for your help !
Last edited by toivo on Sun Jun 13, 2021 12:20 am, edited 1 time in total.
Reason: mod note: moved from 3.x Templates, retitled

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 7243
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: fa fa icons replaced by blinking question and exclamative mark in Gantry 5

Post by AMurray » Sat Mar 13, 2021 9:29 pm

I don't know what you mean - please provide a link to the site showing the problem.

Do you have the latest font awesome version as well?
Regards - A Murray

User avatar
fabio42
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Tue Aug 20, 2019 2:39 pm

Re: fa fa icons replaced by blinking question and exclamative mark in Gantry 5

Post by fabio42 » Sat Mar 13, 2021 10:00 pm

Hello !
So, here's a link to the website : https://www.4u2learn.fr/joomla/forumkunena
There are 2 icons blinking (in the top horizontal menu, the two menu items being "download" and "contact me")and what is strange is that if you go to the welcome page, the icons do not blink anymore : https://www.4u2learn.fr/joomla/
As for the Awesome Font version, where can I get this information in my admin panel ? I believe they were installed with Gantry automatically (and were therefore automatically updated as well), so I never figured that out.
Thanks for your answer !

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 7243
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: fa fa icons replaced by blinking question and exclamative mark in Gantry 5

Post by AMurray » Sat Mar 13, 2021 10:33 pm

[edit] Now I look closer, it appears it's only the Kunena forum link that shows the missing icons. All other pages seem to load them correctly. Not sure then if that's a Kunena problem directly.

Below advice may no longer be relevant.

I think the problem is that Gantry's list of FA icons might be out of date. I don't know how it sources the icons you can select using http://docs.gantry.org/gantry5/tutorial ... con-picker but the ones you have chosen appear to no longer exist at the fontawesome end.

Using your two examples: the Download and Contact Us menu items:

(1) The inspect element function of my browser shows the download icon on your site as "fa-cloud-download" but on fontawesome.com, the only similar icon I can find is "fa-cloud-download-alt".

(2) Inspect element also shows on your site, the Contact Us icon to be "fa-envelope-o" but the most similar icon name I can find on fontawesome.com is "fa-envelope-open"

So the flashing exclamation/question is indicating a missing icon (due to the wrong name). If the icons are selected through the icon picker, then I think you need to ask Gantry the question about them getting their extension/framework/template updated. Ask them to replicate the issue with the two icons you're having issues with.

Also, can you replicate the problem yourself; maybe set up a new test site, a fresh install of Gantry, and just see if it still presents a problem on a fresh install.
Regards - A Murray

User avatar
fabio42
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Tue Aug 20, 2019 2:39 pm

Re: fa fa icons replaced by blinking question and exclamative mark in Gantry 5

Post by fabio42 » Sun Mar 14, 2021 9:58 am

Hi !
Thanks for all the investigations into the problem. I'm now going to keep digging into the issue by contacting both Gantry & Kunena support. It appears that both of them provided a recent update at about the same moment, and I did not notice the issue at first, so, il it impossible for me to know which one is the "culprit" ;) in the problem.
I thought that Gantry updated the Font Awesome icons regularly but obviously they don't.
What I still do not undertsand is why the icons appear on some menu links and not others. :(
Hope someone will find the solution !
Thanks again !

User avatar
fabio42
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Tue Aug 20, 2019 2:39 pm

Re: fa fa icons replaced by blinking question and exclamative mark in Gantry 5

Post by fabio42 » Sat Jun 12, 2021 4:23 pm

Back me with the solution !
I had to go in the template options of the Kunena Forum (Crypsis), and set "Load External CDN Fontawesome" to "No". That fixed it !
Thanks for your time anyway !

skurvish
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Oct 27, 2008 2:41 pm

Re: fa fa icons replaced by blinking question and exclamation mark in Kunena

Post by skurvish » Sat Oct 16, 2021 3:12 pm

Thank you for returning and providing your solution. It helped me solve the same problem I was having.


Post Reply

Return to “Extensions for Joomla! 3.x”