Error when editing articles in php 8+ Topic is solved

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
kkdahl
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Jul 30, 2022 8:43 am

Error when editing articles in php 8+

Post by kkdahl » Tue Sep 27, 2022 5:48 am

Have a 3.10.11 site using seblod 3.22.1.
I get this error, when I try to edit any article (FE and BE)

count(): Argument #1 ($value) must be of type Countable|array, null given

If I downgrade php to 7.4 all is well, and things works as supposed to, but on php 8.0 or 8.1 the error is there.
(Everything else but the article-editing seems to work fine, and the site is showing and behaving nicely to the users.

I can't make any sense of it?

SharkyKZ
Joomla! Hero
Joomla! Hero
Posts: 2472
Joined: Fri Jul 05, 2013 10:35 am
Location: Parts Unknown

Re: Error when editing articles in php 8+

Post by SharkyKZ » Tue Sep 27, 2022 6:34 am

Seblod 3.x is not and probably will not be compatible with PHP 8. You'll have to wait for 4.0 to be released.

kkdahl
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sat Jul 30, 2022 8:43 am

Re: Error when editing articles in php 8+

Post by kkdahl » Thu Sep 29, 2022 5:20 am

Dang!

EOL regarding security support on php 7.4 is 28 nov 2022 :eek:


Post Reply

Return to “Extensions for Joomla! 3.x”