PHP 8 migration for ARI Ext Menu Topic is solved

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
Jefferson49
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sun Sep 11, 2022 11:07 am

PHP 8 migration for ARI Ext Menu

Post by Jefferson49 » Sun Sep 11, 2022 11:37 am

Hello users of the ARI Ext Menu,

during the migration of my joomla 3.10 site to PHP 8, I recognized that the ARI Ext Menu module is not working with PHP 8. Therefore, I created a patch for the ARI Ext Menu, which I provide on Github: https://github.com/Jefferson49/PHP8_mod_ariextmenu

The patch was developed and successfully tested with:
  • joomla 3.10.11; but should also run with other joomla 3.x versions
  • PHP 8.0.20
  • ARI Ext Menu 2.2.11
The following aspects of the PHP code were patched in 6 PHP files of the module:
  • Substitution of curly braces for character access in arrays (e.g. "my_array[0]" instead of "my_array{0}")
  • Declaration of static methods as static (i.e. "static function" instead of "function" only)

User avatar
ozneilau
Joomla! Guru
Joomla! Guru
Posts: 867
Joined: Tue Aug 04, 2009 9:05 am
Location: Tasmania, Australia
Contact:

Re: PHP 8 migration for ARI Ext Menu

Post by ozneilau » Sun Sep 25, 2022 11:03 am

On behalf of the 100+ Joomla fans that have read this post, and all the rest that come by later, thank-you so much for sharing!

Jefferson49
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Sun Sep 11, 2022 11:07 am

Re: PHP 8 migration for ARI Ext Menu

Post by Jefferson49 » Sun Nov 20, 2022 4:19 pm

Hello users of the ARI Ext Menu,

now, I managed to migrate the module to joomla 4.x

The patch for the 4.x migration (including also PHP8) is available on Github:
https://github.com/Jefferson49/PHP8_mod_ariextmenu

The joomla 4.x patch (including PHP 8 patch) was developed and tested with:
  • joomla 4.2.5; but should also run with other joomla 4.x versions.
  • PHP 8.0.23; but should also run with other PHP 8.x versions
  • ARI Ext Menu 2.2.11 (with PHP 8 patch)

BruceT123
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Dec 01, 2022 7:56 am

Re: PHP 8 migration for ARI Ext Menu

Post by BruceT123 » Thu Dec 01, 2022 7:59 am

I agreed with this article. In November 2022, PHP 7's final version 7.4 will no longer get security updates. Then, PHP 7.4 users will need to update to version 8.0 or later. Before then, it would be really helpful if ARI Ext Menu could be upgraded to support PHP version 8.X. Thank you.


Post Reply

Return to “Extensions for Joomla! 3.x”