SEF links not working when menu items added in JCE Topic is solved

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
jeffhoneyager
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 106
Joined: Fri Dec 16, 2005 12:16 am
Location: Michigan
Contact:

SEF links not working when menu items added in JCE

Post by jeffhoneyager » Mon Dec 05, 2022 6:14 pm

Any ideas?

SEF & htacces.txt >> .htaccess all set correctly

Any menu other than the main menu displays a url like:

/index.php?option=com_content&view=article&id=29:hempstead-tx-pool-installation-custom-decks&catid=11:cities-served&Itemid=343

Obviously not very nice.

What else should I look for ?
Last edited by toivo on Tue Dec 06, 2022 5:40 am, edited 1 time in total.
Reason: mod note: moved from 3.x Administration, retitled
Peace & Joy, Jeff Honeyager
http://ExpertWebProfessionals.com
http://Jeff.honeyager.com
"Test Everything, Hold On To The Good."

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 15501
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: SEF not working

Post by toivo » Mon Dec 05, 2022 9:07 pm

jeffhoneyager wrote:
Mon Dec 05, 2022 6:14 pm
SEF & htacces.txt >> .htaccess all set correctly
Just a thought, is your web server Apache or LiteSpeed, both of which support .htaccess?

Go to Articles - Options and make sure that the URL Routing option is 'Modern' and that 'Remove IDs from URLs' has been selected.
Toivo Talikka, Global Moderator

jeffhoneyager
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 106
Joined: Fri Dec 16, 2005 12:16 am
Location: Michigan
Contact:

Re: SEF not working

Post by jeffhoneyager » Mon Dec 05, 2022 11:35 pm

Thank you for responding.

It supports .htaccess
Both Article options were selected as you suggested.

Weird - if I put a link from the main menu - all works well. On other menus placed in modules, the URL is not SEF.

All my other sites, other menus have SEF.

So bizarre :(
Peace & Joy, Jeff Honeyager
http://ExpertWebProfessionals.com
http://Jeff.honeyager.com
"Test Everything, Hold On To The Good."

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 15501
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: SEF not working

Post by toivo » Tue Dec 06, 2022 1:59 am

Are there any third party plugins that could be the root cause?

Please post the results from the Forum Post Assistant (FPA) by following the instructions at https://forumpostassistant.github.io/docs/ so that our volunteer experts can review the configuration.
Toivo Talikka, Global Moderator

jeffhoneyager
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 106
Joined: Fri Dec 16, 2005 12:16 am
Location: Michigan
Contact:

Re: SEF not working

Post by jeffhoneyager » Tue Dec 06, 2022 4:18 am

Again, thank you. You got me in debug mode.

Here is the issue:

1) Created a long menu of single article links
2) Displayed this menu on the "Right" module position

SEF works for those menu items

Problem: I wanted to display this menu in a mega menu, but I could not format this list into a 3 column table. The list is too long for a drop down.

So: Created a custom module with 3 columns and entered the names of the menu items in the entries of the 3 columns.

3) Added a link from the 3 col. module as a menu item. In the editor (JCE), the link tool selects the menu item and replaces it with the NON-SEF URL

4) So the 3 column module display in the mega menu does what it was told to do - use the NON-SEF URL.

Everything is working as it should.

I have to manually enter the SEF URL for each item in the 3 column module.

Thanks again for your repeated replies. You helped make me work through and find the exact cause and solution.
Peace & Joy, Jeff Honeyager
http://ExpertWebProfessionals.com
http://Jeff.honeyager.com
"Test Everything, Hold On To The Good."

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 15501
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: SEF not working

Post by toivo » Tue Dec 06, 2022 5:36 am

Cheers.

jeffhoneyager wrote:
Tue Dec 06, 2022 4:18 am
In the editor (JCE), the link tool selects the menu item and replaces it with the NON-SEF URL
That is how JCE inserts the links, if you use the Browse function and locate the menu item from the list of menus. When the page is rendered, Joomla converts the non-SEF links to SEF links.

Ref. Selecting "menu link" doesn't give me a sef url, only non sef, why?

jeffhoneyager wrote:
Tue Dec 06, 2022 4:18 am
I have to manually enter the SEF URL for each item in the 3 column module.
No need to do that if the selected menu links are relative. If the link in the custom module is an absolute link, starting with http or https://, the link remains in the original non-SEF format and is not converted when the page is rendered. Therefore, always use relative links.
Toivo Talikka, Global Moderator

jeffhoneyager
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 106
Joined: Fri Dec 16, 2005 12:16 am
Location: Michigan
Contact:

Re: SEF links not working when menu items added in JCE

Post by jeffhoneyager » Tue Dec 06, 2022 9:39 am

In JCE Profile Manager - Changed the URL to relative, opened and then saved the module.

All is well. All links are now SEF!

Truly "Tovio" is a Joomla Master.

Thank you sooo much.
Peace & Joy, Jeff Honeyager
http://ExpertWebProfessionals.com
http://Jeff.honeyager.com
"Test Everything, Hold On To The Good."


Post Reply

Return to “Extensions for Joomla! 3.x”