Thousand of error after upgrading from php 7.3 to 8

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
mch79
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Wed Jul 22, 2015 7:25 am

Thousand of error after upgrading from php 7.3 to 8

Post by mch79 » Sun Dec 04, 2022 5:29 am

Hi,

After upgrading from php 7.3 to php 8 in joomla latest version- gettings hunrdres of similar errors in log file where coming as folder in public_html.webp - which never exists

Also i dont have webp enabled as of now in my images so far,

2022-12-04 05:11:34 UTC [nginx][crit] 6908#0: *2524105 openat() "/home/u246-1hyszbvlbl/www/xyz.com/public_html.webp" failed (13: Permission denied), client: 106.79.209.217
request: "GET /images/easyblog_articles/554/b2ap3_medium_MGA-Alloy-Wheel.jpg

error only coming in images
No error in frontend, as site doing fine.
can anyone help on it

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 15443
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Thousand of error after upgrading from php 7.3 to 8

Post by toivo » Sun Dec 04, 2022 8:28 am

Even if the error seems to have something to do with the extension EasyBlog, the message is not originating from Joomla or the third party extension. The failed function openat() is not even part of PHP but probably belongs to Nginx, the web server or Linux, the operating system.

Contact the support team of your host and give them the details of the issue.
Toivo Talikka, Global Moderator


mch79
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Wed Jul 22, 2015 7:25 am

Re: Thousand of error after upgrading from php 7.3 to 8

Post by mch79 » Mon Dec 05, 2022 2:20 pm

Thanks, connected with host and they replied 3 things
a) Server configuration is perfect

b) If no issues on website and fact that public_html.webp folder do not exists then can ignore error_log (As default folder is public_html)

c) They dint have any answer for error and related to joomla component and asked if i feel that server needs some changes - can hire a server developer expert who can check and suggest.

This is what they replied
"Hello, and thank you for contacting our helpdesk.

There isn't anything missing from the nginx configuration.

This is a non-existent file:
/home/xxxxxx/www/xxxxx/public_html.webp


And it also is not a folder.

Most likely some part of the site tried to access this non-existent file/folder, hence the error.

In case the application does work as intended, it should not be worried about, however if you do want to further check it - I would advise you to contact a professional website developer who can help you out with this task."


My Worries
Although there are no errors but Unsure should i actually ignore this error_log file which is like building up for every image showing same errors and entries crossed in several hundred thousands.

Lastly - when i was on joomla 3.9x and on php 7.3 - there was no error. Updated extension and on php 8 with joomla 3.11.x latest and since then this issue is happening in error_log file - should i actually ignore ?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 29641
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Thousand of error after upgrading from php 7.3 to 8

Post by Per Yngve Berg » Tue Dec 06, 2022 8:31 am

Did you have a Mobile App in the past connected to your Joomla Site?

public_html.webp was another virtual host defined in Nginx.

Look for it in the nginx.conf file.

mch79
Joomla! Apprentice
Joomla! Apprentice
Posts: 30
Joined: Wed Jul 22, 2015 7:25 am

Re: Thousand of error after upgrading from php 7.3 to 8

Post by mch79 » Wed Dec 07, 2022 5:50 am

Thanks no mobile app used in past
I was on Cloud server, downgraded to shared one now as lost traffic earlier
thats all. Unfortunately no access to nginx file


Post Reply

Return to “Extensions for Joomla! 3.x”