can't get into Admin because of an extension

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
Argyll45
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Feb 07, 2019 7:35 am

can't get into Admin because of an extension

Post by Argyll45 » Fri Dec 09, 2022 9:29 am

Running joomla 3.11 recently updated and now I get the message

Deprecated: Required parameter $url follows optional parameter $data in /****/*/*/htdocs/***/Joomla/***/plugins/system/antispambycleantalk/classes/Cleantalk.php on line 269

the folk at cleantalk anti spam say I can replace the contents of the cleantalk plugin folder with the new version I had to get. I am not so sure.

guess I am looking for reassurance before taking this step.

Jim

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 24099
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: can't get into Admin because of an extension

Post by pe7er » Fri Dec 09, 2022 2:52 pm

You can disable plugins via the database using phpMyAdmin or another tool.
All extensions are in the #__extensions table.
The enabled field determines if the extension is enabled (1 = yes, 0 = no).

You can also rename the plugin folder so that it won't loaded,
e.g use FTP to rename
/plugins/system/antispambycleantalk/
to
/plugins/system/antispambycleantalk-old/
Kind Regards,
Peter Martin, Global Moderator
Company website: https://db8.nl (Renewed!) - Joomla specialist, Nijmegen, Netherlands
The best website: https://the-best-website.com


Post Reply

Return to “Extensions for Joomla! 3.x”