Issue Updating Community Builder - Claim Joomla Issue

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
insprymedia
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Apr 06, 2011 12:44 pm
Location: Atlanta, Georgia
Contact:

Issue Updating Community Builder - Claim Joomla Issue

Post by insprymedia » Wed Sep 06, 2023 7:00 pm

Hello,

We're having an issue where we cannot update Community Builder from 2.8.0 to 2.8.1 on Joomla 3.10.11. We have tried changing our PHP versions (tried 7.4, 8.0, and 8.1) and we have this issue across all of them. We are getting this error when trying to update the package file: https://app.screencast.com/DUZh7wCJIP16R

Our site is connected to the MySQL database so I'm not sure why this error is showing.

We submitted this issue to Community Builder's support team and they claim this seems like an issue with Joomla in general. See the post here: https://www.joomlapolis.com/forum/profe ... e-to-2-8-1

Can anyone help with this issue or are experiencing the same issue?

Thanks!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 42902
Joined: Sat Apr 05, 2008 9:58 pm

Re: Issue Updating Community Builder - Claim Joomla Issue

Post by Webdongle » Wed Sep 06, 2023 10:09 pm

Could the problem be with your database version?
/**
* Method to check whether the installed database version is supported by the database driver
*
* @return boolean True if the database version is supported
*
* @since 3.0.0
*/
public function isMinimumVersion()
{
return version_compare($this->getVersion(), static::$dbMinimum) >= 0;
}

/**
* Method to get the first row of the result set from the database query as an associative array
* of ['field_name' => 'row_value'].
*
* @return mixed The return value or null if the query failed.
*
* @since 1.7.0
* @throws RuntimeException
*/
public function loadAssoc()
{
$this->connect();

$ret = null;
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 16541
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Issue Updating Community Builder - Claim Joomla Issue

Post by toivo » Wed Sep 06, 2023 10:35 pm

insprymedia wrote:
Wed Sep 06, 2023 7:00 pm
We are getting this error when trying to update the package file
That is a weird error, if everything else, including Community Builder itself, works all right.

Which version of Community Builder was the previous one? Was the error message presented at the very start of the update or later?

Please post the results from the Forum Post Assistant (FPA) by following the instructions at https://forumpostassistant.github.io/docs/ so that the Joomla configuration can be reviewed.
Toivo Talikka, Global Moderator

insprymedia
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Apr 06, 2011 12:44 pm
Location: Atlanta, Georgia
Contact:

Re: Issue Updating Community Builder - Claim Joomla Issue

Post by insprymedia » Thu Sep 07, 2023 7:02 pm

Webdongle wrote:
Wed Sep 06, 2023 10:09 pm
Could the problem be with your database version?
/**
* Method to check whether the installed database version is supported by the database driver
*
* @return boolean True if the database version is supported
*
* @since 3.0.0
*/
public function isMinimumVersion()
{
return version_compare($this->getVersion(), static::$dbMinimum) >= 0;
}

/**
* Method to get the first row of the result set from the database query as an associative array
* of ['field_name' => 'row_value'].
*
* @return mixed The return value or null if the query failed.
*
* @since 1.7.0
* @throws RuntimeException
*/
public function loadAssoc()
{
$this->connect();

$ret = null;
Hi!

Our server uses MariaDB 10.6, which is supported I believe. Let me know if you don't think that's the case though.

toivo wrote:
Wed Sep 06, 2023 10:35 pm
insprymedia wrote:
Wed Sep 06, 2023 7:00 pm
We are getting this error when trying to update the package file
That is a weird error, if everything else, including Community Builder itself, works all right.

Which version of Community Builder was the previous one? Was the error message presented at the very start of the update or later?

Please post the results from the Forum Post Assistant (FPA) by following the instructions at https://forumpostassistant.github.io/docs/ so that the Joomla configuration can be reviewed.
Hey!

We did experience a similar error when updating from the last version of Community Builder. When we updated to 2.8.0, the errors was the same and I thought it could have been a PHP issue. I reverted the PHP version from 8.0 to 7.4 on our server, re-ran the update, and it worked fine. I then updated our server to 8.0 again.

I attempted this process again on this update (2.8.0 to 2.8.1) but it kept giving the same error in my initial post.

Any additional ideas on fixing this or should I proceed with setting up FPA?

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9127
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Issue Updating Community Builder - Claim Joomla Issue

Post by AMurray » Mon Sep 18, 2023 9:51 pm

Yes, @toivo asked you to post the FPA, so please do so - as you haven't done to date, that would be the lack of reason for response to your question and there was no reason to "bump" the post (which is against the forum rules).
Regards - A Murray


Post Reply

Return to “Extensions for Joomla! 3.x”