I was trying to install a component, this is the error

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Locked
User avatar
thehitechpanky
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Wed Jan 04, 2012 5:51 am
Location: India
Contact:

I was trying to install a component, this is the error

Post by thehitechpanky » Thu Mar 28, 2013 12:40 am

Warning: array_key_exists() expects parameter 2 to be array, null given in /home/smilyo/public_html/components/com_payplans/xiframework/base/model.php on line 393

Warning: Invalid argument supplied for foreach() in /home/smilyo/public_html/components/com_payplans/xiframework/base/abstract/factory.php on line 105

Warning: array_key_exists() expects parameter 2 to be array, null given in /home/smilyo/public_html/components/com_payplans/xiframework/base/model.php on line 393

Warning: Invalid argument supplied for foreach() in /home/smilyo/public_html/components/com_payplans/helpers/app.php on line 150

Notice: Undefined property: stdClass::$blockLogging in /home/smilyo/public_html/components/com_payplans/helpers/logger.php on line 17

Fatal error: Cannot access empty property in /home/smilyo/public_html/libraries/joomla/base/object.php on line 194
Please visit our website http://www.smilyo.com and give a lil feedback to help us improve.
Thankyou!

 
User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38597
Joined: Sat Apr 05, 2008 9:58 pm

Re: I was trying to install a component, this is the error

Post by Webdongle » Thu Mar 28, 2013 1:26 am

Check with the extension developer that your php version and database version meets the requirements for their extension ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

User avatar
thehitechpanky
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Wed Jan 04, 2012 5:51 am
Location: India
Contact:

Re: I was trying to install a component, this is the error

Post by thehitechpanky » Thu Mar 28, 2013 2:10 am

Yes my php and db are of latest version
Please visit our website http://www.smilyo.com and give a lil feedback to help us improve.
Thankyou!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38597
Joined: Sat Apr 05, 2008 9:58 pm

Re: I was trying to install a component, this is the error

Post by Webdongle » Thu Mar 28, 2013 3:03 am

thehitechpanky wrote:Yes my php and db are of latest version
But is the extension compatible with the latest version of php and database ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

User avatar
thehitechpanky
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Wed Jan 04, 2012 5:51 am
Location: India
Contact:

Re: I was trying to install a component, this is the error

Post by thehitechpanky » Thu Mar 28, 2013 5:33 am

How can I check that, it is not getting installed, neither im able to uninstall, its stuck in the middle. I can't even check the version :(
Please visit our website http://www.smilyo.com and give a lil feedback to help us improve.
Thankyou!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38597
Joined: Sat Apr 05, 2008 9:58 pm

Re: I was trying to install a component, this is the error

Post by Webdongle » Thu Mar 28, 2013 10:52 am

thehitechpanky wrote:How can I check that, it is not getting installed, neither im able to uninstall, its stuck in the middle. I can't even check the version :(
You can check the version by looking at the file you downloaded or by going to the site you downloaded it from.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

User avatar
thehitechpanky
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Wed Jan 04, 2012 5:51 am
Location: India
Contact:

Re: I was trying to install a component, this is the error

Post by thehitechpanky » Thu Mar 28, 2013 11:12 am

That was long time back.. searched on google... My pc crashed once after that, and I lost the data.
Please visit our website http://www.smilyo.com and give a lil feedback to help us improve.
Thankyou!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38597
Joined: Sat Apr 05, 2008 9:58 pm

Re: I was trying to install a component, this is the error

Post by Webdongle » Thu Mar 28, 2013 11:34 am

thehitechpanky wrote:That was long time back..
Then it probably was written for php and database version that was current at that time. So it may well be incompatible with current versions and that's why you get the database error ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

User avatar
thehitechpanky
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Wed Jan 04, 2012 5:51 am
Location: India
Contact:

Re: I was trying to install a component, this is the error

Post by thehitechpanky » Sun Mar 31, 2013 9:20 am

Now I am getting this error


Warning: array_key_exists() expects parameter 2 to be array, null given in /home/smilyo/public_html/components/com_payplans/xiframework/base/model.php on line 393

Warning: Invalid argument supplied for foreach() in /home/smilyo/public_html/components/com_payplans/xiframework/base/abstract/factory.php on line 105

Warning: array_key_exists() expects parameter 2 to be array, null given in /home/smilyo/public_html/components/com_payplans/xiframework/base/model.php on line 393

Warning: Invalid argument supplied for foreach() in /home/smilyo/public_html/components/com_payplans/helpers/app.php on line 150

Fatal error: Cannot access empty property in /home/smilyo/public_html/libraries/joomla/base/object.php on line 194
Please visit our website http://www.smilyo.com and give a lil feedback to help us improve.
Thankyou!

User avatar
thehitechpanky
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Wed Jan 04, 2012 5:51 am
Location: India
Contact:

Re: I was trying to install a component, this is the error

Post by thehitechpanky » Sun Mar 31, 2013 9:21 am

Just help me uninstall it... so i can try another version
Please visit our website http://www.smilyo.com and give a lil feedback to help us improve.
Thankyou!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38597
Joined: Sat Apr 05, 2008 9:58 pm

Re: I was trying to install a component, this is the error

Post by Webdongle » Sun Mar 31, 2013 12:42 pm

If it installed you can find it in
283.JPG
You do not have the required permissions to view the files attached to this post.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

User avatar
thehitechpanky
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Wed Jan 04, 2012 5:51 am
Location: India
Contact:

Re: I was trying to install a component, this is the error

Post by thehitechpanky » Mon Apr 15, 2013 1:44 pm

It is there, but when I try to uninstall it the error says

Warning: array_key_exists() expects parameter 2 to be array, null given in /home/smilyo/public_html/components/com_payplans/xiframework/base/model.php on line 393

Warning: Invalid argument supplied for foreach() in /home/smilyo/public_html/components/com_payplans/xiframework/base/abstract/factory.php on line 105

Warning: array_key_exists() expects parameter 2 to be array, null given in /home/smilyo/public_html/components/com_payplans/xiframework/base/model.php on line 393

Warning: Invalid argument supplied for foreach() in /home/smilyo/public_html/components/com_payplans/helpers/app.php on line 150

Fatal error: Cannot access empty property in /home/smilyo/public_html/libraries/joomla/base/object.php on line 194
Please visit our website http://www.smilyo.com and give a lil feedback to help us improve.
Thankyou!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 38597
Joined: Sat Apr 05, 2008 9:58 pm

Re: I was trying to install a component, this is the error

Post by Webdongle » Mon Apr 15, 2013 4:22 pm

Perhaps contact the developer of the extension and ask them why their extension broke your site ?

Maybe it's time to restore with a backup ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

 

Locked

Return to “Extensions for Joomla! 3.x”