Page 1 of 1

Random Image module not displaying images

Posted: Wed Apr 10, 2013 1:44 pm
by samyoong
Hey guys, i read like 5 of the past posts that different people post on here and none of the solutions work for me.

Basically, under options I specified image path as "images/my image" but none of the images display neither do the random image module title

(so I've tried removing the forward slash "/" before the keyword 'images' in the image folder path - also tried taking away both " and ")

I'm at a loss - have tried for 40 minutes now

Please help! :(

Re: Random Image module not displaying images

Posted: Wed Apr 10, 2013 5:18 pm
by imanickam
Are you having a directory/folder named "my images"? If so, suggest making it as "myimages" or "my_images" and trying it out.

What is your site's URL so that others can see what is happening?

Re: Random Image module not displaying images

Posted: Thu Apr 11, 2013 4:44 am
by samyoong
Hey, thanks for your reply.

My homepage (it's random content now cos I'm using it to learn stuff) - http://moviesavenue.com

If you go there, you'll see that there's no random image module displayed at all.

Have just renamed my folder to 'myimage' and specified the path in the module to point to "public_html/images/myimage" and public_html/images/myimage (with and without the " and ")
but still no result :(

Re: Random Image module not displaying images

Posted: Thu Apr 11, 2013 4:54 am
by samyoong
My screenshots for the settings that I applied to the module

Image
Image

Re: Random Image module not displaying images

Posted: Thu Apr 11, 2013 5:45 am
by imanickam
The path to the images folder should be relative to the site's URL.

So, suggest using images/myimages (without double quotes).

What are some of the file names in the directory images/myimages?

Re: Random Image module not displaying images

Posted: Thu Apr 11, 2013 2:47 pm
by samyoong
Yea I thought about that too - what would the relative site URL be in my case?
I can't quite figure out - I tried viewing the full path but it's too long with a lot of '%' symbols within the path

Screenshot of my images' file name within the directory itself

Image

Uploaded with ImageShack.us

Re: Random Image module not displaying images

Posted: Thu Apr 11, 2013 4:39 pm
by imanickam
Your domain is pointing to public_html. Hence the relative path to your images is \images\myimage.

Suggest using images\myimage

Check whether appropriate permissions are there for the files in the directory \images\myimage

Note:
I could view the following images with the URLs specified.

Re: Random Image module not displaying images

Posted: Fri Apr 12, 2013 2:23 pm
by samyoong
it worked :)
Thanks! :)