swMenuPro CSS3 breaks SSL website template in IE 11

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
pintobuck
Joomla! Explorer
Joomla! Explorer
Posts: 257
Joined: Tue Mar 06, 2007 9:39 am

swMenuPro CSS3 breaks SSL website template in IE 11

Postby pintobuck » Mon Aug 07, 2017 4:59 pm

I'm using Joomla 3.7.4, Gantry 5 Hydrogen template, swMenuPro 10 with its CSS3 menu system, running on a website hosting service, with a dedicated SSL certificate installed by the hosting service.

swMenuPro is definitely breaking my website when I activate SSL, and I force HTTPS URLs via my web hosting provider.

The problem manifests itself when using MS Internet Explorer 11 or MS Edge browsers, with security set to the default values. Both I.E and Edge break the template when SSL is activated, and pose the question: "Show all content?". If the user answers yes on every page, then the browser will display the website properly. However, that is very off-putting to users that arrive at a broken website and have to answer a question they don't understand, on every page. (To most users, the question seems to be asking if the user wants to display dangerous content.) Please note that the problem goes away if I deactivate the swMenuPro module which uses the CSS3 menu. But, I need the CSS3 menu for mobile devices.

The issue seems to be that I.E and Edge browser detect mixed content containing SSL and non-SSL URLs. So, the browsers pose the question whether to Show All Content or not.

When I view page source, I see that swMenuPro CSS3 menu module created two non-SSL, canonical links as follows:

<script type="text/javascript" src="http://backgroundsearch.com/modules/mod_swmenupro/js/jquery.js"></script>

<link type='text/css' href='http://backgroundsearch.com/modules/mod_swmenupro/styles/menu92.css' rel='stylesheet' />

(I posted this issue on the swMenuPro website 4 months ago, and there has been not response. )

So, one question is: How can we make swMenuPro CSS3 use relative URLs instead of http:// URLs? Or, any other solutions? Thanks.

pintobuck
Joomla! Explorer
Joomla! Explorer
Posts: 257
Joined: Tue Mar 06, 2007 9:39 am

Re: swMenuPro CSS3 breaks SSL website template in IE 11

Postby pintobuck » Tue Aug 08, 2017 1:26 pm

I noticed that swMenuFree and swMenuPro are no longer listed in Joomla.org Extensions Directory. So, maybe the extensions have been abandoned. Temporarily or permanently is unknown.


Return to “Extensions for Joomla! 3.x”

Who is online

Users browsing this forum: Scottyman and 21 guests