Page 1 of 1

Error after extension activate

Posted: Mon Apr 22, 2019 2:15 pm
by terciodejesus
Guys, good morning. I'm doing a simple freelance on a joomla site. It was functioning normally. However, I was adding an extension to include facebook's pixel code and the installation occurred in a normal way.

However, when I activated the facebook pixel, an error happened and now the site no longer works.

The description of the error is:

0 - Call to undefined method JApplicationSite::isClient()

The tutorial of inclusion of the Pixel of the FB I follow here:
https://extensions.joomla.org/extension/facebook-pixel/

This is the site:
http://www.quatroestacoesdecoracoes.com.br/

The version of joomla:
3.x

Re: Error after extension activate

Posted: Mon Apr 22, 2019 4:23 pm
by Webdongle
That is a paid for extension. Suggest you contact their devs. In the meantime recover using the backup that you made before installing the extension. No backup then you can disable the plugin by editing the database (make a database back up first)

viewtopic.php?f=806&t=969442 please

Re: Error after extension activate

Posted: Tue Apr 23, 2019 10:07 am
by AMurray
There have been dozens of updates for the Joomla 3 series - which specific version are you using? i.e. you should be using 3.9.5......

Re: Error after extension activate

Posted: Tue Apr 23, 2019 10:08 am
by AMurray
It could be incompatibility of the extension - e.g. with the PHP version you're using. All that will be listed when you run the FPA and post the report's results, as @Webdongle as requested

Re: Error after extension activate

Posted: Tue Apr 23, 2019 9:26 pm
by terciodejesus
Fixed! All I did was access via FTP and look at plugins '/system/<plugin_name_folder>' and rename the php plugin file to 'officialfacebookpixel.php-off'

Thank you all!

Re: Error after extension activate

Posted: Tue Apr 23, 2019 9:57 pm
by Webdongle
That is not a fix because now you can not uninstall it. Disabling the plugin in the database then uninstall is a fix. Or now you can disable it in /administrator then rename the folder correctly then uninstall.