The anti-spam settings for this website are not yet properly configured

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
Evra531
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Jul 01, 2019 9:43 am

The anti-spam settings for this website are not yet properly configured

Post by Evra531 » Fri Jul 12, 2019 12:36 pm

While using K2, I get the message: "The anti-spam settings for this website are not yet properly configured and comments cannot yet be published. Please notify the site administrator"

Does it mean that my Joomla site has no anti-spam setting, or that I have missed something? How and where is this to be configured?

Kindly advise.
Last edited by imanickam on Fri Jul 12, 2019 1:05 pm, edited 1 time in total.
Reason: Corrected the extension name from KR to K2 and deleted the following two posts that clarified KR as K2.

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4822
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: The anti-spam settings for this website are not yet properly configured

Post by AMurray » Sat Jul 13, 2019 2:27 am

I would say your guess is correct - a captcha is not enabled, so you need to check as below:

On the Global Configuration > Site screen, you can see the Captcha options there.

If the captcha you want to use is not listed (Such as Recaptcha) then either (1) install a relevant plugin, or (2) ensure the Google Recaptcha is enabled (this is included as part of the Joomla core).

If not using Google Recaptcha, there are several listed in the JED that are other sorts of captcha challenges like "what is 2+ 5" (or other random, simple questions like that).

For Google Captcha, be sure you're using the correct secret/site keys for V2 or V3 (each require separate sets of keys).

Do you have anything else in your site that uses captcha - such as a normal contact form, or even your user registration form etc? If so, and a recaptcha works there, it might be just something in K2 that needs to be enabled.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

Evra531
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Jul 01, 2019 9:43 am

Re: The anti-spam settings for this website are not yet properly configured

Post by Evra531 » Sat Jul 13, 2019 9:55 am

Thanks, Murray. I had already realized it and fixed the Recaptcha. Thanks for your note, as it assures that what I did is the right thing, and not some freaky temporary solution. Cheers :)


Post Reply

Return to “Extensions for Joomla! 3.x”