Error upgrading gantry 5 from 5.4.28 to 5.4.29

This forum is for general questions about extensions for Joomla! 3.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
il_cipo
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Apr 13, 2010 5:01 pm

Error upgrading gantry 5 from 5.4.28 to 5.4.29

Post by il_cipo » Wed Jul 17, 2019 9:38 pm

Hi guys
hope this is the right section for my question.
I have been reading lots of stuff around but I don't manage to find a solution to my problem.
When I upgrade (from within Joomla backend) to the latest gantry I get this error:

Access denied for user 'user1'@'localhost' to database 'db1'
Package Update: There was an error installing an extension: com_gantry5_v5.4.29.zip
Before updating ensure that the update is compatible with your Joomla! installation.
You are strongly advised to make a backup of your installation before you start updating.

I checked the DB and all users/rights are OK. I did manually check them.
All the access rights on the installation files seem ok.
I attach the full FPA snapshot for your review (https://we.tl/t-QuryY2d30C)
I can't attach the file because it seems too big (even if only 800KB).

Any idea or help?
THX
CIPO

User avatar
paulala
Joomla! Explorer
Joomla! Explorer
Posts: 301
Joined: Sat Oct 30, 2010 12:32 pm
Location: Scotland
Contact:

Re: Error upgrading gantry 5 from 5.4.28 to 5.4.29

Post by paulala » Thu Jul 18, 2019 7:50 am

Are you trying to update gantry via the button in Gantry or through the Joomla extensions area?
Warm Regards,
Paula Livingstone, Skydiving Instructor and Network Security Consultant
https://paulalivingstone.com
http://rustyice.co.uk

il_cipo
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Apr 13, 2010 5:01 pm

Re: Error upgrading gantry 5 from 5.4.28 to 5.4.29

Post by il_cipo » Thu Jul 18, 2019 8:04 am

Hi Paula.
Through Extension->Manage->Intall of my Joomla backend. Which is the usual way I do once I enter my admin panel and I land on the System/Control Panel.
I also tried to manually upload the Gantry ZIP package (exactly the one reported in the above error message) and then run the update from "Install from a folder" (after unzipping it) and also "Upload package file". All failed with the same above error. THX for help.

User avatar
paulala
Joomla! Explorer
Joomla! Explorer
Posts: 301
Joined: Sat Oct 30, 2010 12:32 pm
Location: Scotland
Contact:

Re: Error upgrading gantry 5 from 5.4.28 to 5.4.29

Post by paulala » Thu Jul 18, 2019 8:06 am

Could you post an FPA please? https://forumpostassistant.github.io/docs/
Warm Regards,
Paula Livingstone, Skydiving Instructor and Network Security Consultant
https://paulalivingstone.com
http://rustyice.co.uk

il_cipo
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Apr 13, 2010 5:01 pm

Re: Error upgrading gantry 5 from 5.4.28 to 5.4.29

Post by il_cipo » Thu Jul 18, 2019 8:12 am

I did it, in the link I posted (wetransfer)

User avatar
paulala
Joomla! Explorer
Joomla! Explorer
Posts: 301
Joined: Sat Oct 30, 2010 12:32 pm
Location: Scotland
Contact:

Re: Error upgrading gantry 5 from 5.4.28 to 5.4.29

Post by paulala » Thu Jul 18, 2019 8:14 am

Ah I don't think many people are going to download a file from there to see this.
Warm Regards,
Paula Livingstone, Skydiving Instructor and Network Security Consultant
https://paulalivingstone.com
http://rustyice.co.uk

il_cipo
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Apr 13, 2010 5:01 pm

Re: Error upgrading gantry 5 from 5.4.28 to 5.4.29

Post by il_cipo » Thu Jul 18, 2019 8:28 am

Right :)
here it is
Forum Post Assistant (v1.4.9 (lambrusca) : 18th July 2019 wrote:
Last PHP Error(s) Reported :: wrote:[18-Jul-2019 04:19:55 UTC] PHP Notice: Array to string conversion in /home/lghosxmy/public_html/plugins/system/plugin_googlemap3/plugin_googlemap3_helper.php on line 293
Basic Environment :: wrote:Joomla! Instance :: Joomla! 3.9.8-Stable (Amani) 11-June-2019
Joomla! Platform :: Joomla Platform 13.1.0-Stable (Curiosity) 24-Apr-2013
Joomla! Configured :: Yes | Read-Only (444) | Owner: --protected-- . (uid: 1/gid: 1) | Group: --protected-- (gid: 1) | Valid For: 3.9
Configuration Options :: Offline: false | SEF: true | SEF Suffix: false | SEF ReWrite: true | .htaccess/web.config: Yes | GZip: false | Cache: true | CacheTime: 15 | CacheHandler: file | CachePlatformPrefix: true | FTP Layer: false | Proxy: false | LiveSite: http://skudo.tech | Session lifetime: 15 | Session handler: none | Shared sessions: false | SSL: 0 | Error Reporting: maximum | Site Debug: true | Language Debug: false | Default Access: 1 | Unicode Slugs: false | dbConnection Type: mysqli | PHP Supports J! 3.9.8: Yes | Database Supports J! 3.9.8: Yes | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 2.6.32-754.14.2.el6.x86_64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate, br | Doc Root: --protected-- | System TMP Writable: Yes | Free Disk Space : 5.69 GiB |

PHP Configuration :: Version: 7.1.30 | PHP API: cgi-fcgi | Session Path Writable: Yes | Display Errors: | Error Reporting: 32759 | Log Errors To: error_log | Last Known Error: 18th July 2019 04:19:55. | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: | Open Base: | Uploads: 1 | Max. Upload Size: 256M | Max. POST Size: 256M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 384M

Database Configuration :: Version: 5.7.26 (Client:mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $) | Host: --protected-- (--protected--) | default Collation: latin1_swedish_ci (default Character Set: latin1) | Database Size: 16.60 MiB | #of Tables:  110
Detailed Environment :: wrote:PHP Extensions :: Core (7.1.30) | date (7.1.30) | libxml (7.1.30) | openssl (7.1.30) | pcre (7.1.30) | zlib (7.1.30) | filter (7.1.30) | hash (1.0) | pcntl (7.1.30) | readline (7.1.30) | Reflection (7.1.30) | SPL (7.1.30) | session (7.1.30) | standard (7.1.30) | cgi-fcgi () | bcmath (7.1.30) | calendar (7.1.30) | ctype (7.1.30) | curl (7.1.30) | dom (20031129) | mbstring (7.1.30) | ftp (7.1.30) | gd (7.1.30) | gettext (7.1.30) | imap (7.1.30) | json (1.5.0) | exif (7.1.30) | mcrypt (7.1.30) | mysqlnd (mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $) | PDO (7.1.30) | Phar (2.0.2) | posix (7.1.30) | pspell (7.1.30) | SimpleXML (7.1.30) | soap (7.1.30) | sockets (7.1.30) | sqlite3 (7.1.30) | tidy (7.1.30) | tokenizer (7.1.30) | xml (7.1.30) | xmlwriter (7.1.30) | xsl (7.1.30) | zip (1.13.5) | mysqli (7.1.30) | pdo_mysql (7.1.30) | pdo_sqlite (7.1.30) | wddx (7.1.30) | xmlreader (7.1.30) | xmlrpc (7.1.30) | Zend Engine (3.1.0) |
Potential Missing Extensions :: iconv |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): Yes
Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (---) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (755) |

Elevated Permissions (First 10) :: tmp/language/ (777) | tmp/language/en-GB/ (777) | tmp/packages/ (777) |
Database Information :: wrote:Database statistics :: Uptime: 86543 | Threads: 1 | Questions: 40055 | Slow queries: 0 | Opens: 7020 | Flush tables: 1 | Open tables: 1811 | Queries per second avg: 0.462 |
Extensions Discovered :: wrote:Components :: SITE ::
Core :: com_mailto (3.0.0) 1 | com_wrapper (3.0.0) 1 |
3rd Party::

Components :: ADMIN ::
Core :: com_content (3.0.0) 1 | com_categories (3.0.0) 1 | com_fields (3.7.0) 1 | com_config (3.0.0) 1 | com_finder (3.0.0) 1 | com_admin (3.0.0) 1 | com_menus (3.0.0) 1 | com_cache (3.0.0) 1 | com_templates (3.0.0) 1 | com_newsfeeds (3.0.0) 1 | com_plugins (3.0.0) 1 | com_installer (3.0.0) 1 | com_languages (3.0.0) 1 | com_banners (3.0.0) 1 | com_actionlogs (3.9.0) 1 | com_redirect (3.0.0) 1 | com_privacy (3.9.0) 1 | com_cpanel (3.0.0) 1 | com_associations (3.7.0) 1 | com_tags (3.1.0) 1 | com_checkin (3.0.0) 1 | com_messages (3.0.0) 1 | com_media (3.0.0) 1 | com_joomlaupdate (3.6.2) 1 | com_modules (3.0.0) 1 | com_users (3.0.0) 1 | com_contenthistory (3.2.0) 1 | com_search (3.0.0) 1 | com_login (3.0.0) 1 | com_postinstall (3.2.0) 1 | com_ajax (3.2.0) 1 |
3rd Party:: COM_FOXCONTACT (3.8.2) 1 | com_xmap (2.3.4) 1 | com_gantry5 (5.4.29) 1 | com_rsform (2.0.15) 1 | Akeeba (6.3.1) 1 | com_phocaemail (3.0.5) 1 |

Modules :: SITE ::
Core :: mod_articles_categories (3.0.0) 1 | mod_stats (3.0.0) 1 | mod_breadcrumbs (3.0.0) 1 | mod_login (3.0.0) 1 | mod_languages (3.5.0) 1 | mod_finder (3.0.0) 1 | mod_articles_latest (3.0.0) 1 | mod_tags_popular (3.1.0) 1 | mod_footer (3.0.0) 1 | mod_search (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_users_latest (3.0.0) 1 | mod_whosonline (3.0.0) 1 | mod_articles_popular (3.0.0) 1 | mod_banners (3.0.0) 1 | mod_wrapper (3.0.0) 1 | mod_articles_category (3.0.0) 1 | mod_articles_archive (3.0.0) 1 | mod_articles_news (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_random_image (3.0.0) 1 | mod_related_items (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_tags_similar (3.1.0) 1 | mod_syndicate (3.0.0) 1 |
3rd Party:: PopUp Aholic (1.3.1) 1 | mod_gantry5_particle (5.4.29) 1 | RokAjaxSearch (2.0.6) 1 | Easy Joomla PayPal Payment / Donati (2.5.0) ? | MOD_FOXCONTACT (3.8.2) 1 |

Modules :: ADMIN ::
Core :: mod_status (3.0.0) 1 | mod_sampledata (3.8.0) 1 | mod_latest (3.0.0) 1 | mod_login (3.0.0) 1 | mod_privacy_dashboard (3.9.0) 1 | mod_toolbar (3.0.0) 1 | mod_version (3.0.0) 1 | mod_multilangstatus (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_submenu (3.0.0) 1 | mod_popular (3.0.0) 1 | mod_latestactions (3.9.0) 1 | mod_custom (3.0.0) 1 | mod_quickicon (3.0.0) 1 | mod_stats_admin (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_logged (3.0.0) 1 | mod_title (3.0.0) 1 |
3rd Party::

Libraries ::
Core ::
3rd Party:: FOF30 (3.1.2) 1 |

Plugins ::
Core :: plg_user_joomla (3.0.0) 1 | plg_user_contactcreator (3.0.0) 0 | plg_user_profile (3.0.0) 0 | plg_user_terms (3.9.0) 0 | plg_fields_user (3.7.0) 1 | plg_fields_integer (3.7.0) 1 | plg_fields_imagelist (3.7.0) 1 | plg_fields_color (3.7.0) 1 | plg_fields_repeatable (3.9.0) 1 | plg_fields_calendar (3.7.0) 1 | plg_fields_textarea (3.7.0) 1 | plg_fields_editor (3.7.0) 1 | plg_fields_list (3.7.0) 1 | plg_fields_checkboxes (3.7.0) 1 | plg_fields_media (3.7.0) 1 | plg_fields_url (3.7.0) 1 | plg_fields_usergrouplist (3.7.0) 1 | plg_fields_radio (3.7.0) 1 | plg_fields_text (3.7.0) 1 | plg_fields_sql (3.7.0) 1 | plg_installer_webinstaller (2.0.1) 1 | plg_installer_packageinstaller (3.6.0) 1 | PLG_INSTALLER_FOLDERINSTALLER (3.6.0) 1 | PLG_INSTALLER_URLINSTALLER (3.6.0) 1 | PLG_ACTIONLOG_JOOMLA (3.9.0) 1 | plg_system_fields (3.7.0) 1 | plg_system_languagefilter (3.0.0) 0 | PLG_SYSTEM_ACTIONLOGS (3.9.0) 0 | plg_system_logout (3.0.0) 1 | plg_system_debug (3.0.0) 1 | plg_system_stats (3.5.0) 1 | plg_system_logrotation (3.9.0) 1 | plg_system_log (3.0.0) 1 | plg_system_cache (3.0.0) 0 | plg_system_updatenotification (3.5.0) 1 | plg_system_remember (3.0.0) 1 | plg_system_privacyconsent (3.9.0) 0 | plg_system_highlight (3.0.0) 1 | plg_system_sef (3.0.0) 1 | plg_system_redirect (3.0.0) 0 | plg_system_p3p (3.0.0) 0 | plg_system_languagecode (3.0.0) 0 | plg_system_sessiongc (3.8.6) 1 | plg_twofactorauth_yubikey (3.2.0) 0 | plg_twofactorauth_totp (3.2.0) 0 | plg_privacy_user (3.9.0) 1 | plg_privacy_consents (3.9.0) 1 | plg_privacy_actionlogs (3.9.0) 1 | plg_privacy_message (3.9.0) 1 | plg_privacy_content (3.9.0) 1 | plg_editors-xtd_fields (3.7.0) 1 | plg_editors-xtd_readmore (3.0.0) 1 | plg_editors-xtd_image (3.0.0) 1 | plg_editors-xtd_module (3.5.0) 1 | plg_editors-xtd_article (3.0.0) 1 | plg_editors-xtd_pagebreak (3.0.0) 1 | plg_editors-xtd_menu (3.7.0) 1 | plg_captcha_recaptcha (3.4.0) 0 | plg_captcha_recaptcha_invisible (3.8) 0 | plg_finder_newsfeeds (3.0.0) 1 | plg_finder_categories (3.0.0) 1 | plg_finder_contacts (3.0.0) 1 | plg_finder_content (3.0.0) 1 | plg_finder_tags (3.0.0) 1 | plg_search_newsfeeds (3.0.0) 1 | plg_search_categories (3.0.0) 1 | plg_search_contacts (3.0.0) 1 | plg_search_content (3.0.0) 1 | plg_search_tags (3.0.0) 1 | plg_content_fields (3.7.0) 1 | plg_content_pagenavigation (3.0.0) 1 | plg_content_confirmconsent (3.9.0) 0 | plg_content_joomla (3.0.0) 1 | plg_content_emailcloak (3.0.0) 1 | plg_content_finder (3.0.0) 0 | plg_content_vote (3.0.0) 1 | plg_content_pagebreak (3.0.0) 1 | plg_content_loadmodule (3.0.0) 1 | plg_quickicon_joomlaupdate (3.0.0) 1 | plg_quickicon_phpversioncheck (3.7.0) 1 | plg_quickicon_extensionupdate (3.0.0) 1 | plg_quickicon_privacycheck (3.9.0) 1 | plg_extension_joomla (3.0.0) 1 | plg_authentication_joomla (3.0.0) 1 | plg_authentication_gmail (3.0.0) 0 | plg_authentication_ldap (3.0.0) 0 | plg_authentication_cookie (3.0.0) 1 |
3rd Party:: plg_installer_rsform (1.0.0) 1 | PLG_SYSTEM_DD_GOOGLE_ANALYTICS (1.0.0.2) 0 | System - RSForm! Pro Delete Submiss (1.0.0) ? | System - Google Maps (3.3) 1 | plg_system_gantry5 (5.4.29) 1 | PLG_SYSTEM_AKEEBAUPDATECHECK (1.1) 0 | PLG_SYSTEM_BACKUPONUPDATE (3.7) 0 | System - RokBooster (1.1.18) 0 | plg_gantry5_preset (5.4.29) 1 | RokPad (2.1.10) 1 | plg_editors_codemirror (5.40.0) 1 | plg_editors_tinymce (4.5.11) 1 | plg_content_foxcontact (3.8.2) 1 | plg_quickicon_gantry5 (5.4.29) 1 | plg_quickicon_akeebabackup (1.0) 1 | Xmap - Content Plugin (2.0.4) 1 | Xmap - WebLinks Plugin (2.0.1) 1 | Xmap - Virtuemart Plugin (2.0.3) 0 | Xmap - SobiPro Plugin (2.0.2) 0 | XMAP_PLUGIN_K2 (1.3) 0 | Xmap - Mosets Tree Plugin (2.0.2) 0 | Xmap - Kunena Plugin (3.0.0) 0 |
Templates Discovered :: wrote:Templates :: SITE :: protostar (1.0) 1 | beez3 (3.1.0) 1 | rt_xenon (1.3.0) 1 |
Templates :: ADMIN :: isis (1.0) 1 | hathor (3.0.0) 1 |
Last edited by imanickam on Thu Jul 18, 2019 4:16 pm, edited 1 time in total.
Reason: Disabled smilies

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 5056
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Error upgrading gantry 5 from 5.4.28 to 5.4.29

Post by AMurray » Thu Jul 18, 2019 9:15 am

When I go to Gantry's download page it takes me to the download for the "package" and not singularly the "com_gantry5_v5.4.29.zip". Or are you saying, it gets part way through then gives you that access denied error?

I believe you should install joomla-pkg_gantry5_v5.4.29.

If you have checked the database user and login, then I don't know why you still get the "access denied" error - as that's a MySQL error not Joomla.

I hope the real creditials for your database are not user1'@'localhost' to database 'db1' (I will assume they have been changed for the purpose of posting the error in your question to avoid putting real details in this post).
FPA wrote:[18-Jul-2019 04:19:55 UTC] PHP Notice: Array to string conversion in /home/lghosxmy/public_html/plugins/system/plugin_googlemap3/plugin_googlemap3_helper.php on line 293
.
Error above seems unrelated to the other. Perhaps try disabling this one for the time being - or update it? It would also be curious to see if any other extension update comes up with that same access denied error.
FPA wrote:levated Permissions (First 10) :: tmp/language/ (777) | tmp/language/en-GB/ (777) | tmp/packages/ (777) |
These elevated permissions should be 755 not 777.

Finally: It seems Gantry is already at the latest version, so why the need to update? Did you resolve this since you posted your question?
FPA wrote:3rd Party:: COM_FOXCONTACT (3.8.2) 1 | com_xmap (2.3.4) 1 | com_gantry5 (5.4.29) 1 | com_rsform (2.0.15) 1 | Akeeba (6.3.1) 1 | com_phocaemail (3.0.5) 1 |
If you just read through the FPA report you can see the other related Gantry extensions - plugins and modules are all showing version 5.4.29.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

il_cipo
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Apr 13, 2010 5:01 pm

Re: Error upgrading gantry 5 from 5.4.28 to 5.4.29

Post by il_cipo » Thu Jul 18, 2019 10:33 am

AMurray wrote:
Thu Jul 18, 2019 9:15 am
When I go to Gantry's download page it takes me to the download for the "package" and not singularly the "com_gantry5_v5.4.29.zip". Or are you saying, it gets part way through then gives you that access denied error?
I believe you should install joomla-pkg_gantry5_v5.4.29.
I started doing the update via Joomla backend because Joomla was (is) saying that Gantry needs to be updated. So I select the package (from within Joomla package update) and press update. Then I get the above error which mentions the ZIP package. So next I went to Gantry homepage and downloaded what I thought (still think) was the right package and tried a more manual update still via the Joomla backend (update via ZIP package). All the time failing.
When it fails (with the mentioned error) then my site goes down and reporting this message "Failed to load 'rt_xenon' template: Please install Gantry 5 Framework!".

To fix it I go to extension - manage -manage, select all Gantry items and enable them back.
All items seem update except one "the package" which is still at the old version. See pic Image
The Rockettheme support is telling me that I should get a full error-free update. In fact, Joomla still tells me I need to update Gantry (the package is still the old version).
AMurray wrote:
Thu Jul 18, 2019 9:15 am
If you have checked the database user and login, then I don't know why you still get the "access denied" error - as that's a MySQL error not Joomla.
Exactly, it puzzles me because I don't get such error when I access the DB via SSH.
AMurray wrote:
Thu Jul 18, 2019 9:15 am
I hope the real creditials for your database are not user1'@'localhost' to database 'db1' (I will assume they have been changed for the purpose of posting the error in your question to avoid putting real details in this post).
Correct, I did that to avoid posting real info :)
AMurray wrote:
Thu Jul 18, 2019 9:15 am
Error above seems unrelated to the other. Perhaps try disabling this one for the time being - or update it? It would also be curious to see if any other extension update comes up with that same access denied error.
Correct, completely unrelated and will fix it separately.

So, right now Joomla keeps telling me that Gantry is not updated and I get the DB access error every time I try to update it via Joomla.
thx
You do not have the required permissions to view the files attached to this post.

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 5056
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Error upgrading gantry 5 from 5.4.28 to 5.4.29

Post by AMurray » Sat Jul 20, 2019 4:17 am

Yet, I see in that list all the associated extensions with Gantry showing v 5.4.29. Maybe just a caching issue?

Can you uninstall, and reinstall the entire Gantry package?
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

il_cipo
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Apr 13, 2010 5:01 pm

Re: Error upgrading gantry 5 from 5.4.28 to 5.4.29

Post by il_cipo » Sat Jul 20, 2019 10:29 am

AMurray wrote:
Sat Jul 20, 2019 4:17 am
Yet, I see in that list all the associated extensions with Gantry showing v 5.4.29. Maybe just a caching issue?

Can you uninstall, and reinstall the entire Gantry package?
The admin support at Rockettheme tried that already on my site and didn't help:
https://rockettheme.com/forum/joomla-te ... 20#1412797

THX

il_cipo
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Tue Apr 13, 2010 5:01 pm

Re: Error upgrading gantry 5 from 5.4.28 to 5.4.29

Post by il_cipo » Mon Jul 22, 2019 2:21 pm

Problem solved.
It was related to phpmyadmin and the name of the DB. My cPanel and phpmyadmin need the prefix of the name to be the same as my ISP hosting account username ... my phpmyadmin didn't pick my DB automatically so I did all testing via SSH but it seems that the problem was also preventing my Gantry to update through the access right error.
So I created a new DB with the correct name, loaded the DB from the older DB (thus renaming it) and that's it. It now works :)


Post Reply

Return to “Extensions for Joomla! 3.x”