Installion resets itself on IIS

This forum is for issues with installing Joomla! 3.x on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
mckinnonk
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Apr 12, 2017 10:11 pm

Installion resets itself on IIS

Postby mckinnonk » Thu Apr 13, 2017 2:27 pm

Increasing max_execution_time did not work for me. Continues to loop, no errors, no indication what could possibly be the problem.
Last edited by mandville on Sun Apr 16, 2017 7:22 pm, edited 1 time in total.

User avatar
AMurray
Joomla! Hero
Joomla! Hero
Posts: 2992
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Installion resets itself

Postby AMurray » Fri Apr 14, 2017 6:17 am

Maybe other php settings you haven't considered?

  • upload_max_filesize (try at least 20M)

  • post_max_size (try at least 20M)

  • memory_limit (try at least 128M).
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

mckinnonk
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Apr 12, 2017 10:11 pm

Re: Installion resets itself

Postby mckinnonk » Sat Apr 15, 2017 11:47 pm

Nope, I've considered and increased them all. I have all green status on third step and it still loops with multiple browsers.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33631
Joined: Sat Apr 05, 2008 9:58 pm

Re: Installion resets itself

Postby Webdongle » Sun Apr 16, 2017 12:59 am

http://forum.joomla.org/viewtopic.php?f=621&t=582860 please

It could be a 'Ownership' issue depending on the stack you use.

mckinnonk
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Apr 12, 2017 10:11 pm

Re: Installion resets itself

Postby mckinnonk » Sun Apr 16, 2017 4:59 am

Care to elaborate. Are you referring to a permissions issue, as in file ownership?

I'm not sure what FPA has to do with my post, as I don't have a working site yet. Did you make a mistake on your link?

Again my stack is:
Server 2016, SQL Express 2016, PHP7

All green on install, no errors reported by php. I think Joomla is not compatible with this stack. Perhaps the upcoming release will be.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 23725
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Installion resets itself

Postby Per Yngve Berg » Sun Apr 16, 2017 9:24 am

Are you using MS SQL Server and not MySQL?

You are in the wrong forum for installing joomla on an IIS Web Server.
https://forum.joomla.org/viewforum.php?f=717

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33631
Joined: Sat Apr 05, 2008 9:58 pm

Re: Installion resets itself

Postby Webdongle » Sun Apr 16, 2017 11:21 am

mckinnonk wrote:Care to elaborate. ...
If you dont understand the explantion in the fpa thread then I doubt I could explain it in a way that you understand. Perhaps ask your parents or a teacher what it means by
The Forum Post Assistant (FPA) script has been developed to assist forum posters to be able to post relevant system, instance, PHP and troubleshooting information directly in to a pre-formatted forum post. This will save a few hours of posting back and forth, asking for, and explaining how to acquire useful information in order for other forum users to help troubleshoot a problem.
This process also means that consistent information is gathered and presented in every case, enabling helpers to quickly target information relevant to the specific problem observed by the user.




mckinnonk wrote:... Are you referring to a permissions issue, as in file ownership?

....
Not as such ... I am referring to file Ownership not the Permissions assigned to the users



mckinnonk wrote:...
I'm not sure what FPA has to do with my post, as I don't have a working site yet. Did you make a mistake on your link?....
Again ... Perhaps ask your parents or a teacher to explain it to you.


mckinnonk wrote:...
Again my stack is:
Server 2016, SQL Express 2016, PHP7....
The fpa will provide more information.

mckinnonk
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Apr 12, 2017 10:11 pm

Re: Installion resets itself

Postby mckinnonk » Sun Apr 16, 2017 6:49 pm

I'm an IT founder with 30 years of experience, I know what FPA is and it has no bearing on my situation. Your very insulting to assume that I need ask a teacher, as I've been mentoring IT Experts for longer than you've been alive, most likely.

Although my experience with PHP is somewhat limited as I'm mostly in IT Management and don't dig in much.
Last edited by mckinnonk on Sun Apr 16, 2017 6:54 pm, edited 1 time in total.

mckinnonk
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Apr 12, 2017 10:11 pm

Re: Installion resets itself

Postby mckinnonk » Sun Apr 16, 2017 6:51 pm

Per Yngve Berg wrote:Are you using MS SQL Server and not MySQL?

You are in the wrong forum for installing joomla on an IIS Web Server.
https://forum.joomla.org/viewforum.php?f=717


Yes, I should have posted there. However, it's not an IIS problem.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33631
Joined: Sat Apr 05, 2008 9:58 pm

Re: Installion resets itself

Postby Webdongle » Sun Apr 16, 2017 8:55 pm

mckinnonk wrote:I'm an IT founder with 30 years of experience, I know what FPA is and it has no bearing on my situation. ...
If you knew what the problem was then you wouldn't need to post on here for help. Without you running the fpa and posting the results on here then those who are trying to help you will not be able to know if it shows a configuration error.

mckinnonk wrote:Although my experience with PHP is somewhat limited as I'm mostly in IT Management and don't dig in much
The fpa often shows the php errors which in turn helps locate the source of the problem

mckinnonk wrote:Yes, I should have posted there. However, it's not an IIS problem.
Joomla installs successfully on many server configurations therefore it is reasonable to conclude that the problem is with the server not being configured in a way that suits the installation.

mckinnonk
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Apr 12, 2017 10:11 pm

Re: Installion resets itself

Postby mckinnonk » Sun Apr 16, 2017 11:16 pm

Joomla installs successfully on many server configurations therefore it is reasonable to conclude that the problem is with the server not being configured in a way that suits the installation.


It's reasonable, but not always the case. Most people using php use mysql and apache. I'm using the newest Windows server, with the newest Microsoft SQL, and almost the newest PHP. It's reasonable that Joomla is buggy in this environment, since few people use this configuation.

I have attached my FPA results, which will not help in my situation.
You do not have the required permissions to view the files attached to this post.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33631
Joined: Sat Apr 05, 2008 9:58 pm

Re: Installion resets itself

Postby Webdongle » Mon Apr 17, 2017 12:34 am

mckinnonk wrote:... Most people using php use mysql and apache. I'm using the newest Windows server, with the newest Microsoft SQL, and almost the newest PHP. It's reasonable that Joomla is buggy in this environment, since few people use this configuation.....
Yep and there are few in bugsquad that use any windows server.


Did you have difficulty understanding the instructions on how to generate the fpa output in a format for the forum ?

Anyway from the html of the fpa page you attached
Doc Root: E:/Joomla
Server Temp: C:\Windows\TEMP
Server Temp Writable: No
looks like the problem. If it is then get ready for a big 'told you so 8 posts ago'
Webdongle wrote:http://forum.joomla.org/viewtopic.php?f=621&t=582860 please

It could be a 'Ownership' issue depending on the stack you use.



Addendum
Session Path Writable: No
might also cause problems.

mckinnonk
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Apr 12, 2017 10:11 pm

Re: Installion resets itself

Postby mckinnonk » Mon Apr 17, 2017 1:38 am

[
Did you have difficulty understanding the instructions on how to generate the fpa output in a format for the forum ?


No, I chose to attach it. I hate long posts of code; attaching makes more sense. Also, I remote into my work computer and save the output in dropbox.

Do you have difficulty providing support without being insulting? Your passive aggressiveness can cause many people to stop posting or not post at all. It's really turning me off of trying Joomla.

If it is then get ready for a big 'told you so 8 posts ago


Good find, but didn't fix the problem. So, no you haven't told me so.
You do not have the required permissions to view the files attached to this post.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33631
Joined: Sat Apr 05, 2008 9:58 pm

Re: Installion resets itself

Postby Webdongle » Mon Apr 17, 2017 8:44 am

mckinnonk wrote:...
No, I chose to attach it. I hate long posts of code; attaching makes more sense. ...
It is easier to read the output in the forum ... if you cant be bothered to copy/paste the (fpa) generated output then I cant be bothered to download and unpack attached files.



mckinnonk wrote:...
Do you have difficulty providing support without being insulting? Your passive aggressiveness can cause many people to stop posting or not post at all. ...
No. I just choose to highlight your arrogance and your inability to help yourself. It took numerous posts to get you to run the fpa and even then you choose to be stubborn and refuse to post the results in a format which is readable directly in the thread. All those extra posts to discover a simple mistake in your server setup. Your uncooperative nature makes it difficult for others to help you. I wish you luck finding someone prepared to give their time helping you find other problems with your server setup.


Return to “Joomla! 3.x on IIS webserver”

Who is online

Users browsing this forum: No registered users and 3 guests