White page!

This forum is for issues with installing Joomla! 3.x on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

White page!

Postby Rickardo » Thu Jun 22, 2017 9:42 am

When I click on my "Contact Us" page I'm getting a white page.
Sometimes I get the contact form with this error message then if I click on the link again it goes back to white.

Warning
JCacheStorageFile::_deleteFolder Failed deleting 7cf231b7577e540fe90617bb9cf9f794-cache-page-d9c72ac7b40e7a165c1b5eb5f9d67cfc.php


Please help or I fear I will pull all my hair out!

The site is mourned.sa.edu.au

Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

Site down

Postby Rickardo » Thu Jun 22, 2017 10:05 am

I've wrecked my site. I tried to change the cache settings and now I can't access the site front-end.

In the cache settings I don't have the file option anymore.

Please help

http://www.muirden.sa.edu.au
Last edited by toivo on Thu Jun 22, 2017 10:52 am, edited 1 time in total.
Reason: mod note: merged with the previous topic, please keep the issues and actions in one topic

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3147
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: White page!

Postby ribo » Thu Jun 22, 2017 10:16 am

Go to joomla backend and check in System-System Information-Folder Permissions , cache (Cache Folder) and administrator/cache (Cache Folder) if they are Unwritable. All folders except configuration.php must be Writable. If you have folders with permission 755 and you see them Unwritable, then you have permission issue in your host server and your host must fix it.
chat room spontes : http://www.spontes.com

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3256
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: White page!

Postby AMurray » Thu Jun 22, 2017 10:22 am

Rickardo,

This is apparently the same as your other question - viewtopic.php?f=706&t=952026 (in this you mention your lack of faith in the hosting you are forced to be using...).

Sounds strange if not the same host or server to have two in a row that come up with the same problem.

Sorry, I can't offer any further advice other than what my posts said in your other question.

[edit] To top this off, the URL you quoted results in "Server not found".

Code: Select all

mourned.sa.edu.au
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

Re: White page!

Postby Rickardo » Thu Jun 22, 2017 10:25 am

Hello, yes, I'm still having issues. Now I've crashed it.
I tried to change the cache settings, big mistake!
Now I get this message-
0 The file Cache Storage is not supported on this platform.

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3256
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: White page!

Postby AMurray » Thu Jun 22, 2017 10:30 am

You can turn off caching options for Joomla in the configuration.phpfile (in the Joomla directory where you have your site). Try this for the other one as well.

open "configuration.php" in a text editor (suggest Notepad++).

around lines 10, 11, 12 find these settings:

Code: Select all

public $cache_handler = 'file';
   public $cachetime = '15';
   public $caching = '1';


Change them to

Code: Select all

public $cache_handler = 'none';
   public $cachetime = '0';
   public $caching = '0';


See what happens; if it mucks it up further, restore the original settings but putting the original values back in.

Also you might be able to disable plugins through the database, but I don't know what access you have to something like PHPMyAdmin or similar tool.

If I'm wrong in my assumptions here hopefully someone will correct me.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3147
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: White page!

Postby ribo » Thu Jun 22, 2017 10:38 am

Session Path Writable: No . This must be yes. Talk to your host. Generally i advice you to find a joomla friendly host and to no be to a windows host.
chat room spontes : http://www.spontes.com

Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

Re: White page!

Postby Rickardo » Thu Jun 22, 2017 10:41 am

Thanks but no luck there.
In the Folder Permissions it says the configuration.php is unwritable.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3147
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: White page!

Postby ribo » Thu Jun 22, 2017 10:42 am

All the folders are writable?
chat room spontes : http://www.spontes.com

Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

Re: White page!

Postby Rickardo » Thu Jun 22, 2017 10:46 am

Yes Ribo, thanks,I tried to get them to use a different Joomla friendly host. I'm not happy with the hosting but I'm not the boss unfortunately. The configuration.php and the cache are not writable.

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3256
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: White page!

Postby AMurray » Thu Jun 22, 2017 10:49 am

You should be able to make configuration.php writeable.

Assuming that on a Windows Server running IIS, you can still (in Windows Explorer) right click the file, go to Properties on the context menu, towards the bottom of the dialogue and change the status from "read only" to writeable (uncheck the checkbox under the Attributes section)

Forgive me for being off the beaten track if so 8)

file_properties.PNG


That is, if you have such access in the Windows Server (via Windows Explorer). This is a simple file operation, so shouldn't be too hard to do ???

Sorry if I'm telling you stuff you know, but your comment above about "it not working" seems confusing when it shoudl be straight forward.
You do not have the required permissions to view the files attached to this post.
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3147
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: White page!

Postby ribo » Thu Jun 22, 2017 10:49 am

Let s tell you again what i see in your host server from a first look from your fpa results in viewtopic.php?f=706&t=952026#p3480381

Session Path Writable: No . This must be yes. Talk to your host to fix it
Max. Upload Size: 20M | Max. POST Size: 8M . Make them both 30M

As i saw also in your last post you have unwritable cache folder. The problem is in your host side with permission issue.
chat room spontes : http://www.spontes.com

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3147
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: White page!

Postby ribo » Thu Jun 22, 2017 10:59 am

AMurray wrote:You should be able to make configuration.php writeable.

Assuming that on a Windows Server running IIS, you can still (in Windows Explorer) right click the file, go to Properties on the context menu, towards the bottom of the dialogue and change the status from "read only" to writeable (uncheck the checkbox under the Attributes section)

Forgive me for being off the beaten track if so 8)

file_properties.PNG

That is, if you have such access in the Windows Server (via Windows Explorer). This is a simple file operation, so shouldn't be too hard to do ???

Sorry if I'm telling you stuff you know, but your comment above about "it not working" seems confusing when it shoudl be straight forward.

Please let me inform you something that it seems that you don t know and you give wrong advice. In windows NT you can have unwritable the file configuration.php . This is not wrong and the OP will not have this cache error that he has. You can test it in your windows pc with wamp server or uniform server and install a joomla without change any permission anywhere. The problem of OP is that he has unwritable the cache folders and this is permission issue in his host server generally.
chat room spontes : http://www.spontes.com

Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

Re: White page!

Postby Rickardo » Thu Jun 22, 2017 11:01 am

Thanks, I appreciate the help. I don't have Explorer, I'm on a Mac. Is it possible to with it?
This is my first Joomla site so I don't know that much.

Ribo, I stuffed it up when I tried to change the cache settings. The site was working, with some issues, but at least it was working.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3147
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: White page!

Postby ribo » Thu Jun 22, 2017 11:05 am

If you are on Mac you must use Mamp https://www.mamp.info/en/
chat room spontes : http://www.spontes.com

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3147
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: White page!

Postby ribo » Thu Jun 22, 2017 11:08 am

But i am not understand your point about Mac. Your joomla site is it in a live server or in your local pc?
chat room spontes : http://www.spontes.com

Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

Re: White page!

Postby Rickardo » Thu Jun 22, 2017 11:12 am

The site is live-
www.muirden.sa.edu.au
I mention the mac because Amurray said I could change the write setting in Windows Explorer.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3147
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: White page!

Postby ribo » Thu Jun 22, 2017 11:17 am

Rickardo wrote:Thanks, I appreciate the help. I don't have Explorer, I'm on a Mac. Is it possible to with it?
This is my first Joomla site so I don't know that much.

Ribo, I stuffed it up when I tried to change the cache settings. The site was working, with some issues, but at least it was working.

Ok i think that i understand what do you say about Mac. It s no matter in what browser you are or in what pc you are when you are trying to make things in joomla. Your problem is with permissions and it s not your fault or joomla s fault. This is server s problem and or speak to your host to solve it or change host.
chat room spontes : http://www.spontes.com

Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

Re: White page!

Postby Rickardo » Thu Jun 22, 2017 11:26 am

Thanks for your help. I'll get on to the host about it.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3147
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: White page!

Postby ribo » Thu Jun 22, 2017 12:22 pm

Rickardo wrote:The site is live-
http://www.muirden.sa.edu.au
I mention the mac because Amurray said I could change the write setting in Windows Explorer.

No need to make anything like this. It s good for security reasons configuration.php to be unwritable . The problem is in your folders that they must be writable.
chat room spontes : http://www.spontes.com

Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

Re: White page!

Postby Rickardo » Thu Jun 22, 2017 4:39 pm

In the fpa I did the other day this came up-

[20-Jun-2017 20:30:03 UTC] PHP Warning: fclose() expects parameter 1 to be resource, boolean given in E:\inetpub\web-sites\clients.murraypestcontrol.com.au-25\web\cron_emal_notify.php on line 170

I don't know who Murray Pest Control is.
The site is on a shared server.
I'm worried about the security of the site with this.
Why would this come up?
The more I can find wrong with this server setup the more chance I have to convince the boss to change hosts to a Joomla friendly one.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18598
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: White page!

Postby leolam » Thu Jun 22, 2017 4:50 pm

Your site shows to be a Wordpress site? If you do not know that site as posted what is your site? What is going on here?

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

Re: White page!

Postby Rickardo » Thu Jun 22, 2017 7:38 pm

Hey Leo,
No my site is a Joomla site
www.muirden.sa.edu.au
This appeared on an fpa I did the other day and I thought it strange, that's why I'm asking.

User avatar
sozzled
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4288
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

The file Cache Storage is not supported on this platform

Postby sozzled » Thu Jun 22, 2017 8:56 pm

First of all, I think I may be wasting my time contributing to this topic because I don't think I'll be able to assist further than what has already been written. The list of problems seems endless and I'm not even sure where to begin.

This topic is a continuation of an earlier suite of problems encountered by @Rickardo. Those problems were not resolved. I've attempted to sift through the posts and replies in both these topics and three things are evident:

(1) despite @Rickardo stating
Rickardo wrote:This is my first Joomla site ...
there are references to more than two sites (see msgs #1 and #2 of this topic); one of them does not resolve and the other returns a "404 Page not found" error.

(2) there is evidence that the site is being hosted on a Windows IIS platform; I accept that the [last-referenced] URL is a Joomla website.

(3) both topics refer to
The file Cache Storage is not supported on this platform.
I don't know enough about J! 3.7.0—which is obsolete, by the way—and Window IIS to understand why "the file Cache Storage is not supported" on that platform but I do know that these issues have been ongoing for more than a week, they've been discussed here over the past 2½ days, and we're none the wiser.

The best course of action would be to reload the website from the backup taken before the site was recently "tweaked"; take a copy of the site and work on it in isolation. Perhaps it's possible to relocate the server onto a more "Joomla-friendly" footing, I don't know. I do think, however, that the staff, students and parents associated with this website would be feeling more than a little uncomfortable at this time and they'd be looking for restoration of service (even if that service was tainted with warning messages) instead of what they're faced with now. This is not the right time to experiment. My advice: restore the site from a backup and then take things slowly.

@Rickardo: you have my sympathy, indeed you do. The others here have tried to help but I think it's probably time to rewind a little, pause, and reconsider the strategy. Good luck. Thanks also to @AMurray (I know he's tried his hardest, too) 8)
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

Re: White page!

Postby Rickardo » Thu Jun 22, 2017 9:16 pm

Thanks sizzled,
The only site I have here is the Muirden College one. I referred to the Murray Pest Control site because the name came up in the fpa that I did the other day and I thought it strange and a potential security issue.


[20-Jun-2017 20:30:03 UTC] PHP Warning: fclose() expects parameter 1 to be resource, boolean given in E:\inetpub\web-sites\clients.murraypestcontrol.com.au-25\web\cron_emal_notify.php on line 170

I just want to get the site going properly and am not qualified to experiment.

I'm waiting for the host to open and see if they can restore it to an earlier version. I tried through Akeeba but it wouldn't work.

It is being hosted on a Windows server, not my choice.

I tried to update to 3.7.2 but was unable to do it. That's in another post and is apparently a permission problem, again.

User avatar
sozzled
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4288
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: White page!

Postby sozzled » Thu Jun 22, 2017 9:29 pm

Let's forget about (a) trying to get the site going "properly", (b) "Murray Pest Control", (c) whether the site is hosted on a Windows IIS platform or (d) attempting to update to J! 3.7.2. Your website is off-the-air and it's probably because of the Joomla cache option you've chosen (but that's just an educated guess).

I won't make any assumptions or judgement about what you've already attempted. We'll take it slowly; let's try to get the site going again.

Do you still have access to the Administrator site (the Joomla "backend")?
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

Re: White page!

Postby Rickardo » Thu Jun 22, 2017 9:37 pm

Yes, good advice.
Yes, I do have access to the"backend"

User avatar
sozzled
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4288
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: White page!

Postby sozzled » Thu Jun 22, 2017 9:38 pm

Can you go to Global Configuration » System » Cache Settings and set and save

System Cache = OFF (Caching disabled)

???
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?

Rickardo
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Tue Jun 20, 2017 4:47 pm

Re: White page!

Postby Rickardo » Thu Jun 22, 2017 9:40 pm

I set that to OFF last night but it didn't change anything.

User avatar
sozzled
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4288
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia
Contact:

Re: White page!

Postby sozzled » Thu Jun 22, 2017 9:43 pm

Now go to System » Clear Cache and (even if there's nothing listed), click the Delete All button.

Likewise, go to System » Clear Expired Cache and click the Clear Expired Cache button on that page.
https://www.kuneze.com/blog
Former member of Kunena project team
If you think I’m wrong then say “I think you're wrong.” If you say “You’re wrong!”, how do you know?


Return to “Joomla! 3.x on IIS webserver”

Who is online

Users browsing this forum: No registered users and 4 guests