configuration.php keeps marking itself as read-only Topic is solved

This forum is for issues with installing Joomla! 3.x on IIS webservers.
Locked
dan40
Joomla! Intern
Joomla! Intern
Posts: 53
Joined: Tue Nov 06, 2012 11:52 pm
Contact:

configuration.php keeps marking itself as read-only

Post by dan40 » Fri Sep 21, 2018 6:40 pm

Hi team,

Running IIS8 in Windows Server 2016, Joomla configuration.php keeps marking itself as read-only no matter what changes I make in the back-end.

How can I prevent this from happening? The settings that I set sometimes don't take effect because the file is read-only.

Thanks for any help.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39319
Joined: Sat Apr 05, 2008 9:58 pm

Re: configuration.php keeps marking itself as read-only

Post by Webdongle » Fri Sep 21, 2018 9:49 pm

That is expected behaviour ... Joomla sets it 444
If you can not save global config then you have a file Ownership problem.
viewtopic.php?f=714&t=793531 please
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6352
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: configuration.php keeps marking itself as read-only

Post by AMurray » Fri Sep 21, 2018 11:30 pm

@webdongle, note the OP is running Joomla on a Windows server not Linux, so would the same file permissions apply? Your answer still applies - the configuration.php should be read-only but CHMOD/CHOWN settings don't apply to Windows O/S. Maybe there's more involved with permissions on Windows Server than to Windows desktop/end-user editions of the O/S ???
Regards,
--------------------------------------------------------------
A Murray
Help you I can, yes!. Post your question, you should. Keep it on topic you must!
Use the Forc....Forum Post Assistant my young Padawan!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 39319
Joined: Sat Apr 05, 2008 9:58 pm

Re: configuration.php keeps marking itself as read-only

Post by Webdongle » Sat Sep 22, 2018 12:19 am

@AMurray
Ahh yes ,,, have requested move to windows forum. Windows Permissions settings are different.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.

dan40
Joomla! Intern
Joomla! Intern
Posts: 53
Joined: Tue Nov 06, 2012 11:52 pm
Contact:

Re: configuration.php keeps marking itself as read-only

Post by dan40 » Tue Oct 02, 2018 2:02 am

I know what my problem was. In Windows, you have to open an Explorer menu, then right-click on your website folder within your wwwroot folder (if you keep it there), and select Properties. Then click the Security tab. Add IIS_IUSRS with Read & Execute, List Folder Contents, Read, and Write. I was selecting "Modify" because that's the only way I could get it working. I totally forgot about "write" access. Then click OK.

That will do it for ANYONE having a problem with IIS7/8 and Windows Server website permissions.

Thanks to everyone who replied, sorry for posting in the wrong group, but the topic is resolved.


Locked

Return to “Joomla! 3.x on IIS webserver”