Hyperlinks do not use custom domain in Azure

This forum is for issues with installing Joomla! 3.x on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
jpiston
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Nov 24, 2018 4:31 am

Hyperlinks do not use custom domain in Azure

Post by jpiston » Sat Nov 24, 2018 4:48 am

Hi Guys.
i'm SysAdmin but new in Joomla.
I have migrated an existing Joomla Website to Azure Wep App.

The Migration succeeded. I can access my website using MyWebsiteName.[spam].net
I created and added a Host-name to my Azure Web App in the Custom Domain tab using my own Domain Name.

Have also added a CNAME Record and A Record to my DNS Management so that when user hit www.MyWebsiteName.com they redirecting to MyWebsiteName.[spam].net.
Now I can access my Azure Web App either by https://www.MyWebsiteName.com or https://MyWebsiteName.com. (Works Perfect!)

However all Hyperlinks within the Websites pages still using Azure Website URL example: MyWebsiteName.[spam].net/index.php/contact.html instead of using www.MyWebsiteName.com/contact

Have tried the Following:
1. Component/Redirect = Old Links to be redirected to New Links
2. Can't changed the Articles Links because it using Menu Item Type * = items (I think it is related to K2, where I didn't have any expertise)
3. In my configuration.php file the value for public $live_site = ;; is blank. but for unknown reason I can't modified even through Azure KUDO Console or even via FileZilla (409 Conflict: Could not write to local resource D:\home\site\wwwroot\configuration.php due to error ;Access to the path )

Can't find anywhere where I can changes this setting so that every internal hyperlinks to other pages using my custom domain instead of [spam]

Can anyone please help?

PHP Built On:Windows NT RD00155D498C6F 10.0 build 14393 (Windows Server 2016) i586
Database Version:5.6.39.0
Database Collation utf8_general_ci
Database Connection Collation utf8mb4_general_ci
PHP Version:5.6.38
Web Server:Microsoft-IIS/10.0
WebServer to PHP Interface:cgi-fcgi
Joomla! Version:Joomla! 3.6.4 Stable [ Noether ] 21-October-2016 16:33 GMT
Joomla! Platform Version:Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
User Agent:Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36

Cheers
JPiston
Last edited by toivo on Sat Nov 24, 2018 8:22 am, edited 1 time in total.
Reason: mod note: moved to Joomla 3.x in IIS, fixed subject

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 25770
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Hyperlinks do not use custom domain in Azure

Post by Per Yngve Berg » Sat Nov 24, 2018 9:03 am

Have you renamed webconfig.txt to web.config?

The detection in Joomla for where it's installed is different in IIS than in Apache. You must have an issue with the Virtual Host setup on the server.

Is the rewrite module installed?

You are running outdated/EOL software:
PHP Version:5.6.38 (7.1/7.2)
oomla! Version:Joomla! 3.6.4 (3.9.0)

jpiston
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Nov 24, 2018 4:31 am

Re: Hyperlinks do not use custom domain in Azure

Post by jpiston » Sun Nov 25, 2018 7:29 am

Hi Per Yngve Berg,

Thank you for your time.

Just tried the following:

1. Rename the file web.config.txt to web.config
2. Been able to edit the configuration.php file and set the value of public $live_site = 'https://xxx.com/';
3. Enable the URL rewritng in Global Configuration -> Site: Search Engine Friendly URLs to YES and Use URL Rewriting to YES
4. Change the PHP version to 7.2 in Azure Web Application settings
5. Extension/Update Site > Enabled all and Rebuild
6. Faield to Update the Site from 3.6.4.1 to 3.9.0.10

But Having the following Error:
×
Warning
JFolder::create: Could not create folder.Path: \www
Update path does not exist.
×
Error
Archive does not exist
×
Message
Error updating COM_INSTALLER_TYPE_TYPE_.


Restart the Azure Web App but still the same issue. Hyperling to internal website pages still using xx.[spam].net whereas the home page works
fine with my custom domain name https://xxx.com

I also noticed that in Menu/All Menu/Menu Items, some articles are using K2 setting whereas some are using External URL

1. Home
k2 >> item >> item

2. Contact
External URL (This one I can edit the Link Tab and input my custom domain name, Works Fine)

Any other idea please?

Thanks in Advance
JPISTON

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 25770
Joined: Mon Oct 27, 2008 9:27 pm
Location: Akershus, Norway

Re: Hyperlinks do not use custom domain in Azure

Post by Per Yngve Berg » Sun Nov 25, 2018 9:10 am

jpiston wrote:
Sun Nov 25, 2018 7:29 am
2. Been able to edit the configuration.php file and set the value of public $live_site = 'https://xxx.com/';
It should usually be left blank.
jpiston wrote:
Sun Nov 25, 2018 7:29 am
JFolder::create: Could not create folder.Path: \www
The folder name appears to be 'wwwroot'

Set tmp path to D:\home\site\wwwroot\tmp in configuration.php

Also check the log path.


Post Reply

Return to “Joomla! 3.x on IIS webserver”