Joomla Admin Error: Unknown column 'a.client_id' in 'where clause': Unknown column 'a.client_id' in 'where clause' Topic is solved

This forum is for issues with installing Joomla! 3.x on IIS webservers.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
stuartb42
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Feb 04, 2019 11:11 am

Joomla Admin Error: Unknown column 'a.client_id' in 'where clause': Unknown column 'a.client_id' in 'where clause'

Post by stuartb42 » Mon Feb 04, 2019 11:18 am

Hello
I wonder if anyone can help. I am running a Joomla intranet site on a synology box. I have recently upgraded joomla to version 3.8.8-0166. The front end is all working fine but when I login to the admin page I just get a blue header with the following words:
Error: Unknown column 'a.client_id' in 'where clause': Unknown column 'a.client_id' in 'where clause'

Any ideas on how to fix this? as I am a little stuck on what to do next.

Many thanks

Stuart

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 27190
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: Joomla Admin Error: Unknown column 'a.client_id' in 'where clause': Unknown column 'a.client_id' in 'where clause'

Post by imanickam » Tue Feb 05, 2019 5:18 am

Can you please check whether the database schema is up to date? This could be done in the screen "Extensions: Database".

Make sure to take a backup of your site (both files and database content) before attempting the fix, if need be.
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Joomla! - Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

stuartb42
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Feb 04, 2019 11:11 am

Re: Joomla Admin Error: Unknown column 'a.client_id' in 'where clause': Unknown column 'a.client_id' in 'where clause'

Post by stuartb42 » Tue Feb 05, 2019 11:18 am

Hello thanks, I have just managed to find a fix this morning. I put the following in:
MYWEBSITE/administrator/index.php?option=com_installer&view=database
It found 2 Database Problems. I was then able to update and fix the database


Post Reply

Return to “Joomla! 3.x on IIS webserver”