Solved: Front end login stopped working Topic is solved

Moderators: mandville, PhilD, General Support Moderators

Post Reply
TheThomas
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Mon Aug 17, 2015 9:18 am

Solved: Front end login stopped working

Post by TheThomas » Fri May 20, 2016 8:54 am

Hi, I hope I am in the right forum.

I suddenly (no idea what changed) can no longer login on the frontend (http://fsg-neuoetting.eu/index.php/impressum).
When I enter my credentials, the page just reloads and I am still not logged in.

Backend login works fine!
There are no error messages, reporting is set to maximum.

I already tried creating other users. Those can also just log in backend only.

I will gladly provide a test login.

My question is: Is there a known bug or how can I see whats wrong?
Thank you in advance!
Last edited by TheThomas on Fri May 20, 2016 9:31 am, edited 1 time in total.

User avatar
ltheme
Joomla! Guru
Joomla! Guru
Posts: 573
Joined: Wed Dec 04, 2013 2:43 pm
Location: US
Contact:

Re: Front end login stopped working

Post by ltheme » Fri May 20, 2016 9:09 am

I think it's just problem with cookie domain.
You try to open file "configuration.php" located at root of your source code and search for two params
"$cookie_domain" and "$cookie_path"

and leave it blank as is

public $cookie_domain = "" ;
public $cookie_path = "" ;
Steve (Mr.) - fan of Joomla! CMS.
http://ltheme.com/joomla-templates/ <= Premium Joomla! templates.
http://ltheme.com/free-one-page-joomla-templates/ <= Free Responsive Onepage Joomla! templates
^Compatible with Joomla! 2.5 & 3.x.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36119
Joined: Sat Apr 05, 2008 9:58 pm

Re: Front end login stopped working

Post by Webdongle » Fri May 20, 2016 9:23 am

Check the global permissions for the user group(s) that cant login front end. If you have a 3rd party extension that handles users ... check the settings for that.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

TheThomas
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Mon Aug 17, 2015 9:18 am

Re: Front end login stopped working

Post by TheThomas » Fri May 20, 2016 9:29 am

Thank you both!

The cookie domain was set correctly, however that hint prompted me to check the cookie policy notification bar. That was quite an old module - deleting it let me log in again. So that module was faulty.

Thanks again! :)

User avatar
ltheme
Joomla! Guru
Joomla! Guru
Posts: 573
Joined: Wed Dec 04, 2013 2:43 pm
Location: US
Contact:

Re: Front end login stopped working

Post by ltheme » Fri May 20, 2016 9:40 am

TheThomas wrote:Thank you both!

The cookie domain was set correctly, however that hint prompted me to check the cookie policy notification bar. That was quite an old module - deleting it let me log in again. So that module was faulty.

Thanks again! :)
Enjoy weekend now 8)
Steve (Mr.) - fan of Joomla! CMS.
http://ltheme.com/joomla-templates/ <= Premium Joomla! templates.
http://ltheme.com/free-one-page-joomla-templates/ <= Free Responsive Onepage Joomla! templates
^Compatible with Joomla! 2.5 & 3.x.

fancyhome
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sat Jun 23, 2018 11:56 am

Re: Solved: Front end login stopped working

Post by fancyhome » Sat Jun 23, 2018 12:03 pm

I had the same problem. Login/register form began to give "page cannot be found" or "item 101" error. I then realized that some security plugins/extensions I have installed was causing this error. I uninstalled SQL injection plugin and security check spam protection plugins and it began to work with no issues. keep in mind Just in case...

User avatar
ltheme
Joomla! Guru
Joomla! Guru
Posts: 573
Joined: Wed Dec 04, 2013 2:43 pm
Location: US
Contact:

Re: Solved: Front end login stopped working

Post by ltheme » Sun Aug 05, 2018 6:39 am

fancyhome wrote:
Sat Jun 23, 2018 12:03 pm
I had the same problem. Login/register form began to give "page cannot be found" or "item 101" error. I then realized that some security plugins/extensions I have installed was causing this error. I uninstalled SQL injection plugin and security check spam protection plugins and it began to work with no issues. keep in mind Just in case...
That's great :)
Steve (Mr.) - fan of Joomla! CMS.
http://ltheme.com/joomla-templates/ <= Premium Joomla! templates.
http://ltheme.com/free-one-page-joomla-templates/ <= Free Responsive Onepage Joomla! templates
^Compatible with Joomla! 2.5 & 3.x.


Post Reply

Return to “Access Control List (ACL) in Joomla! 3.x”