'Registered' Student Access Menu not showing when Student Logs in

Moderators: mandville, PhilD, General Support Moderators

jwakers23
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Mon Sep 10, 2012 5:44 pm

'Registered' Student Access Menu not showing when Student Logs in

Postby jwakers23 » Sat Mar 18, 2017 4:04 am

I am totally unsure of what is happening on my site. I have 3.6.5 installed and the site (http://www.bushokai.com) has a 'public' access and a 'student' access. Now (appears to have started happening in the last few days) when a 'registered' Student logs in the 'Student Menu' does not appear. When the page is refreshed the menu has appeared but when a student logs out, the menu stays and does not remove itself. This gives the 'public' access to the paid students lessons, etc.

The 'student' users are set up under the 'registered' group and for two years this has worked flawlessly. Now, after 3.6.5 has been installed, it fails miserably.

I would appreciate starting a discussion about this. I have spent the last six hours going over each and every setting to see if I have inadvertently changed something, but no luck.

Thank you, in advance for any assistance.

User avatar
rcarey
Joomla! Explorer
Joomla! Explorer
Posts: 464
Joined: Sat Apr 25, 2009 9:20 pm
Location: Minnesota (USA)
Contact:

Re: 'Registered' Student Access Menu not showing when Student Logs in

Postby rcarey » Sun Mar 19, 2017 6:04 am

Do you have caching on? That can cause problems like that.
Randy Carey, the iCue Project http://iCueProject.com : developing an intelligent approach to improving the CMS user experience,
Careytech Studios http://careytech.com custom development for tailored or value-added web solutions

jwakers23
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Mon Sep 10, 2012 5:44 pm

Re: 'Registered' Student Access Menu not showing when Student Logs in

Postby jwakers23 » Sun Mar 19, 2017 6:30 am

Thank you, rcarey. I thought that I had checked that yesterday, but it was not changed. I reset it to caching disabled and now the login is working correctly. Thanks again for keeping me focused.....it has been a long day.

User avatar
rcarey
Joomla! Explorer
Joomla! Explorer
Posts: 464
Joined: Sat Apr 25, 2009 9:20 pm
Location: Minnesota (USA)
Contact:

Re: 'Registered' Student Access Menu not showing when Student Logs in

Postby rcarey » Sun Mar 19, 2017 6:46 am

Glad it was a simple solution for you. Caching still trips me up every so often - I think we've all been there.
Randy Carey, the iCue Project http://iCueProject.com : developing an intelligent approach to improving the CMS user experience,
Careytech Studios http://careytech.com custom development for tailored or value-added web solutions

User avatar
rcarey
Joomla! Explorer
Joomla! Explorer
Posts: 464
Joined: Sat Apr 25, 2009 9:20 pm
Location: Minnesota (USA)
Contact:

Re: 'Registered' Student Access Menu not showing when Student Logs in

Postby rcarey » Sun Mar 19, 2017 6:48 am

But do keep in mind that you can fine-tune your caching so that everything but key modules are cached.
Randy Carey, the iCue Project http://iCueProject.com : developing an intelligent approach to improving the CMS user experience,
Careytech Studios http://careytech.com custom development for tailored or value-added web solutions


Return to “Access Control List (ACL) in Joomla! 3.x”

Who is online

Users browsing this forum: No registered users and 1 guest