"Register to read more" works perfectly in blog/list but not in "Articles - Category" Module

Moderators: mandville, PhilD, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
peteward
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Dec 18, 2013 12:15 pm

"Register to read more" works perfectly in blog/list but not in "Articles - Category" Module

Post by peteward » Thu Aug 23, 2018 4:14 pm

I've been using Joomla for a long time and have recently come up against a problem. Many of the sites I look after have content restricted to paid users.

I've always used Joomla's built in Viewing Access Levels to control this and it works a treat. The user clicks the article title or image or "register to read more" button, they go to a login page and then once logged in, they go to the full article text.

On a site I recently revamped - this is all working as above on the blog layout pages, however I wanted to make use of the Articles - Category module to to display a block of article intros on the home page which are articles that are restricted to members.

The template I'm using displays the module and uses the intro image (linked), the article title (linked), intro text and "Login to read more" button (linked).

Clicking the article title or the "Login to read more" button in the module takes me to a login page but logging in redirects to the user to their profile page. Clicking the image goes to a login page also, but here logging in redirects to the full article.

Thinking this may be a perculiarity of the template, I tested it on a very simple site which had a fresh install of Joomla, I get a similar problem.

In blog layout the link on the "Register to read more" takes the form: mydomain.com/index.php/component/users/?view=login&Itemid=101&return=aW5kZXgucGhwP29wdGlvbj1jb21fY29udGVudCZ2aWV3PWFydGljbGUmaWQ9Mjp0ZXN0aW5nLWFydGljbGUtY2F0ZWdvcmllcyZjYXRpZD04

The to the same article in the Articles - Category module takes the form: mydomain.com/index.php/component/users/?view=login&Itemid=101

If I create a menu item to a login page, then the link in the Articles - Category module takes the form:
mydomain.com/index.php/member-login - where "member-login" is the alias of the login menu item.

On the site where the template I am using pulls through the article image into the Article - Category module, the link on the image is the fully qualified URL to the article, for example:
mydomain.com/index.php/members-only/182-employment/458-are-you-discriminating-when-recruiting.

You can see it the problem in action at http://www.featco.co.uk using the login:
U: member
P: password

The article titled "Testing Articles Category" is restricted to members only.

When not logged in, accessing it via the blog listing on the Home Page or via the "Members Only Article" link in the main menu, the login redirect works perfectly.

When not logged in, following the link in the Articles - Category module (below the Main Menu module), the login redirect goes to the profile.

The site where the template pulls through the article image is www.sandwich.org.uk. The block of articles headed "Advice" on the home page are all created from an Articles - Category module. I can't give a login for that site but you can see the difference in the links in the source code.

Any ideas?

Thanks,
Pete

Post Reply

Return to “Access Control List (ACL) in Joomla! 3.x”