Guest access not working

Moderators: mandville, PhilD, General Support Moderators, mandville, PhilD, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
dave600
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Mar 08, 2011 6:02 pm

Guest access not working

Post by dave600 » Wed Oct 14, 2020 2:56 am

I have a problem with a module with Guest access that doesn't show up when not logged in (it's a login button).

This issue seems to have appeared recently, not sure when as I don't normally administer the site. If I change the module access to Public, it appears just fine. The Guest User Group in User:Options is set to Public. It doesn't work either on the standard Protostar template.

(The problem isn't confined to modules. It happens also on a component where a field set to Guest never appears no matter the login status.)

Is this a bug, or are there any other settings I can look at?

Joomla 3.9.22

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 27555
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Guest access not working

Post by Per Yngve Berg » Wed Oct 14, 2020 3:44 am

Check that the Guest Group and Access Level is properly set up.
Is also Guest set to Guest in the Options of User Manager?

dave600
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Mar 08, 2011 6:02 pm

Re: Guest access not working

Post by dave600 » Thu Oct 15, 2020 2:44 pm

In Users>User Groups, there is no Guest group.

In Users>Viewing Access Levels, Guests has no group checked. There is no guest checkbox here. (If I check Public here the module does appear for everyone, logged in or not, so the module is working).

In Users: Options, the Guest User Group is set to Public. There is no 'Guest' in the dropdown to select here.

As I recall, this is how it should be?

Edit: No, checking another site, there should be a Guest user group in Users>User Groups. Odd that it's missing. Can I just create one?

Edit: I just made a new one with Public as the parent and set the Guest User Group to Guest. Not sure if there's anything else I need to do, but it seems to be working just fine. No idea how that would have disappeared, but I'm not the normal admin.... Thanks for the help!


Post Reply

Return to “Access Control List (ACL) in Joomla! 3.x”