Page 1 of 1

Joomla3.8.x problem

Posted: Sun Mar 25, 2018 2:35 pm
by xiaomizer
Hi,
When I upgrade Joomla from 3.6.x to 3.8.x,my own developed components have a problem in front page.It prompts me "undefined method FacultyHelpersFaculty::canUserEdit()" But I have defined the method.Can you tell me why?
I wrote this way "$canEdit = FacultyHelpersFaculty::canUserEdit($this->item, $user);"
Hope to get your answers.Thank you.

Re: Joomla3.8.x problem

Posted: Sun Mar 25, 2018 2:52 pm
by Per Yngve Berg
Mod. Note: Relocated the topic to the J3.x Coding Forum.

Re: Joomla3.8.x problem

Posted: Sun Mar 25, 2018 5:05 pm
by toivo
Has the class FacultyHelpersFaculty been included by using 'include' or 'require' in your file, or is it in a namespace? Is the spelling and the use of capital letters exactly the same?

Re: Joomla3.8.x problem

Posted: Mon Mar 26, 2018 2:20 am
by xiaomizer
toivo wrote:Has the class FacultyHelpersFaculty been included by using 'include' or 'require' in your file, or is it in a namespace? Is the spelling and the use of capital letters exactly the same?
I define the method in adminstrator/components,the problem is solved.But I use the method in front page.Do you know why this happens?

Re: Joomla3.8.x problem

Posted: Mon Mar 26, 2018 6:19 am
by toivo
I do not, without answers to my previous question.