issue with Smart Search cronjob

Did you find a bug in Joomla! 3.x but aren't sure? This forum is the place to help figure out if the problem is a bug and how to report it. If you are an experienced Joomla! user and are certain that you have found a bug please use the Bug Tracker to submit your issue.
This forum is for discussion about bugs and to get help with reporting them to the Bug Tracker: https://issues.joomla.org

Moderator: ooffick

Forum rules
Please use the official Bug Tracker to report a bug: https://issues.joomla.org
Post Reply
nvsdesign
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Thu Jan 06, 2011 2:17 pm

issue with Smart Search cronjob

Post by nvsdesign » Tue Oct 26, 2021 9:34 am

Hi all,

I'm having some issues with setting up a cronjob for Smart Search indexing. I'm getting an error in my cronjob saying: 0 - Call to a member function getTag() on null

I did some tests and it looks like this is caused by the system plugin Smart search - content. If I disable this plugin, the error disappears. There are no other plugins active:

Image

This is the full error I get in my cron notification:

Code: Select all

Smart Search INDEXER
============================
Starting Indexer
Setting up Smart Search plugins
Setup 1285 items in 0.265 seconds.
<!DOCTYPE html>
<html lang="en-gb" dir="ltr">
<head>
	<meta charset="utf-8" />
	<title>0 - Call to a member function getTag() on null</title>
	<link href="/home/mysite/public_html/cli/templates/system/css/error.css" rel="stylesheet" />
			<!--[if lt IE 9]><script src="/home/mysite/public_html/cli/media/jui/js/html5.js"></script><![endif]-->
</head>
<body>
	<div class="error">
		<div id="outline">
		<div id="errorboxoutline">
			<div id="errorboxheader">0 - Call to a member function getTag() on null</div>
			<div id="errorboxbody">
			<p><strong>You may not be able to visit this page because of:</strong></p>
			<ol>
				<li>an <strong>out-of-date bookmark/favourite</strong></li>
				<li>a search engine that has an <strong>out-of-date listing for this site</strong></li>
				<li>a <strong>mistyped address</strong></li>
				<li>you have <strong>no access</strong> to this page</li>
				<li>The requested resource was not found.</li>
				<li>An error has occurred while processing your request.</li>
			</ol>
			<p><strong>Please try one of the following pages:</strong></p>
			<ul>
				<li><a href="/home/mysite/public_html/cli/index.php" title="Go to the Home Page">Home Page</a></li>
			</ul>
			<p>If difficulties persist, please contact the System Administrator of this site and report the error below.</p>
			<div id="techinfo">
			<p>
				Call to a member function getTag() on null							</p>
						</div>
			</div>
		</div>
		</div>
	</div>
</body>
</html>

I'm using Joomla 3.10.2 on php 7.4.13.

Any ideas how to solve this?

User avatar
DV-admin
Joomla! Intern
Joomla! Intern
Posts: 84
Joined: Wed Sep 20, 2017 7:24 am
Location: Genova
Contact:

Re: issue with Smart Search cronjob

Post by DV-admin » Wed Oct 27, 2021 9:09 am

Is there a setting in Joomla 3 Smart Search that allows you to disable Filter Numeric Terms?

nvsdesign
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Thu Jan 06, 2011 2:17 pm

Re: issue with Smart Search cronjob

Post by nvsdesign » Thu Oct 28, 2021 2:08 pm

There no such setting in Joomla 3 Smart Search. At least not that I know of.

nvsdesign
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Thu Jan 06, 2011 2:17 pm

Re: issue with Smart Search cronjob

Post by nvsdesign » Mon Nov 08, 2021 8:09 am

Any other ideas..?

SharkyKZ
Joomla! Hero
Joomla! Hero
Posts: 2020
Joined: Fri Jul 05, 2013 10:35 am
Location: Parts Unknown

Re: issue with Smart Search cronjob

Post by SharkyKZ » Mon Nov 08, 2021 9:15 am

It could be any other plugin. Enable debug in global configuration. Reproduce the error again. You should see a stack trace. Post it here.


Post Reply

Return to “Joomla! 3.x Bug Reporting”