Joomla 3.4.5 :: Pathway: Active menu empty on alias

Did you find a bug in Joomla! 3.x but aren't sure? This forum is the place to help figure out if the problem is a bug and how to report it. If you are an experienced Joomla! user and are certain that you have found a bug please use the Bug Tracker to submit your issue.
This forum is for discussion about bugs and to get help with reporting them to the Bug Tracker: https://issues.joomla.org

Moderator: ooffick

Forum rules
Please use the official Bug Tracker to report a bug: https://issues.joomla.org
Locked
sailor01
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Nov 23, 2015 9:17 am

Joomla 3.4.5 :: Pathway: Active menu empty on alias

Post by sailor01 » Mon Nov 23, 2015 8:53 pm

Dear Joomla team,

Thank you for all your effort in Joomla. It is a great tool and I use use it for years now.

In manually building the breadcrumbs / pathway to a component view, Joomla may fail to retrieve the active menu item by e.g.

Code: Select all

$menu = JFactory::getApplication()->getMenu()->getActive();
Thus $menu is unset in some scenarios.

I do understand that this is expected behaviour whenever you create a (text) link with no menu itemID in the URI (though I would prefer a default, which is the frontpage; that could be optional for backwards compatibility).

But this also happens with menu item aliases created in the backend (at least if the alias and the menu item are in different menus):
- Create an menu item alias to a submenu item of a different menu.
- Use the alias on any frontend page that is NOT showing the aliased item menu. (The menu including the alias, e.g. to the user profile page, is displayed on all pages.)
-> The active menu will be empty.

Best regards,
Silke

Locked

Return to “Joomla! 3.x Bug Reporting”