Category Blog Show Tags does not show show tags

Did you may have found a bug in Joomla! 3.x but aren't sure? This forum is the place to help figure out if the problem is a bug and how to report it. If you are an experienced Joomla! user and are certain that you have found a bug please use the Bug Tracker to submit your issue.
This forum is for discussion about bugs and to get help with reporting them to the Bug Tracker: https://issues.joomla.org

Moderator: ooffick

Forum rules
Please use the official Bug Tracker to report a bug: https://issues.joomla.org
User avatar
idleog
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Wed Aug 29, 2007 9:45 am

Category Blog Show Tags does not show show tags

Postby idleog » Tue Aug 08, 2017 4:56 pm

Hi all

If I want to show tags of each article in category blog and set in the option panel of the menu item 'show tags' to 'show' it does not show the tags. If I also set 'show author' or 'show creation date', the tags are shown.
This happens when in global settings show tags is set to 'hide'.

Joomla 3.7.4

Cheers
peter
Eine wunderbare Heiterkeit hat meine ganze Seele eingenommen, gleich den süßen Frühlingsmorgen, die ich mit ganzem Herzen genieße.

User avatar
idleog
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Wed Aug 29, 2007 9:45 am

Re: Category Blog Show Tags does not show show tags

Postby idleog » Tue Aug 08, 2017 5:09 pm

...
which is because:
in components/com_content/views/category/tmpl/blog_item.php:

Code: Select all

<?php // Todo Not that elegant would be nice to group the params ?>
<?php $useDefList = ($params->get('show_modify_date') || $params->get('show_publish_date') || $params->get('show_create_date')
   || $params->get('show_hits') || $params->get('show_category') || $params->get('show_parent_category') || $params->get('show_author') || $assocParam); ?>

<?php if ($useDefList && ($info == 0 || $info == 2)) : ?>
  <?php // Todo: for Joomla4 joomla.content.info_block.block can be changed to joomla.content.info_block ?>
   <?php echo JLayoutHelper::render('joomla.content.info_block.block', array('item' => $this->item, 'params' => $params, 'position' => 'above')); ?>
   <?php if ($info == 0 && $params->get('show_tags', 1) && !empty($this->item->tags->itemTags)) : ?>
      <?php echo JLayoutHelper::render('joomla.content.tags', $this->item->tags->itemTags); ?>
   <?php endif; ?>
<?php endif; ?>


if $useDefList is not true tags are never shown even if show_tags-param is set to '1'.

cheers
peter
Eine wunderbare Heiterkeit hat meine ganze Seele eingenommen, gleich den süßen Frühlingsmorgen, die ich mit ganzem Herzen genieße.


Return to “Joomla! 3.x Bug Reporting”

Who is online

Users browsing this forum: No registered users and 2 guests