Feil ved oppgradering til 3.8

Spørsmål om migrering og oppdatering fra eldre versjoner

Moderators: sone12, Per Yngve Berg

vestfoldgutt
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Sep 29, 2017 1:04 pm

Feil ved oppgradering til 3.8

Postby vestfoldgutt » Fri Sep 29, 2017 1:17 pm

Hei
Ser at flere nylig har fått problemer ved å oppgradere til joomla 3.8 meg selv inkludert. I mitt tilfelle fra joomla 3.5.1 og dette er også versjonen flere sliter med å oppgradere direkte til 3.8. Straks jeg har oppgradert til 3.8 forsvinner alt på administrator siden (blankt). Forsiden fungerer fint. feilmeldingen er 1054 unknown column 'client_id. Noen ide på hvordan man kan fikse dette?

User avatar
rued
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4753
Joined: Fri Sep 16, 2005 10:23 pm
Location: Finland / Norway
Contact:

Re: Feil ved oppgradering til 3.8

Postby rued » Fri Sep 29, 2017 2:03 pm

Se her viewtopic.php?f=9&t=954795&start=30#p3493299

Se også følgende innlegg, som f.eks. viewtopic.php?f=9&t=954795&start=30#p3493310

I korte trekk, enten må du oppdatere database manuelt. Eller du kan rulle tilbake til sikkerhetskopien du helt sikkert tok før du oppdaterte, oppdatere deretter til 3.6.5, og så videre til 3.8.0

Og i fremtiden, ikke vent så mange år mellom oppdateringer. ;)
Rune Rasmussen - http://www.syntaxerror.no
Norske nettløsninger og integrasjoner, CONSIGNOR EDI, Mamut ordreimport og produkteksport, kortbetaling og faktura m.m.

Norsk Joomla! - Norwegian Translation Team - http://www.norskjoomla.no

vestfoldgutt
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Sep 29, 2017 1:04 pm

Re: Feil ved oppgradering til 3.8

Postby vestfoldgutt » Fri Sep 29, 2017 2:26 pm

Takker for svar :)

Jeg pleier å oppdatere mine sider jevnlig men i dette tilfellet var det en kunde som denne uken absolutt ville ha en mal fra shape5 inkludert demo (siteshaper) med innebygd joomla (versjon 3.5.1.) Har henvendt meg til dem om de kan oppdatere joomla versjon i deres siteshaper.

vestfoldgutt
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Sep 29, 2017 1:04 pm

Re: Feil ved oppgradering til 3.8

Postby vestfoldgutt » Fri Sep 29, 2017 5:35 pm

Linken du sendte gjorde at jeg fikk løst problemet...takk :) Dettte ved å gå inn i PhpMyadmin og legge inn følgende Sql kommando (ersatte xxxxx med databasens prefix):

ALTER TABLE `xxxxx_menu_types` ADD COLUMN `client_id` int(11) NOT NULL DEFAULT 0;
UPDATE `xxxxx_menu` SET `published` = 1 WHERE `menutype` = 'main' OR `menutype` = 'menu';
UPDATE `xxxxx_menu`
SET `menutype` = 'main_is_reserved_133C585'
WHERE `client_id` = 0
AND `menutype` = 'main'
AND (SELECT COUNT(`id`) FROM `xxxxx_menu_types` WHERE `client_id` = 0 AND `menutype` = 'main') > 0;

UPDATE `xxxxx_modules`
SET `params` = REPLACE(`params`,'"menutype":"main"','"menutype":"main_is_reserved_133C585"')
WHERE `client_id` = 0
AND (SELECT COUNT(`id`) FROM `xxxxx_menu_types` WHERE `client_id` = 0 AND `menutype` = 'main') > 0;

UPDATE `xxxxx_menu_types`
SET `menutype` = 'main_is_reserved_133C585'
WHERE `client_id` = 0
AND `menutype` = 'main';
UPDATE `xxxxx_menu`
SET `client_id` = 1
WHERE `menutype` = 'main';
UPDATE `xxxxx_menu`
SET `menutype` = 'main'
WHERE `client_id` = 1
AND `menutype` = 'menu';
UPDATE `xxxxx_menu`
SET `menutype` = 'main',
`client_id` = 1
WHERE `menutype` = 'menu'
AND (SELECT COUNT(`id`) FROM `xxxxx_menu_types` WHERE `client_id` = 0 AND `menutype` = 'menu') = 0;
DELETE FROM `xxxxx_menu_types`
WHERE `client_id` = 1
AND `menutype` IN ('main', 'menu');


OG etter at dette er gjort gå inn på administrator siden og fikse databasen ( extension, manage, database og trykke fix knappen)


Return to “Migrering/Oppdatering”

Who is online

Users browsing this forum: No registered users and 1 guest