Problème d'affichage de caractères accentués.

Support et assistance pour l'utilisation de Joomla! 3.0, 3.1 et 3.5 : administration, gestion du contenu, des menus et des extensions natives... et toutes les autres questions qui n'ont pas de place ailleurs

Moderators: sarki, Aidan38

Forum rules
Règles du forum
Post Reply
chti56
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Jan 23, 2015 5:07 pm

Problème d'affichage de caractères accentués.

Post by chti56 » Mon Jan 15, 2018 5:41 pm

Bonsoir,

J'ai un site utilisant la dernière version de Joomla.
Ce site contient une age qui est en fait un bon de commande créé avec Chronoforms5.
Sur ce bon de commande j'ai mis une phrase d'avertissement:

JE CERTIFIE ETRE MAJEUR (18 ans âge légal en France)
Ici le â s'affiche bien mais sur le site l'accent circonflexe est inversé !! Voir ici:

http://gb-producson.com/fr/bon-de-commande.html

Je ne comprends pas pourquoi j'ai ce petit bug... Le source de la page me donne ceci:

body {font-family: 'Acme',Helvetica,Arial,Sans-Serif ;

Je soupçonne donc cette police de caractères 'Acme' ... mais je ne vois pas où cette police est déclarée ...

Quelqu'un me donner une piste ??

Merci d'avance.

JP
Last edited by sarki on Fri Mar 16, 2018 2:30 am, edited 2 times in total.
Reason: Réglé

User avatar
pmleconte
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 206
Joined: Fri Mar 17, 2017 12:55 pm

Re: Problème d'affichage de caractères accentués.

Post by pmleconte » Tue Jan 16, 2018 5:59 pm

Bonsoir JP,

Ce forum n'est pas vraiment réactif sur les sujets en français. Essayez plutôt https://forum.joomla.fr, la communauté y est plus nombreuse et attentive.

Je ne suis pas spécialiste des fonts, mais, je pense que vous y trouverez des oreilles et claviers attentifs.

A plus tard,

Pascal
If anything can go wrong, it will.
https://www.conseilgouz.com/en

User avatar
pmleconte
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 206
Joined: Fri Mar 17, 2017 12:55 pm

Re: Problème d'affichage de caractères accentués.

Post by pmleconte » Tue Jan 16, 2018 6:01 pm

encore moi,

la police Acme est une police googlefont : https://fonts.google.com/specimen/Acme? ... amily=Acme

Effectivement, en entrant â, on obtient un accent inversé ???

Sur le site du créateur du font, on a quelques bizarreries : https://www.huertatipografica.com/en

C'est une police hispanique semble-t-il, pas forcément compatible avec les caractères français. Songez à en choisir une autre...

Pascal
Last edited by pmleconte on Tue Jan 16, 2018 6:05 pm, edited 1 time in total.
If anything can go wrong, it will.
https://www.conseilgouz.com/en

chti56
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Jan 23, 2015 5:07 pm

Re: Problème d'affichage de caractères accentués.

Post by chti56 » Tue Jan 16, 2018 6:04 pm

Merci.
Je vais voir sur l'autre forum..
Effectivement Acme est une googlefont. C'est ce que j'avais aussi vu.

Cdt
Jean-Pierre

User avatar
pmleconte
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 206
Joined: Fri Mar 17, 2017 12:55 pm

Re: Problème d'affichage de caractères accentués.

Post by pmleconte » Tue Jan 16, 2018 6:06 pm

Jean-Pierre,

Avez-vous vu le complément à mon message : https://www.huertatipografica.com/en ?

Pascal
If anything can go wrong, it will.
https://www.conseilgouz.com/en

chti56
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Jan 23, 2015 5:07 pm

Re: Problème d'affichage de caractères accentués.

Post by chti56 » Tue Jan 16, 2018 6:26 pm

Pascal,
Je viens juste de le voir.

JP

chti56
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Jan 23, 2015 5:07 pm

Re: Problème d'affichage de caractères accentués.

Post by chti56 » Tue Jan 16, 2018 6:46 pm

Pascal,

En réponse à un de vos messages, je précise que je n'ai ps sélectionné cet police ... en tout cas je ne vois pas où !!
C'est bien pourquoi je n'arrive pas pour le moment à trouver la solution...

Jean-Pierre

User avatar
pmleconte
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 206
Joined: Fri Mar 17, 2017 12:55 pm

Re: Problème d'affichage de caractères accentués.

Post by pmleconte » Wed Jan 17, 2018 7:53 am

chti56 wrote:Pascal,

En réponse à un de vos messages, je précise que je n'ai ps sélectionné cet police ... en tout cas je ne vois pas où !!
C'est bien pourquoi je n'arrive pas pour le moment à trouver la solution...

Jean-Pierre
Bonjour Jean-Pierre,

Cela a l'air de venir de votre template S5. L'avez-vous "customizé" ? on retrouve la définition Acme sur toutes vos pages et Acme fait partie des fonts disponibles S5.

Pascal
If anything can go wrong, it will.
https://www.conseilgouz.com/en

chti56
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Jan 23, 2015 5:07 pm

Re: Problème d'affichage de caractères accentués.

Post by chti56 » Wed Jan 17, 2018 8:50 am

Bonjour Pascal,
Je n'ai pas customisé ce template.
En faisant une recherche de la chaine Acme dans tous les fichiers du site (pour être 'large') je n'ai rien trouvé...

Jean-Pierre

User avatar
pmleconte
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 206
Joined: Fri Mar 17, 2017 12:55 pm

Re: Problème d'affichage de caractères accentués.

Post by pmleconte » Wed Jan 17, 2018 8:57 am

Lorsque tu affiches une page de ton site, si tu cliques droit et demande l'affichage du code source de la page, tu retrouves le terme ACME sur toutes tes pages. Donc cela semble être la police de caractères par défaut.

Au niveau de S5 (j'utilise un autre template, mais, je pense que la logique est la même), il faut aller sur Extensions/Templates/Style et sélectionner ton template.

Dans l'onglet "Main", il faut sélectionner "Styling" et, là, tu dois avoir "Site font" qui te permet de donner la police de caractères par défaut.

Pascal
If anything can go wrong, it will.
https://www.conseilgouz.com/en

chti56
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Jan 23, 2015 5:07 pm

Re: Problème d'affichage de caractères accentués.

Post by chti56 » Wed Jan 17, 2018 11:55 am

Pascal,

J'ai bien cherché... mais je n'ai aucune de ces options pour ce template !!

Jean-Pierre
You do not have the required permissions to view the files attached to this post.

User avatar
pmleconte
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 206
Joined: Fri Mar 17, 2017 12:55 pm

Re: Problème d'affichage de caractères accentués.

Post by pmleconte » Wed Jan 17, 2018 12:04 pm

Jean-Pierre,

L'affichage du paramétrage de votre template est bien cassé.

Il y a eu une grosse mise à jour Vertex (version 4.2.0) pour Joomla 3.8, l'avez-vous faite ? https://www.shape5.com/documentation/Ve ... -Changelog

Voilà à quoi ressemble mon interface S5. Je suis sur un template Soul Search, mais, je pense que vous devriez avoir quelque chose d'approchant.
vertex.jpg
Pascal
You do not have the required permissions to view the files attached to this post.
If anything can go wrong, it will.
https://www.conseilgouz.com/en

chti56
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Jan 23, 2015 5:07 pm

Re: Problème d'affichage de caractères accentués.

Post by chti56 » Wed Jan 17, 2018 12:48 pm

Pascal,

Je n'ai pas vu et donc pas appliquée la mise à jour dont vous parlez.
Je vais voir.

Jean-Pierre

chti56
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Jan 23, 2015 5:07 pm

Re: Problème d'affichage de caractères accentués.

Post by chti56 » Wed Jan 17, 2018 1:14 pm

Merci pour cette info importante.
Je viens d'appliquer le patch comme décrit (par FTP sur mon site local d'abord).
Je retrouve bien toutes les options de personnalisation du thème !!

Merci. Je vais maintenant fouiller pour régler ce problème.

Je te tiens au courant.

Jean-Pierre

chti56
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Jan 23, 2015 5:07 pm

Re: Problème d'affichage de caractères accentués.

Post by chti56 » Wed Jan 17, 2018 5:06 pm

Pascal,

Problème réglé !!! Après avoir appliqué le patch j'ai pu choisir une autre police et je n'ai plus cet affichage bizarre d'un accent circonflexe inversé !!

Un GRAND MERCI pour m'avoir aidé.

Jean-Pierre


Post Reply

Return to “3.x - Questions générales, nouvel utilisateur”