Erreur de connexion MySQL après passage à php7

Support et assistance pour l'utilisation de Joomla! 3.0, 3.1 et 3.5 : administration, gestion du contenu, des menus et des extensions natives... et toutes les autres questions qui n'ont pas de place ailleurs
Post Reply
TThierry
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Feb 17, 2015 7:50 am
Location: France

Erreur de connexion MySQL après passage à php7

Post by TThierry » Wed Nov 04, 2020 11:50 am

Bonjour,

J'ai un site qui utilise joomla 3.3.6. Le serveur utilise la version 5.4 de php et une base de donnée MySQL 5.6. Tout fonctionnait parfaitement. (Merci joomla :) )
J'ai voulu passer à la version 7.0 de php. Mais aussitôt, l'affichage des pages du site a disparu, remplacé par l'erreur suivante:
Error displaying the error page: Application Instantiation Error: Could not connect to MySQL.
Or, joomla recommande la version 7 de php pour faire tourner joomla 3.x
Ma question :
Faut-il modifier quelque chose dans joomla avant de faire la bascule de php 5 vers php 7?
En revenant à php 5 le site s'est remis à fonctionner, mais je souhaite rester à jour et donc basculer vers php7.
Merci pour votre aide.

User avatar
sarki
Joomla! Guru
Joomla! Guru
Posts: 527
Joined: Mon Sep 19, 2005 2:34 pm
Location: Suisse
Contact:

Re: Erreur de connexion MySQL après passage à php7

Post by sarki » Wed Nov 04, 2020 1:48 pm

Bonjour,
Attention, nous sommes à la version 3.9.22 de Joomla, la version 3.3.6 est totalement obsolète et contient de nombreuses failles découvertes depuis qui ont été corrigées, en vérifiant je vois qu'elle a presque 5 ans !
Si vous ne mettez pas à jour Joomla il est normal que vous ne puissiez utiliser une version PHP qui n'existait pas à l'époque de cette ancienne version de Joomla.
De plus vous mettez votre site en danger, il y a régulièrement des sites entièrement supprimés et remplacés par des pages de propagande ou des sites illégaux car ils n'étaient pas à jour.
Lorsqu'un logiciel est créé il peut être considéré comme sûr car personne n'a jamais trouvé de faille de sécurité, puis un jour cela se produit... L'évolution du matériel peut également entraîné de nouvelles failles, c'est pourquoi vous devez toujours maintenir Joomla et les extensions ajoutées à jour.
Cela se fait simplement depuis l'administration et vous reçevez même une notification e-mail lorsqu'une mise à jour est détectée si dans votre profil administrateur vous avez coché de reçevoir les notifications système.

Attention, avant de faire les mises à jour je vous conseille de faire une sauvegarde complète du site, car il se peut que vous ayez une extension tierce ajoutée qui doit être mise à jour avant, cela même s'il n'est pas indiqué qu'une mise à jour soit disponible. Le message d'avertissement se fait que si l'extension est codée en suivant les protocoles Joomla, ce que ne font pas tous les auteurs d'extensions.

L'extension Akeeba Backup est parfaite pour faire des sauvegardes complètes du site avec les éléments de la base de données (articles, configuration, utilisateurs, mots de passe, etc.).
Si cette extension n'est pas déjà installée sur votre site, vous devrez installer une ancienne version en raison de la version PHP du serveur. Voir : https://www.akeeba.com/compatibility.ht ... patibility
French Joomla Translation & Support : www.joomla.fr
French JCE Translation & Support : www.sarki.ch/jce

User avatar
sarki
Joomla! Guru
Joomla! Guru
Posts: 527
Joined: Mon Sep 19, 2005 2:34 pm
Location: Suisse
Contact:

Re: Erreur de connexion MySQL après passage à php7

Post by sarki » Wed Nov 04, 2020 1:50 pm

Note, il existe une traduction en français d'Akeeba Backup, si vous ne l'avez pas dites-le moi, je la mettrai ici en fichier joint ;)
French Joomla Translation & Support : www.joomla.fr
French JCE Translation & Support : www.sarki.ch/jce

TThierry
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Feb 17, 2015 7:50 am
Location: France

Re: Erreur de connexion MySQL après passage à php7

Post by TThierry » Thu Nov 05, 2020 7:04 am

Bonjour Sarki,

Merci pour ces réponses. Je vais mettre à jour mon site en espérant que ça résolve le problème. J'avais installé Akeeba back up donc pas de souci de ce coté là.
Curieusement, ma page d'administration du site me dit que joomla est à jour, ce qui est faux si j'en crois votre email.
Je reviendrai ici pour dire si la manip a réussi et si elle a permis de résoudre le problème. Ce qui me fait douter est que la version que j'utilise (joomla3.3.6) est déjà censée fonctionner avec php 7.

TThierry
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Feb 17, 2015 7:50 am
Location: France

Re: Erreur de connexion MySQL après passage à php7

Post by TThierry » Thu Nov 05, 2020 7:24 am

Re bonjour,

La sauvegarde avec Akeeba s'est bien passée.
J'ai vidé le cache des mises à jour du panneau de contrôle et maintenant joomla me propose une mise à jour, mais pas vers 3.9.22, seulement vers 3.6.5.
Une idée de l'explication?
J'attends d'en savoir plus pour poursuivre.

User avatar
sarki
Joomla! Guru
Joomla! Guru
Posts: 527
Joined: Mon Sep 19, 2005 2:34 pm
Location: Suisse
Contact:

Re: Erreur de connexion MySQL après passage à php7

Post by sarki » Thu Nov 05, 2020 7:41 am

Joomla 3.3.6 a été mis à dispo le 1.10.2014 alors que PHP 7 a été mis à dispo le 3.12.2015, votre version n'est donc pas compatible, sans parler du fait que la version PHP que propose votre hébergeur n'est certaiment pas la 7.0 ;)
D'après le message d'erreur il s'agit d'un problème de connexion à la base de données, je ne pense donc pas que l'incompatibilité vienne d'une extension tierce mais ce n'est pas impossible non plus.

Pourquoi vous n'avez pas de message de mise à jour pour Joomla depuis 6 ans est bien étonnant, je me souviens qu'il y a eu une version qui a eu un problème à ce niveau, mais en vérifiant il semble que c'est la 3.4 : https://docs.joomla.org/J3.x:Upgrading_ ... _to_3.5/fr
Si vous n'avez jamais eu non plus de message de mise à jour pour les extensions, alors il est possible que cela vienne d'un paramètre qui n'est pas activé sur le serveur.
Vous avez ici un tuto sur le processus de mise à jour de Joomla : https://docs.joomla.org/J3.x:Updating_J ... Method)/fr

Conclusion
Pour effectuer les mises à jour de Joomla, vous allez devoir le faire par étape, vous n'allez pas pouvoir passer à la dernière version depuis la 3.3.6
Personnelement je passerai déjà à la version 3.5.0 en l'installant manuellement, la liste des versions est ici :
https://downloads.joomla.org/cms/joomla3/
Puis je vérifierai si la détection de mises à jour fonctionne, pour savoir si le problème venait de l'ancienne version de Joomla ou d'un paramètre qui n'est pas activé sur le serveur.
Redites-moi si vous avez besoin d'aide ;)
French Joomla Translation & Support : www.joomla.fr
French JCE Translation & Support : www.sarki.ch/jce

TThierry
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Feb 17, 2015 7:50 am
Location: France

Re: Erreur de connexion MySQL après passage à php7

Post by TThierry » Thu Nov 05, 2020 7:53 am

Encore une fois merci Sarki pour ces infos.
Entretemps j'ai fait la mise à jour vers 3.6.5 qui m'était proposée. Ça s'est bien passé.
Seulement, à la fin joomla m'a demandé un identifiant et un mot de passe correspondant à mon site pour la finaliser. J'ai entré mon identifiant et mon mot de passe d'administrateur, mais ils ne sont pas reconnus. S'agit-il d'autres identifiants que joomla attend? lesquels? J'ai du cliquer sur "cancel", donc la finalisation ne s'est pas faite.
La bonne nouvelle est que maintenant joomla me propose la version 3.9.22. Seulement la mise à jour ne peut pas se faire à cause d'un "mot de passe incorrect". sans doute celui qu'il me demandait après la précédente mise à jour car à ce stade il ne me redemande pas de mot de passe.
De quel mot de passe s'agit-il?

User avatar
sarki
Joomla! Guru
Joomla! Guru
Posts: 527
Joined: Mon Sep 19, 2005 2:34 pm
Location: Suisse
Contact:

Re: Erreur de connexion MySQL après passage à php7

Post by sarki » Thu Nov 05, 2020 8:01 am

Super, peut-être que la tentative de mise à jour a réussi à corriger le problème.
Le mot de passe demandé est celui du compte Joomla, mais sauf erreur il doit être d'un niveau d'accès "Super Utilisateur", votre compte est bien de ce niveau ?
French Joomla Translation & Support : www.joomla.fr
French JCE Translation & Support : www.sarki.ch/jce

TThierry
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Feb 17, 2015 7:50 am
Location: France

Re: Erreur de connexion MySQL après passage à php7

Post by TThierry » Thu Nov 05, 2020 8:24 am

La bonne idée était en effet de faire la mise à jour par étape. J'en suis donc à 3.6.5.
Oui mon compte joomla est bien de niveau super utilisateur. Mais le mot de passe n'est pas reconnu quand joomla me le demande pour finaliser la mise à jour. Or il fonctionne toujours, j'ai réussi à me connecter à mon compte sans problème.
Ni dans le tuto, ni dans la doc joomla je n'ai vu qu'on demandait un mot de passe APRES la mise à jour pour la finaliser. C'est curieux. Du coup, pour l'instant, pas possible de passer à la dernière version.
Est-ce que ça pourrait venir du programme de mise à jour de joomla qui ne serait lui-même plus à jour?
Voici ce que j'ai sur l'écran update sites. Est-ce que ça révèle un problème?
You do not have the required permissions to view the files attached to this post.

User avatar
sarki
Joomla! Guru
Joomla! Guru
Posts: 527
Joined: Mon Sep 19, 2005 2:34 pm
Location: Suisse
Contact:

Re: Erreur de connexion MySQL après passage à php7

Post by sarki » Thu Nov 05, 2020 11:00 am

Question : c'est normal que le site soit en anglais et qu'il utilise ce template d'administration ?
La capture ne montre rien d'anormal, et c'est normal que Joomla demande un mot de passe pour finaliser l'installation de la mise à jour, si je me souviens bien c'est parce qu'un nouveau processus lié aux mots de passe a été implémenté, il y a une ou deux versions de joomla 3 où cela est demandé.
Par contre il n'est pas normal que le mot de passe ne fonctionne pas...
Personnellement j'essaierai de créer un nouveau compte Super Utilisateur et j'essaierai de faire la mise à jour avec, si cela ne passe pas le problème est ailleurs.
Essaie encore ça, si cela ne fonctionne pas tu peux me faire un compte provisoire si tu veux et me contacter directement par mail ou message privé pour me donner les accès, j'irai voir de l'intérieur ce qu'il en est.
French Joomla Translation & Support : www.joomla.fr
French JCE Translation & Support : www.sarki.ch/jce

TThierry
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Feb 17, 2015 7:50 am
Location: France

Re: Erreur de connexion MySQL après passage à php7

Post by TThierry » Sat Nov 07, 2020 10:37 am

Je vais faire l'essai que tu recommandes.
L'anglais n'est pas un problème pour moi, donc je ne m'en suis pas occupé. Je n'ai jamais modifié le template d'administration. J'utilise un template appelé purityIII pour le site. Peut-être que le template d'administration va avec?
Je te tiens au courant. Merci encore pour ton support. Pour l'instant, tout fonctionne sur le site (il est accessible et les affichages se font bien, ainsi que l'édition des articles). Ça pourrait rester comme ça mais je voudrais passer à joomla 3.9 pour suivre tes conseils.

User avatar
sarki
Joomla! Guru
Joomla! Guru
Posts: 527
Joined: Mon Sep 19, 2005 2:34 pm
Location: Suisse
Contact:

Re: Erreur de connexion MySQL après passage à php7

Post by sarki » Sat Nov 07, 2020 12:49 pm

Si tu n'as jamais changé le template d'administration alors je suis surpris, je connais très bien le template Purity que j'ai utilisé à une époque et que j'avais traduit en partie, il ne concerne que le frontal.
Le template par défaut de Joomla en administration est le Isis et non le Hathor qui lui a été créé pour répondre aux normes d'accessibilité pour personnes handicapées, il n'est pas très convivial à mon goût mais après c'est une question d'habitude ;)
French Joomla Translation & Support : www.joomla.fr
French JCE Translation & Support : www.sarki.ch/jce


Post Reply

Return to “3.x - Questions générales, nouvel utilisateur”