Går i stå midt i installationen

Her kan du søge hjælp til installation og opdatering, og stille spørgsmål om webhosts.

Moderators: b-ronnow, General Support Moderators

Forum rules
Locked
User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 5:07 pm

Hej

Jeg har brugt et par dage på at lære om Joomla og har lært en masse via http://www.buildajoomlawebsite.com/ og http://www.joomlashine.com/

Jeg har prøvet at lave en ny installation af ver. 2.5 på min localhost men ved min operationer meddeler joomla, at der er alle mulige forskellige databasefejl fx manglende felter. Jeg har prøvet at installere flere gang, men hver gang fejler den.

Da jeg ikke kan installere 2.5, vil jeg så prøve 3.2, men her gå den i stå i installationen, der sker ikke noget. Jeg får billedet:

Installerer...
Laver backup af gamle database tabeller
Opretter databasetabeller
Opretter konfigurationsfil
Sender email til post@stegemueller.dk

Og så sker der ikke mere. Jeg har prøvet flere gange.

Hvad gør jeg så?

Jeg vil være glad for hjælp, for jeg vil jo gerne i gang rigtigt.

Venlig hilsen
Hanne B. Stegemüller
Venlig hilsen
Hanne B. Stegemüller

 
User avatar
Sonderup
Joomla! Explorer
Joomla! Explorer
Posts: 476
Joined: Thu Aug 18, 2005 8:22 pm
Location: Hadsten
Contact:

Re: Går i stå midt i installationen

Post by Sonderup » Tue Apr 29, 2014 6:06 pm

Hej Hanne,

Hvilken PHP version har du på din server?
Med venlig hilsen
Michael Sønderup Nielsen
Seniorudvikler / Joomla Ekspert

https://joomlakonsulenten.dk

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 6:23 pm

Hej Michael

Tak for din interesse i mit problem.

Jeg har tjekket i http://localhost/xampp/ og der står der, at php-versionen er 5.4.7
Venlig hilsen
Hanne B. Stegemüller

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 6:24 pm

Glemte at fortælle, at jeg på min localhost kører med XAMPP 1.8.1
Venlig hilsen
Hanne B. Stegemüller

User avatar
Sonderup
Joomla! Explorer
Joomla! Explorer
Posts: 476
Joined: Thu Aug 18, 2005 8:22 pm
Location: Hadsten
Contact:

Re: Går i stå midt i installationen

Post by Sonderup » Tue Apr 29, 2014 6:38 pm

Hjælper gerne...

Du beskriver forløbet således:
Installerer...
Laver backup af gamle database tabeller
Opretter databasetabeller
Opretter konfigurationsfil
Sender email til post@stegemueller.dk
Det kunne tyde på, at du ikke kan sende mails fra din localhost. Må indrømme at jeg ikke lige kan huske, om man kan undlade at få tilsendt mailen. Kan man det, så prøv det.
Med venlig hilsen
Michael Sønderup Nielsen
Seniorudvikler / Joomla Ekspert

https://joomlakonsulenten.dk

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 6:48 pm

Hej Michael

Jeg tjekkede lige: mailadressen er et krævet felt.
Venlig hilsen
Hanne B. Stegemüller

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 6:59 pm

Jeg prøvede lige noget andet, nemlig at angive et password til databasen, som jeg ellers har ladet stå blank.

Jeg får nu fejlen:
notice
Kunne ikke tilslutte til databasen. Forbindelsen returnerede fejl/nummer: Could not connect to MySQL.

Jeg har prøvet både selv at oprette databasen joomla32 og at lade installationsscriptet gøre det. Samme resultat og det uanset om jeg vælger MySQLi eller MySQL
Venlig hilsen
Hanne B. Stegemüller

User avatar
Sonderup
Joomla! Explorer
Joomla! Explorer
Posts: 476
Joined: Thu Aug 18, 2005 8:22 pm
Location: Hadsten
Contact:

Re: Går i stå midt i installationen

Post by Sonderup » Tue Apr 29, 2014 7:04 pm

Fejlen fortæller, at den ikke kunne forbinde til databasen, fordi en eller flere oplysninger er forkerte.

Du har sikkert allerede dobbelt tjekket om databasenavn, brugernavn og kodeordet er korrekt? ;o)

Du skal altid vælge MySqli.
Med venlig hilsen
Michael Sønderup Nielsen
Seniorudvikler / Joomla Ekspert

https://joomlakonsulenten.dk

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 7:27 pm

Jeg har tjekket mange gange :-) og jeg lader jo egl. Joomla om at oprette brugeren via installationsscriptet, så det kan næppe være forkert. Jeg har tjekket at databasen findes og at den hedder joomla32, som er det jeg angiver i konfigurationen. Er det ikke rigtigt, at man ved at udfylde felterne, lader Joomla generere configfilen?

Fejlen med ikke at kunne connecte til databasennu kommer nu hvor jeg udfylder alle felter. I starten lod jeg password være blankt.

Det er alt sammen meget underligt, for jeg har tidligere haft installeret 2.5, hvor det gik helt glat. Jeg er i startfasen og har behov for at øve mig med forskellige ting, så derfor har jeg prøvet nogle gange.
Venlig hilsen
Hanne B. Stegemüller

User avatar
Sonderup
Joomla! Explorer
Joomla! Explorer
Posts: 476
Joined: Thu Aug 18, 2005 8:22 pm
Location: Hadsten
Contact:

Re: Går i stå midt i installationen

Post by Sonderup » Tue Apr 29, 2014 7:33 pm

Det er korrekt at Joomla selv genererer configuration.php.

- Jeg ville prøve at oprette en helt ny database med brugernavn og kodeord.
- Dernæst slet Joomla filerne i den pågældende folder og "upload" en frisk Joomla.
- Start installeren...

Det burde være lige til, hvis XAMP er opsat korrekt.
Med venlig hilsen
Michael Sønderup Nielsen
Seniorudvikler / Joomla Ekspert

https://joomlakonsulenten.dk

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 7:35 pm

Jeg prøvede lige at slette databasen i MySQL, og dermed lade Joomla oprette den via installationen. Herefter tjekkede jeg igen i MySQL og der kan jeg se, at den kommer så langt som til at oprette databasen, men den opretter ikke tabellerne.

Dette var en situation, hvor jeg ikke angav et password til brugeren 'root'
Venlig hilsen
Hanne B. Stegemüller

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 7:36 pm

Bahnhof wrote:Det er korrekt at Joomla selv genererer configuration.php.

- Jeg ville prøve at oprette en helt ny database med brugernavn og kodeord.
- Dernæst slet Joomla filerne i den pågældende folder og "upload" en frisk Joomla.
- Start installeren...

Det burde være lige til, hvis XAMP er opsat korrekt.
Det prøver jeg lige, og så vender jeg tilbage med hvordan det er gået. Du skal igen have tak for din interesse.
Venlig hilsen
Hanne B. Stegemüller

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 7:50 pm

Så er det forsøgt

- Slettede på forhånd databasen joomla32 vha 'drop' kommandoen i mysql
- Angav e-mail, brugernavn og adgangskode i Generel konfiguration
- i Databasekonfiguration angav jeg MySQLi, host, bruger root og en adgangskode samt databasenavn joomla32
- klikkede 'næste' og fik

Code: Select all

notice
Kunne ikke tilslutte til databasen. Forbindelsen returnerede fejl/nummer: Could not connect to MySQL.
Jeg kunne se, at scriptet ikke oprettede databasen. Det gjorde jeg så selv i phpMyAdmin. Men fejlen jeg får, er den samme.

Er det ikke bare højst besynderligt?
Vil du råde mig til alligevel at prøve ver. 2.5. og så lægge et spm. i det rette forum, hvis det stadig ikke lykkes?
Venlig hilsen
Hanne B. Stegemüller

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 7:53 pm

Stegemueller wrote:
Bahnhof wrote: Det burde være lige til, hvis XAMP er opsat korrekt.
.
PS: Jeg har ingen mistanke til min XAMPP, den plejer da at fungere.
Venlig hilsen
Hanne B. Stegemüller

User avatar
Sonderup
Joomla! Explorer
Joomla! Explorer
Posts: 476
Joined: Thu Aug 18, 2005 8:22 pm
Location: Hadsten
Contact:

Re: Går i stå midt i installationen

Post by Sonderup » Tue Apr 29, 2014 7:56 pm

Er der nogle tabeller i databasen?
Med venlig hilsen
Michael Sønderup Nielsen
Seniorudvikler / Joomla Ekspert

https://joomlakonsulenten.dk

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 8:25 pm

Nej databasen er helt tom
Venlig hilsen
Hanne B. Stegemüller

User avatar
Sonderup
Joomla! Explorer
Joomla! Explorer
Posts: 476
Joined: Thu Aug 18, 2005 8:22 pm
Location: Hadsten
Contact:

Re: Går i stå midt i installationen

Post by Sonderup » Tue Apr 29, 2014 8:26 pm

Har brugeren "root" alle rettigheder i databasen? Altså, har "root" tilladelse til at oprette tabeller.
Med venlig hilsen
Michael Sønderup Nielsen
Seniorudvikler / Joomla Ekspert

https://joomlakonsulenten.dk

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 8:28 pm

Nu prøvede jeg lige for sjov med version 2.5 også, og der får jeg også: "Kunne ikke tilslutte til databasen. Forbindelsen returnerede nummer: Unable to connect to the Database: Could not connect to MySQL." altså må det være et eller andet med MySQL?

Se bort fra dette svar. Jeg lavede en dum fejl, og fik ikke indtastet bruger root
Last edited by Stegemueller on Tue Apr 29, 2014 8:32 pm, edited 1 time in total.
Venlig hilsen
Hanne B. Stegemüller

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 8:29 pm

Bahnhof wrote:Har brugeren "root" alle rettigheder i databasen? Altså, har "root" tilladelse til at oprette tabeller.
Jeg er ret sikker på at jeg har set, at root har alle rettigheder, men hvor er det nu jeg tjekker det igen?
Venlig hilsen
Hanne B. Stegemüller

User avatar
Sonderup
Joomla! Explorer
Joomla! Explorer
Posts: 476
Joined: Thu Aug 18, 2005 8:22 pm
Location: Hadsten
Contact:

Re: Går i stå midt i installationen

Post by Sonderup » Tue Apr 29, 2014 8:30 pm

Det kan du se via PhpMyAdmin.
Med venlig hilsen
Michael Sønderup Nielsen
Seniorudvikler / Joomla Ekspert

https://joomlakonsulenten.dk

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 8:34 pm

Åh ja tak skal du have.

Code: Select all

root, linux, Nej, ALL PRIVILEGES 
Venlig hilsen
Hanne B. Stegemüller

User avatar
Sonderup
Joomla! Explorer
Joomla! Explorer
Posts: 476
Joined: Thu Aug 18, 2005 8:22 pm
Location: Hadsten
Contact:

Re: Går i stå midt i installationen

Post by Sonderup » Tue Apr 29, 2014 8:36 pm

Kan du tage et screen dump af Roots rettigheder?
Med venlig hilsen
Michael Sønderup Nielsen
Seniorudvikler / Joomla Ekspert

https://joomlakonsulenten.dk

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 8:39 pm

Ja det kan jeg, det kommer her
You do not have the required permissions to view the files attached to this post.
Venlig hilsen
Hanne B. Stegemüller

User avatar
Sonderup
Joomla! Explorer
Joomla! Explorer
Posts: 476
Joined: Thu Aug 18, 2005 8:22 pm
Location: Hadsten
Contact:

Re: Går i stå midt i installationen

Post by Sonderup » Tue Apr 29, 2014 8:43 pm

Prøv at ændre brugernavn "root" til noget andet samt indsætte et kodeord.

Prøv at køre installeren igen og indsætte det nye brugernavn og kodeord.
Med venlig hilsen
Michael Sønderup Nielsen
Seniorudvikler / Joomla Ekspert

https://joomlakonsulenten.dk

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 8:50 pm

Bahnhof wrote:Prøv at ændre brugernavn "root" til noget andet samt indsætte et kodeord.

Prøv at køre installeren igen og indsætte det nye brugernavn og kodeord.
Jeg må hellere oprette en ny bruger og et password i MySQL (root er i brug til andre applikationer) men hvordan er det nu jeg opretter en ny bruger?
Venlig hilsen
Hanne B. Stegemüller

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 8:50 pm

Jeg er for dum
Jeg har fundet det
Venlig hilsen
Hanne B. Stegemüller

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 9:03 pm

Jeg har oprettet en bruger 'root2' med alle privilegier, password er også 'root2'.

Når jeg prøver at køre installeren får jeg straks denne meddelelse:

Code: Select all

Kunne ikke tilslutte til databasen. Forbindelsen returnerede fejl/nummer: Could not connect to MySQL.
Venlig hilsen
Hanne B. Stegemüller

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 9:07 pm

Jeg kigger lidt rundt i phpMyAdmin og finder denne tekst under brugertabellen:

Code: Select all

Forbindelse for kontrolbruger som defineret i din konfiguration slog fejl.
Har det nogen betydning for det vi arbejder med?
Venlig hilsen
Hanne B. Stegemüller

User avatar
Stegemueller
Joomla! Apprentice
Joomla! Apprentice
Posts: 34
Joined: Mon Jan 07, 2008 6:12 pm
Location: København
Contact:

Re: Går i stå midt i installationen

Post by Stegemueller » Tue Apr 29, 2014 9:21 pm

Det er sørme lykkedes vha. bruger 'root2' og pass code 'root2'. Jeg opdagede, at jeg havde lavet en fejl ved oprettelsen af brugeren i phpMyAdmin; jeg havde ikke sat værten til localhost. Herefter kørte installeren straks igennem.

Mange tak for din hjælp og bistand! :)
Venlig hilsen
Hanne B. Stegemüller

User avatar
Sonderup
Joomla! Explorer
Joomla! Explorer
Posts: 476
Joined: Thu Aug 18, 2005 8:22 pm
Location: Hadsten
Contact:

Re: Går i stå midt i installationen

Post by Sonderup » Wed Apr 30, 2014 6:53 am

Godt vi fandt fejlen.

Hjælper gerne! :)
Med venlig hilsen
Michael Sønderup Nielsen
Seniorudvikler / Joomla Ekspert

https://joomlakonsulenten.dk

 

Locked

Return to “Installation, backup, opdatering og flytning - Godt igang”