Upgrade naar 3.4.8 stopt op 90%

Installatie van Joomla! 3.x(= Short Term Support versie)

Moderator: pe7er

Forum rules
Forum Regels
Nico Meurders
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Feb 23, 2016 9:56 pm

Upgrade naar 3.4.8 stopt op 90%

Postby Nico Meurders » Tue Feb 23, 2016 10:29 pm

Hallo,
ik heb al een aantal keer geprobeerd mijn 2.5 website te upgraden naar de laatste 3.4.
Ik heb een backup van mijn live-site geïnstalleerd in een aparte test-website, alle tabellen in mijn tets-database verwijderd,alle niet-Joomla extensies uitgeschakeld en vervolgens de upgrade gedraaid. op ongeveer 90% van het proces stopt de upgrade en krijg ik een heel lange foutmelding, die begint met:

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /administrator/index.php.

Reason: Corrupt status line returned by remote server: HTTP/1.1 500 Duplicate entry '1' for key 'PRIMARY' SQL=-- -- Dumping data for table `josn_content_types` -- INSERT INTO `josn_content_types` (`type_id`, `type_title`, `type_alias`, `table`, `rules`, `field_mappings`,`router`) VALUES (1, 'Article', 'com_content.article', '{"special":{"dbtable":"#__content","key":"id","type":"Content","prefix":"JTable","config":"array()"},"common":{"dbtable":"#__core_content","key":"ucm_id","type":"Corecontent","prefix":"JTable","config":"array()"}}', '',

Kan iemand een suggestie doen waar ik verder mee kom?
Groeten,
Nico
Last edited by toivo on Wed Feb 24, 2016 5:06 pm, edited 1 time in total.
Reason: mod note: moved to the Dutch forum

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18713
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Upgrade naar 3.4.8 stopt op 90%

Postby leolam » Wed Feb 24, 2016 3:17 pm

Nico, je hebt gepost in het Global forum en de taal is Engels hier. (You have posted in the global forum and the language is English here).

This error is triggered when an SSL connection is configured from the browser to Apache, and Apache does a reverse proxy to your server. Virtual Hosts are getting mixed up. In short, the server name presented is that of the reverse DNS resolution of the IP, not the one in the URL.

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

Nico Meurders
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Feb 23, 2016 9:56 pm

Re: Upgrade naar 3.4.8 stopt op 90%

Postby Nico Meurders » Wed Feb 24, 2016 4:25 pm

Hello Leo,
thank you for your response.
I am sorry for not posting in English, didn't know about that.
But what do i have to do, to avoid the mentioned error?
Or do I have to ask the webhost?
Kind regards,
nico

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18713
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Upgrade naar 3.4.8 stopt op 90%

Postby leolam » Wed Feb 24, 2016 4:27 pm

Contact the host and post
The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /administrator/index.php.
as well as my response. They will help you

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

hvdmeer
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 129
Joined: Mon May 13, 2013 1:34 pm
Location: Arnhem
Contact:

Re: Upgrade naar 3.4.8 stopt op 90%

Postby hvdmeer » Wed Feb 24, 2016 5:24 pm

[offtopic]Je onderwerp staat inmiddels in het Nederlandstalige gedeelte van dit forum. ;)
Assistant Team Leader Joomla! Social Media Team
J!Docs translator - Joomla User Group Arnhem Organizer - Wannabe Patch tester
Personal site: https://www.hierbenikthuis.nl
Moderator on joomlacommunity.nl

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18713
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Upgrade naar 3.4.8 stopt op 90%

Postby leolam » Thu Feb 25, 2016 2:14 am

Kleine correctie: Het is jouw topic.... Ik probeer alleen te helpen

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

Nico Meurders
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Feb 23, 2016 9:56 pm

Re: Upgrade naar 3.4.8 stopt op 90%

Postby Nico Meurders » Thu Feb 25, 2016 10:11 am

Beste Leo en hvdmeer,
dank voor jullie reacties.
Ik heb inmiddels contact gehad met mijn host en die stuurt de volgende aanbeveling:
'Ik heb de melding even bekeken en zie dat het opnieuw gaat om "Duplicate entry '1' for key 'PRIMARY'" dit betekend dat er iets geïmporteerd wordt, waar al data in staat met de zelfde ID, we kunnen hierin geen ondersteuning bieden.
Ik weet niet exact wat de mogelijkheden zijn van Kickstarter, maar als je enkel de bestanden kunt back-uppen, dan kun je zelf bijv. m.b.v. database exporteren en database importeren de database back-uppen en overzetten, mogelijk levert dat geen problemen op'

Aangezien het probleem zich voordoet bij de upgrade, nadat ik een nieuwe testsite heb opgezet met Kickstart en de backup, heb ik niet het idee dat deze aanbeveling mij verder helpt.
Hebben jullie wellicht nog adviezen?

Met vriendelijke groeten,
Nico

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18713
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Upgrade naar 3.4.8 stopt op 90%

Postby leolam » Thu Feb 25, 2016 2:55 pm

I believe you still have incompatible extensions installed on the site. Extensions include "packages" modules/plugins/templates/languages/components/etc anything that can be installed. You can review these in Extension -->Manage. Check them out 1 by one. Anything from Peter van Westen (Nonumber? : remove

Every single extension needs to be checked and either updated or uninstalled before updating from 2.5 to 3. 4

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team


Return to “Installatie 3.x”

Who is online

Users browsing this forum: No registered users and 2 guests