Joomla 3.7, todavia con JS antiguas

Para cualquier tema sobre Joomla que no sea de soporte: anuncios oficiales, JoomlaDays, JUGs, magazine...

Moderators: carcam, hefesto

sach1988
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Sep 15, 2017 3:07 pm

Joomla 3.7, todavia con JS antiguas

Postby sach1988 » Fri Sep 15, 2017 3:38 pm

Hola comunidad.

"Si bien es cierto las librerías Java adicionales aportan una experiencia de usuario agradable, si no se gestionan adecuadamente o no se actualizan con frecuencia representan un gran riesgo para la integridad de los sitios web y por lo tanto la disponibilidad, confidencialidad e integridad de la información. En este caso particular, durante el muestreo general de la aplicación se detectó que la aplicación tiene o usa bases de la librería “jQuery” (jquery-ui-autocomplete versión 1.8.23), la cual hace referencia a librerías liberadas en 2012, si bien es cierto, dada la premura de las pruebas realizadas y teniendo en cuenta que el realizar vectores de ataque avanzados sobre dicha librería comprometería al sitio y sus componentes, no se realizó una explotación avanzada y a profundidad que permitiera evidenciar aún más la vulnerabilidad actual, se recomienda verificar el uso y actualización de la librería, dado que para la misma existen múltiples vulnerabilidades y vectores de ataque documentados"


pues revisando las librerias de javascript del joomla 3.7, en especial las de jQuery como las de Query UI, están versiones muy antiguas (jQuery UI - v1.9.2 - 2013-07-14; jQuery JavaScript Library v1.12.4 estando en la actualidad v3.2.1)

esto da entender que prima la funcionalidad que la seguridad?.

existe una actualizar las librerias de JS sin comprometer la funcionalidad del sitio y mitigar los riesgos de ataques y comprometer el sitio web?

muchas gracias.

User avatar
mjparadac
Joomla! Ace
Joomla! Ace
Posts: 1393
Joined: Mon Oct 29, 2012 3:58 pm

Re: Joomla 3.7, todavia con JS antiguas

Postby mjparadac » Tue Sep 19, 2017 5:17 pm

Hola sach1988, bienvenido al foro

Este extension https://extensions.joomla.org/extension/jquery-easy/ podría servirle para poder contrarrestar cualquier tipo de inconveniente con librerías jquery.

Saludos,
Joomla Community Ambassador for A2 Hosting | A2 Hosting - Our speed, your success | https://www.a2hosting.com/joomla-hosting?utm_campaign=grassroots&utm_medium=forum&utm_source=joomla.org


Return to “Salón de la comunidad Ñ”

Who is online

Users browsing this forum: No registered users and 1 guest