Probleem met Sigplus foto gallery

Moderator: pe7er

Forum rules
Forum Regels
Post Reply
LoesW
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Oct 21, 2007 3:00 pm

Probleem met Sigplus foto gallery

Post by LoesW » Thu Oct 22, 2020 8:12 am

Voor mijn site https://www.natuurstichtingkadans.nl/ gebruik ik al jaren
sigplus Image Gallery Plus
. Het is gemaakt voor Joomla 1.x en 2.x. Inmiddels gebruik ik het ook in Joomla 3.9.22, maar heb ik problemen met de weergave van staande foto's. In de verkenner worden de foto's in diverse programma's juist weergegeven. In Sigplus kan het zijn dat de kleine foto in orde is, maar de grote niet. Of juist andersom.
Voorbeelden:
https://www.natuurstichtingkadans.nl/te ... ember-2019 staande foto's worden in het grote formaat liggend weergegeven.
https://www.natuurstichtingkadans.nl/te ... tober-2020 foto 22 en 25.
Wie weet raad?
Kind regards from Loes

I use Joomla 3.9.x and PHP 7

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2886
Joined: Sun May 04, 2008 12:37 pm

Re: Probleem met Sigplus foto gallery

Post by waarnemer » Thu Oct 22, 2020 8:21 am

Heb je het al opgelost? Ik zie niets geks. Behalve dan dat de eerste rij verschoven is.
Alles komt uit de cache preview.

LoesW
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Oct 21, 2007 3:00 pm

Re: Probleem met Sigplus foto gallery

Post by LoesW » Thu Oct 22, 2020 9:55 am

Hallo Waarnemer
Er is nog niets opgelost. Mijn standaard browser is Chrome. In Firefox en Edge gaat het op pagina https://www.natuurstichtingkadans.nl/te ... ember-2019 ook fout met alle staande foto's. De preview is in orde, klik je er een aan, dan opent die dwars.
Op mijn smartphone gaat het wel goed!
Kind regards from Loes

I use Joomla 3.9.x and PHP 7

LoesW
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Oct 21, 2007 3:00 pm

Re: Probleem met Sigplus foto gallery

Post by LoesW » Thu Oct 22, 2020 11:51 am

Onderaan pagina https://www.natuurstichtingkadans.nl/te ... ember-2019 heb ik het tweede album van die pagina ook nog met ppgallery opgenomen. Het probleem met de staande foto's blijft.
De eerste rij foto's is nu niet meer verschoven zoals bij de Sigplus albums. Pluspuntje voor ppgallery dus.
Kind regards from Loes

I use Joomla 3.9.x and PHP 7

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2886
Joined: Sun May 04, 2008 12:37 pm

Re: Probleem met Sigplus foto gallery

Post by waarnemer » Thu Oct 22, 2020 12:10 pm

Mja nu snap ik wat je bedoelt.. ik zat naar de grootte van het bestand te kijken.. ;)

Het is de browser die het het exif attribuut "orientation" niet respecteert.
Het plaatje is gemaakt op een FUJI T10 en de camera is op z'n kant gehouden.
De camera zelf kan dat dus wel detecteren, de browser die het moet laten zien.. niet.

daar is, beter was want eigenlijk deprecated, CSS property "image-orientation" voor.
https://developer.mozilla.org/en-US/doc ... rientation

Beter om de plaatjes te optimaliseren inclusief het draaien.

LoesW
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Oct 21, 2007 3:00 pm

Re: Probleem met Sigplus foto gallery

Post by LoesW » Thu Oct 22, 2020 12:20 pm

De foto's op mijn site worden door verschillende mensen en met verschillende camera's of smartphones gemaakt.
Bedankt voor de tip. Ik heb de staande foto's in het album van november op mijn PC een keer liggend en daarna weer staand gemaakt (gewoon selecteren in de Verkenner en kiezen voor rechtsom en dan linksom draaien) en opnieuw geupload. Nu worden ze in 3 browsers en beide gallery plugins juist getoond.
Probleem opgelost dus denk ik.
Kind regards from Loes

I use Joomla 3.9.x and PHP 7


Post Reply

Return to “Algemene vragen”