Problemen in mainmenu met settings public en registered

Moderator: pe7er

Forum rules
Forum Regels
Post Reply
DirkBDS
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Nov 14, 2018 8:12 am

Problemen in mainmenu met settings public en registered

Post by DirkBDS » Wed Nov 14, 2018 8:24 am

Hoi,

Sinds de upgrade naar 3.9.0 loop ik tegen het volgende probleem aan.
Website gebruikt de standaard mainmenu. In dit menu zitten ook enkel subitems verwerkt. Enkele van die items zijn "public", dus voor iedereen toegankelijk, andere zijn enkel toegankelijk als geregistreerd gebruiker.

Wat ik ondertussen heb opgemerkt is dat wanneer er maar één artikel aan een menu-item wordt gekoppeld en ingesteld staat op public, er geen probleem is. Van zodra het menu-item één public artikel heeft en sub-items heeft die op registered ingesteld staan, krijg ik een 500 foutmelding.

Iemand dit ook al meegemaakt en een oplossing hiervoor heeft?

url: newinfo.abcministries.be
Joomla! 3.9.0
PHP versie 7.1
Webserver nginx/1.6.2

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2032
Joined: Sun May 04, 2008 12:37 pm

Re: Problemen in mainmenu met settings public en registered

Post by waarnemer » Wed Nov 14, 2018 12:42 pm

ik zie in je voorbeeld geen sub items in het menu.
is dit voorbeeld een schone 3.9.0 of een update van 3.8?


... heb je htaccess.txt netjes omgezet naar .htaccess?

DirkBDS
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Nov 14, 2018 8:12 am

Re: Problemen in mainmenu met settings public en registered

Post by DirkBDS » Wed Nov 14, 2018 2:40 pm

Hoi,
De sub items zijn enkel voor geregistreerde gebruikers.

Clean 3.9.0 en yup .htaccess

User avatar
Rondeb
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Mon Dec 02, 2013 12:14 pm
Location: Meschede - Germany
Contact:

Re: Problemen in mainmenu met settings public en registered

Post by Rondeb » Wed Nov 14, 2018 6:14 pm

Hallo,

hernoem je .htaccess eens naar htaccess.txt

En bij algemene instellingen zet daar URL herschrijven eens uit.
Kijk nu of de menu items die public zijn wel werken.

Groeten Ron ;)

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2032
Joined: Sun May 04, 2008 12:37 pm

Re: Problemen in mainmenu met settings public en registered

Post by waarnemer » Wed Nov 14, 2018 7:36 pm

Mm ja gek.. dat had ik vanmiddag ook gepost maar het is blijkbaar niet aangekomen..

Ik schreef iets van:

Overheen gelezen, je gebruikt nginx ipv apache... als je sef seo uitzet en .htaccess terug naar htaccess.txt zou die het weer moeten doen...

(zie zelfde als @Rondeb)

Kijk dan op https://docs.joomla.org/Nginx en https://docs.joomla.org/Enabling_Search ... s_on_Nginx

DirkBDS
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Nov 14, 2018 8:12 am

Re: Problemen in mainmenu met settings public en registered

Post by DirkBDS » Wed Nov 14, 2018 11:10 pm

Bedankt voor de reacties. Jammer maar helaas ...

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2032
Joined: Sun May 04, 2008 12:37 pm

Re: Problemen in mainmenu met settings public en registered

Post by waarnemer » Thu Nov 15, 2018 9:52 am

Heb je cache enabled? Wat als je het uitzet?
En kun je voor de SEF uitzetten? Als ik kijk staat het nog enabled...


Ook een beetje onderzoek gedaan... 'infofoon' is ook van jou, klopt dat? je newinfo.abcministries.be is een kopie daarvan, klopt ook? Kan dus heel goed zijn dat de sporen van 'infofoon' roet in het eten gooien.

Check je config en files en folders hierop.. je config kan paden hebben naar de locaties van 'infofoon', je nginx config kan ook verkeerd info hebben..... het kan ook zomaar zijn dat de ownership van folders en bestanden niet bij de user die bij newinfo.abcministries.be hoort berust.

DirkBDS
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Nov 14, 2018 8:12 am

Re: Problemen in mainmenu met settings public en registered

Post by DirkBDS » Thu Nov 15, 2018 10:56 am

Newinfo is volledig nieuw en onafhankelijk opgebouwd juist om die problemen te vermijden. Aparte webruimte, aparte en nieuwe database en nieuwe databasegebruiker.

Cache is standaard uitgeschakeld.

Alvast bedankt om mee te kijken en denken!

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2032
Joined: Sun May 04, 2008 12:37 pm

Re: Problemen in mainmenu met settings public en registered

Post by waarnemer » Thu Nov 15, 2018 12:12 pm

als ik kijk onderaan de admin login zie ik rechtsonderin toch echt "© 2018 Infofoon" vandaar.

wat zegt je system info? geen gekke meldingen? (system ->system information)
wat zegt warnings? (extensions -> manage ->warnings)
wat zegt database? (extensions -> manage -> database)

Overigens zou volgens mij elke poging tot het benaderen van restricted content moeten lijden naar de login pagina. Dat gaat dus niet. Het geeft error 500 maar in je infofoon.abcministries.be gaat dat ook niet goed.. maar dan error 403.... er is ergens iets niet goed in de config.

DirkBDS
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Nov 14, 2018 8:12 am

Re: Problemen in mainmenu met settings public en registered

Post by DirkBDS » Thu Nov 15, 2018 2:40 pm

Bij de copyright kan je invullen wat je wil ;-)
De bedoeling is van de nieuwe opzet om te ontdekken wat het probleem is. Eens gevonden en opgelost kan hij gebruikt worden als de vernieuwde up-to-date versie.
Schermafbeelding 2018-11-15 om 15.36.05.png
Schermafbeelding 2018-11-15 om 15.35.43.png
Schermafbeelding 2018-11-15 om 15.35.25.png
You do not have the required permissions to view the files attached to this post.

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2032
Joined: Sun May 04, 2008 12:37 pm

Re: Problemen in mainmenu met settings public en registered

Post by waarnemer » Thu Nov 15, 2018 3:47 pm

wat staat er op de andere tabs van de systeem info?

het vreemde is dat je hoofdomein op hetzelfde IP ook met ngingx prima werkt.
je subdomains dus niet. je infofoon. en newinfo. geven dus allebei errors. de ene error 403 de andere error 500.

waarnemer
Joomla! Hero
Joomla! Hero
Posts: 2032
Joined: Sun May 04, 2008 12:37 pm

Re: Problemen in mainmenu met settings public en registered

Post by waarnemer » Thu Nov 15, 2018 4:16 pm

Ook vreemd... met wat je ook invult na het (sub)domainname

vb>
https://newinfo.abcministries.be/onzin
https://newinfo.abcministries.be/meteenverlengsnoer

het verwijst allemaal naar de home page... die zouden een 404 moeten geven. Er is geen 301/3 redirect dus er is wel iets mis met de instellingen van nginx lijkt het.

DirkBDS
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Nov 14, 2018 8:12 am

Re: Problemen in mainmenu met settings public en registered

Post by DirkBDS » Sat Nov 17, 2018 9:53 am

Inderdaad, dat was mij ook al opgevallen dat wanneer het in hoofddomein is er geen problemen zich voordoen.
De kans op fouten in subdomeinen wel. In elk geval al gemeld aan de host. Die vond het ook vreemd maar het wordt wel onderzocht.

User avatar
Rondeb
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Mon Dec 02, 2013 12:14 pm
Location: Meschede - Germany
Contact:

Re: Problemen in mainmenu met settings public en registered

Post by Rondeb » Mon Nov 19, 2018 1:33 pm

Middag,

en al wat vernomen van je hosting?

Groetjes Ron

DirkBDS
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Wed Nov 14, 2018 8:12 am

Re: Problemen in mainmenu met settings public en registered

Post by DirkBDS » Thu Nov 22, 2018 10:36 am

Neen, momenteel nog niet.

User avatar
Rondeb
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Mon Dec 02, 2013 12:14 pm
Location: Meschede - Germany
Contact:

Re: Problemen in mainmenu met settings public en registered

Post by Rondeb » Thu Nov 22, 2018 9:40 pm

Avond Dirk,

gaat niet zo snel bij je hosting ;)

Maar als test kan je in je root van het hoofddomein een extra map en daar de test site eens inzetten.
Zo kun je zien of het wel werkt of niet ;)

Succes ermee.

groeten Ron


Post Reply

Return to “Algemene vragen”