Site gehacked - Help!

Moderator: pe7er

Forum rules
Forum Regels
User avatar
edgarveen
Joomla! Explorer
Joomla! Explorer
Posts: 255
Joined: Wed Aug 24, 2005 6:06 pm
Location: The Netherlands

Site gehacked - Help!

Postby edgarveen » Sun Jul 06, 2008 7:30 pm

Tijdens mijn vakantie is één van mijn site's gehacked. Ik weet het, ben zelf zo stom geweest om deze niet tijdig te updaten....

Bij het opstarten van de site verschijnt de volgende regel:
"Parse error: syntax error, unexpected T_STRING in /home/jeugdland/domains/jeugdlandalblasserdam.nl/public_html/cms/configuration.php on line 118"

Via ftp uiteindelijk de configuration.php bekeken, en vanaf deze line staat inderdaad een script wat er niet hoort te staan. Ook staat er een of andere Russische footer tekst. Allemaal leuk en aardig maar het is toch wel vervelend.
Iemand een idee hoe ik dit kan herstellen...
Wist je dat alle elektrische apparaten op rook werken?

Zodra de rook eruit is doen ze het niet meer!

User avatar
jwr
Joomla! Guru
Joomla! Guru
Posts: 543
Joined: Thu Aug 18, 2005 5:54 pm
Location: Sliedrecht, the Netherlands

Re: Site gehacked - Help!

Postby jwr » Sun Jul 06, 2008 7:47 pm

Hoi,
Misschien eoa. ftp-setting corrupt ? t lijkt of de file om zeep is gegaan tijdens de transfer .

0.02 cents
JW
Looking for J! help ? Paste your (English preferred) errormessage in the searchbar !

User avatar
edgarveen
Joomla! Explorer
Joomla! Explorer
Posts: 255
Joined: Wed Aug 24, 2005 6:06 pm
Location: The Netherlands

Re: Site gehacked - Help!

Postby edgarveen » Mon Jul 07, 2008 8:01 am

Nou, nee... ten eerste is er geen aanpassing geweest aan de configuration.php file en er is een plaatje en tekst aan de body toegevoegd. Dus hij is duidelijk gehacked. Het lijkt erop dat dit het enige bestandje is wat ze om zeep hebben geholpen, helaas heb ik geen goede backup (stom, ik weet het). Maar hoe kan ik de configuration.php weer correct krijgen?
Wist je dat alle elektrische apparaten op rook werken?

Zodra de rook eruit is doen ze het niet meer!

User avatar
dam-man
Joomla! Exemplar
Joomla! Exemplar
Posts: 7962
Joined: Fri Sep 09, 2005 2:13 pm
Location: The Netherlands
Contact:

Re: Site gehacked - Help!

Postby dam-man » Mon Jul 07, 2008 11:00 am

edgarveen wrote:Nou, nee... ten eerste is er geen aanpassing geweest aan de configuration.php file en er is een plaatje en tekst aan de body toegevoegd. Dus hij is duidelijk gehacked. Het lijkt erop dat dit het enige bestandje is wat ze om zeep hebben geholpen, helaas heb ik geen goede backup (stom, ik weet het). Maar hoe kan ik de configuration.php weer correct krijgen?
Misschien vanuit een andere installatie kopiëren en dan aanpassen?
Robert Dam - Joomla Forum Moderator
Dutch Boards | Joomla Coding Boards | English Support Boards

User avatar
edgarveen
Joomla! Explorer
Joomla! Explorer
Posts: 255
Joined: Wed Aug 24, 2005 6:06 pm
Location: The Netherlands

Re: Site gehacked - Help!

Postby edgarveen » Wed Jul 16, 2008 6:07 pm

Ik heb de installation map opnieuw geupload en de eerste stappen opnieuw doorgelopen. Bij de ene laatste stap wordt er een nieuwe configuration.php geschreven, die heb ik aangepast (oude DB) en nu werkt het weer.

Ik wil het eerste topic op solved zetten, maar kan het bericht niet meer editten...
Wist je dat alle elektrische apparaten op rook werken?

Zodra de rook eruit is doen ze het niet meer!

User avatar
dam-man
Joomla! Exemplar
Joomla! Exemplar
Posts: 7962
Joined: Fri Sep 09, 2005 2:13 pm
Location: The Netherlands
Contact:

Re: Site gehacked - Help!

Postby dam-man » Thu Jul 17, 2008 9:58 am

edgarveen wrote:Ik heb de installation map opnieuw geupload en de eerste stappen opnieuw doorgelopen. Bij de ene laatste stap wordt er een nieuwe configuration.php geschreven, die heb ik aangepast (oude DB) en nu werkt het weer.

Ik wil het eerste topic op solved zetten, maar kan het bericht niet meer editten...


Dat klopt, deze is ouder dan 7 dagen. Ik heb het bij deze gedaan!
Robert Dam - Joomla Forum Moderator
Dutch Boards | Joomla Coding Boards | English Support Boards

User avatar
edgarveen
Joomla! Explorer
Joomla! Explorer
Posts: 255
Joined: Wed Aug 24, 2005 6:06 pm
Location: The Netherlands

Re: Site gehacked - Help!

Postby edgarveen » Thu Jul 17, 2008 1:49 pm

dam-man wrote:Dat klopt, deze is ouder dan 7 dagen. Ik heb het bij deze gedaan!


Oké, bedankt.


Return to “Installatie 1.0.x”

Who is online

Users browsing this forum: No registered users and 2 guests