Verhuizen lokaal naar server lukt niet ! [opgelost]

Moderator: pe7er

Forum rules
Forum Regels
Post Reply
edijkxh
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Sep 23, 2008 8:04 pm

Verhuizen lokaal naar server lukt niet ! [opgelost]

Post by edijkxh » Tue Sep 23, 2008 8:21 pm

Hallo,
Ik ben de afgelopen weken als leek bezig geweest een joomla site te maken.
Na enige twijfel of ik dit wel zou kunnen, heb ik toch maar besloten om het te proberen.
Bij XS4all een Advanced Unix site aangevraagd (draaide nu op Advanced windows, dus de oude site ligt eruit).
Deze is nu in de lucht. Met phpadmin de database geëxporteerd en geïmporteerd op de phpmyadmin van xs4all.
Dit is gelukt, 82 jos_ bestanden geïmporteerd. Daarna de bestanden van de joomlasite geïmporteerd met Filezilla in de map /htdocs. Eerst stond er op de site een melding van XS4all over de geregistreerde domeinnaam. Na importeren is dit verandert in een 404-foutmelding. Ook /phpmyadmin is niet meer te benaderen, ook 404.
Ik heb verschillende instellingen gedaan in mijn configuration.php, maar er gebeurt niks.
Aangezien ik er verder geen verstand van heb, zou ik willen vragen of iemand mij hiermee wil helpen.
Het is een site voor een basisschool en volgens mij gaat het me echt niet lukken.
En ik kan niet terug naar de oude site, omdat het omgezet is naar Unix.
(site: http://www.pwadelier.nl)

Ik zou enorm blij zijn met hulp.

Een radeloze juf !
Last edited by edijkxh on Wed Sep 24, 2008 2:05 pm, edited 1 time in total.

User avatar
sc00zy
Joomla! Exemplar
Joomla! Exemplar
Posts: 9529
Joined: Thu Aug 18, 2005 9:07 am
Location: Assen, Netherlands
Contact:

Re: Verhuizen lokaal naar server lukt niet !

Post by sc00zy » Tue Sep 23, 2008 9:02 pm

Heb je de bestanden op de juiste locatie geupload? (in de htdocs map)
Arjan Menger
http://www.welldotcom.nl - Professionele Joomla! Design, Ontwikkeling en Hosting
http://www.joomlaideal.nl - iDEAL betaalmethode voor Joomla! en Virtuemart

edijkxh
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Sep 23, 2008 8:04 pm

Re: Verhuizen lokaal naar server lukt niet !

Post by edijkxh » Tue Sep 23, 2008 9:06 pm

Ja, daar staan ze in !

User avatar
sc00zy
Joomla! Exemplar
Joomla! Exemplar
Posts: 9529
Joined: Thu Aug 18, 2005 9:07 am
Location: Assen, Netherlands
Contact:

Re: Verhuizen lokaal naar server lukt niet !

Post by sc00zy » Tue Sep 23, 2008 9:58 pm

Heb je misschien bestanden verwijderd die je beter niet had kunnen verwijderen? Wellicht dat ze van XS4ALL even kunnen kijken. Zo'n melding komt mij in ieder geval niet bekend voor.
Arjan Menger
http://www.welldotcom.nl - Professionele Joomla! Design, Ontwikkeling en Hosting
http://www.joomlaideal.nl - iDEAL betaalmethode voor Joomla! en Virtuemart

edijkxh
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Sep 23, 2008 8:04 pm

Re: Verhuizen lokaal naar server lukt niet !

Post by edijkxh » Tue Sep 23, 2008 10:07 pm

Volgens mij heb ik niets gewist, alleen maar de map installation (dat moet toch ?).
Maar ik ga morgen wel met XS4all bellen, kijken of zij iets weten.

Toch bedankt!

User avatar
sc00zy
Joomla! Exemplar
Joomla! Exemplar
Posts: 9529
Joined: Thu Aug 18, 2005 9:07 am
Location: Assen, Netherlands
Contact:

Re: Verhuizen lokaal naar server lukt niet !

Post by sc00zy » Tue Sep 23, 2008 10:22 pm

Wel vreemd dan. Ik ben benieuwd wat de oorzaak is en wil, als je er niet uitkomt, ook nog wel even kijken.
Arjan Menger
http://www.welldotcom.nl - Professionele Joomla! Design, Ontwikkeling en Hosting
http://www.joomlaideal.nl - iDEAL betaalmethode voor Joomla! en Virtuemart

edijkxh
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Sep 23, 2008 8:04 pm

Re: Verhuizen lokaal naar server lukt niet !

Post by edijkxh » Wed Sep 24, 2008 8:18 am

Nou, ik heb XS4all gebeld. Alle website-instellingen kloppen. Mijn error-message stond nu ook in beeld sinds vanmorgen, met daaronder kan niet verbinden met database. De helpdesk zegt dat er dus iets niet klopt met de database. Heel phpmyadmin was verdwenen van de server. Als je van lokaal overzet naar de server zijn er waarschijnlijk allerlei verwijzingen die niet kloppen, dus kan de server daar niet mee overweg. Of hij is gebouwd in Windows en draait nu niet in Unix. Maar zij kijken niet verder, zij controleren alleen de website en dat is OK.
Tip van hem: laat iemand naar de database kijken die er meer verstand van heeft.
Maar ik heb dat niet, was al blij dat alles goed draaide op mijn laptop.
Enig idee ?

User avatar
sc00zy
Joomla! Exemplar
Joomla! Exemplar
Posts: 9529
Joined: Thu Aug 18, 2005 9:07 am
Location: Assen, Netherlands
Contact:

Re: Verhuizen lokaal naar server lukt niet !

Post by sc00zy » Wed Sep 24, 2008 8:28 am

Kunnen zij niet gewoon je account resetten?
Arjan Menger
http://www.welldotcom.nl - Professionele Joomla! Design, Ontwikkeling en Hosting
http://www.joomlaideal.nl - iDEAL betaalmethode voor Joomla! en Virtuemart

edijkxh
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Sep 23, 2008 8:04 pm

Re: Verhuizen lokaal naar server lukt niet !

Post by edijkxh » Wed Sep 24, 2008 10:29 am

Ja, dat hebben ze nu gedaan.
Nu kan ik weer de database inlezen, maar als dat weer fout gaat, is er toch iets mis !

Maar ik ga het nog maar een keer proberen dan.

edijkxh
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Sep 23, 2008 8:04 pm

Re: Verhuizen lokaal naar server lukt niet !

Post by edijkxh » Wed Sep 24, 2008 10:40 am

Ik kan weer in phpmyadmin. Ze hadden gezegd dat de fabrieksinstellingen teruggezet zouden worden, maar nu staat de database die ik geïmporteerd heb er nog gewoon in. En de website-bestanden staan ook nog gewoon in htdocs.
Alleen nog steeds de melding: kan niet verbinden met database. Zou jij misschien daarnaar kunnen kijken ?

edijkxh
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Sep 23, 2008 8:04 pm

Re: Verhuizen lokaal naar server lukt niet !

Post by edijkxh » Wed Sep 24, 2008 11:15 am

Ben ik weer. Ik kan de website nu wel bereiken !
Ik heb aanpassingen gemaakt in de configuration.php (andere instellingen gedaan, dan xs4all mij vertelde)
en nu komt de website wel in beeld. Alleen mijn hele template is verdwenen, dus het is een zooitje.

Ik heb XS4all weer gebeld, zij zeggen dat alles nu goed draait, maar dat alleen alle php-scriptjes aangepast moeten worden.
Is dat zo ? Als ik het zo op internet lees, zou alles in één keer goed moeten kunnen gaan.
Ik heb geen verstand van scripts herschrijven !

edijkxh
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Sep 23, 2008 8:04 pm

Re: Verhuizen lokaal naar server lukt niet !

Post by edijkxh » Wed Sep 24, 2008 11:24 am

En dan nog maar één: ergens op klikken geeft allemaal 404 foutmeldingen. In beeld komt het webadres dubbel: www.pwadelier.nl/www.pwadelier.nl/etc. Dus dat klopt al niet.
Inloggen in de back-end lukt ook, maar krijg geen icoontjes, fout op de pagina en kan niets opslaan om te veranderen. Dus heb je enig idee wat er nu nog fout gaat ?

User avatar
sc00zy
Joomla! Exemplar
Joomla! Exemplar
Posts: 9529
Joined: Thu Aug 18, 2005 9:07 am
Location: Assen, Netherlands
Contact:

Re: Verhuizen lokaal naar server lukt niet !

Post by sc00zy » Wed Sep 24, 2008 12:48 pm

Vreemd. De CSS en afbeeldingen zijn wel bereikbaar, maar worden niet ingeladen.
Arjan Menger
http://www.welldotcom.nl - Professionele Joomla! Design, Ontwikkeling en Hosting
http://www.joomlaideal.nl - iDEAL betaalmethode voor Joomla! en Virtuemart

edijkxh
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Sep 23, 2008 8:04 pm

Re: Verhuizen lokaal naar server lukt niet !

Post by edijkxh » Wed Sep 24, 2008 1:34 pm

Probleem opgelost !!!!
Ik had bij live_site:www.pwadelier.nl neergezet.
Nu heb ik dat weggehaald, is dus leeg nu en nu worden de afbeeldingen wel geladen !

Bedankt voor de reacties !

User avatar
sc00zy
Joomla! Exemplar
Joomla! Exemplar
Posts: 9529
Joined: Thu Aug 18, 2005 9:07 am
Location: Assen, Netherlands
Contact:

Re: Verhuizen lokaal naar server lukt niet ! [opgelost]

Post by sc00zy » Wed Sep 24, 2008 2:16 pm

Bij live site moet er http:// voor de url staan ;)
Arjan Menger
http://www.welldotcom.nl - Professionele Joomla! Design, Ontwikkeling en Hosting
http://www.joomlaideal.nl - iDEAL betaalmethode voor Joomla! en Virtuemart

edijkxh
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Tue Sep 23, 2008 8:04 pm

Re: Verhuizen lokaal naar server lukt niet ! [opgelost]

Post by edijkxh » Wed Sep 24, 2008 2:50 pm

Oh, dom van mij !
Maar ik vul het maar helemaal niet meer in, want het werkt !

Nogmaals dank.


Post Reply

Return to “Installatie 1.0.x”