Page 1 of 1

Compatibile layer 3.10 and 4.0

Posted: Mon Aug 03, 2020 1:51 pm
by JurajB
Hello,
is this the first time that Joomla! apply compatibility layers for smoother extension migrations to Joomla! 4?
Thanks.

Re: Compatibile layer 3.10 and 4.0

Posted: Mon Aug 03, 2020 6:39 pm
by sozzled

Re: Compatibile layer 3.10 and 4.0

Posted: Mon Aug 03, 2020 8:29 pm
by JurajB
Thanks! But thats not all, what about 3.10? Can you be more specific how this alter plugin working and migrating from 3 to v4? And some technical information about this?

Re: Compatibile layer 3.10 and 4.0

Posted: Tue Aug 04, 2020 1:23 am
by toivo
Search and you will find documentation, for example:
Version 4.0 Beta FAQ
Joomla 3.10 and the update checker

Re: Compatibile layer 3.10 and 4.0

Posted: Tue Aug 04, 2020 10:49 am
by JurajB
"The team that finally submitted the Pull Request to the Core CMS where: Samuel Schepp, Kevin Linne and David Donges. "
Its a typo ? before : should be were?
Im not that good in english but this sentence didnt make sense to me.

OK. So the update checker was here in J!2.x to J!3 migration.
But the compatibile layer in 3.10 is new thing in Joomla! world, right?
Anyway Im impressed how georgeous project Joomla! is. And also tons of features under the hood. Prepare for future. IOT, intelligent cities, city administration - Joomla! 4 is on the way.

Re: Compatibile layer 3.10 and 4.0

Posted: Tue Aug 04, 2020 12:01 pm
by JAVesey
JurajB wrote:
Tue Aug 04, 2020 10:49 am
Its a typo ? before : should be were?
Yes.

The correct English would be "The team that finally submitted the Pull Request to the Core CMS were Samuel Schepp, Kevin Linne and David Donges." (so "were" instead of "where" and no ":").

This is not a criticism, of course; English isn't everyone's first language and you worked out what the correct wording should have been, so well done you, too :)

I agree that Joomla 4 is looking good and the 3.9.x --> 3.10.0 --> 4.0.0 transition is taking shape nicely. Kudos to the Dev team :D

Re: Compatibile layer 3.10 and 4.0

Posted: Tue Aug 04, 2020 10:12 pm
by brian
There is no such thing as a compatible layer

Re: Compatibile layer 3.10 and 4.0

Posted: Wed Aug 05, 2020 7:30 am
by JurajB
brian :) so tells us what is this thing? layer should be understanded in more ways. So than it is a backwards compatibility? Isnt there something that keeps plugins a room for migration - I dont know both J4 and J3 supported plugins at once?
Thanks.