Class 'JResponse' not found

Be informed that this forum is not an official support forum for Joomla! 4.0. Any issues regarding Joomla! 4.0 must be reported at https://issues.joomla.org/.

Joomla 4.0 is still in Beta stage. This forum should be used for sharing information about Joomla! 4.0.

Moderators: ooffick, ooffick

Forum rules
Post Reply
GillianBPP
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 181
Joined: Wed Oct 01, 2014 10:25 am

Class 'JResponse' not found

Post by GillianBPP » Sat Dec 12, 2020 11:28 am

I am working on updating my J3x templates to J4x

Yesterday, I followed the Joomla Docs instructions by copying a live site and installing it on a development platform (a subdomain on another domain), upgraded to J3.10 then to J4 Beta 5. All non-J4 compatible plugins, extensions (e.g. Regular Labs) have either been disabled or uninstalled.

The site is rendering correctly and I'm able to edit template files in the admin panel.

However, when I click on 'Menus -> Main Menu' I just get this:

Image

None of my template files contain 'JResponse' and clicking the 'Rebuild' button does nothing.

If I start from scratch with a new installation of J4 Beta 5 I don't get this problem. Any ideas? Thanks.
You do not have the required permissions to view the files attached to this post.

SharkyKZ
Joomla! Ace
Joomla! Ace
Posts: 1841
Joined: Fri Jul 05, 2013 10:35 am
Location: Parts Unknown

Re: Class 'JResponse' not found

Post by SharkyKZ » Sat Dec 12, 2020 12:13 pm

This class doesn't exist in J4. Enable debug to see what's trying to use it.

User avatar
ceford
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 165
Joined: Mon Feb 24, 2014 10:38 pm
Location: Edinburgh, Scotland
Contact:

Re: Class 'JResponse' not found

Post by ceford » Sun Dec 13, 2020 10:08 pm

SharkyKZ wrote:
Sat Dec 12, 2020 12:13 pm
This class doesn't exist in J4. Enable debug to see what's trying to use it.
To expand a little: go to Global Configuration / System and set Debug System to Yes. Then in Server set Error Reporting to Maximum.

You can do a global search of the code for JResponse using grep (linux) or an IDE such as Eclipse PDT. That should tell you a likely source of the problem.


Post Reply

Return to “Joomla! 4 Related”