FPA self deletes on running Topic is solved

This Forum board is about discussions about the FPA tool.

Moderator: General Support Moderators

Post Reply
stuffdone
Joomla! Guru
Joomla! Guru
Posts: 548
Joined: Tue Oct 28, 2008 11:06 pm
Location: NE Florida
Contact:

FPA self deletes on running

Post by stuffdone » Tue Jan 05, 2021 4:37 pm

I am dealing with some issues and to help, other ppl here want me to post output from FPA

Problem is when I try the FPA keeps telling me it is self-deleting due to the time it has been on the server. ( Have no clue what that means. Am I required to leave it for a set period of time?

The quick start guide just say to upload the script, then run from browser but all I get is that message and the script vanishes.
FPA_Error.jpg
You do not have the required permissions to view the files attached to this post.
Last edited by toivo on Tue Jan 05, 2021 5:13 pm, edited 1 time in total.
Reason: mod note: moved from 3.x Security
--- http://www.Stuffdone.com ---
Wow. Doing web sites for over 25 years now. I will be 75 in March. That's 1/3 of my entire life :)

frostmakk
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 197
Joined: Sun Dec 28, 2014 9:30 am
Location: Stavanger, Norway

Re: FPA self deletes on running

Post by frostmakk » Tue Jan 05, 2021 5:09 pm

This has been discussed before, don't remember the post.
As a work around comment out line 97 define ( '_FPA_SELF_DESTRUCT', TRUE);

Edit:
Found it. viewtopic.php?f=806&t=982234
Last edited by frostmakk on Tue Jan 05, 2021 5:13 pm, edited 1 time in total.

gws
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4233
Joined: Tue Aug 23, 2005 1:56 pm
Location: South coast, UK
Contact:

Re: FPA self deletes on running

Post by gws » Tue Jan 05, 2021 5:13 pm


stuffdone
Joomla! Guru
Joomla! Guru
Posts: 548
Joined: Tue Oct 28, 2008 11:06 pm
Location: NE Florida
Contact:

Re: FPA self deletes on running

Post by stuffdone » Tue Jan 05, 2021 5:28 pm

Comment out line 97 solved the problem.

I get the idea behind self destruct but it has a time warning in the script when it runs anyway.
While I agree it is not a "bug" the lack of information about that problem being absent from documentation is a "bug" in terms of instructions.

Better solution to avoid the date/time stamp issue would be:

1) Provide the work around as part of the documentation.
2) Design script so that once you export a report is self destructs in x seconds.
--- http://www.Stuffdone.com ---
Wow. Doing web sites for over 25 years now. I will be 75 in March. That's 1/3 of my entire life :)

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10066
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: FPA self deletes on running

Post by sozzled » Tue Jan 05, 2021 6:51 pm

stuffdone wrote:
Tue Jan 05, 2021 5:28 pm
Better solution to avoid the date/time stamp issue would be:

1) Provide the work around as part of the documentation.
2) Design script so that once you export a report is self destructs in x seconds.
The problem is caused by using a file transfer method (e.g. Win SCP) that preserves the original date modified value when you copy files from your PC to your file server (as discussed in viewtopic.php?f=806&t=982234#p3615105). Some file transfer methods are better than others. It's not necessary to modify the FPA source code.

Your request to provide a "work around" as part of the documentation is worth taking on board and I will write to the FPA development team to request that the documentation is modified. Thanks.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 10066
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: FPA self deletes on running

Post by sozzled » Tue Jan 05, 2021 10:28 pm

Documentation updated.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

stuffdone
Joomla! Guru
Joomla! Guru
Posts: 548
Joined: Tue Oct 28, 2008 11:06 pm
Location: NE Florida
Contact:

Re: FPA self deletes on running

Post by stuffdone » Wed Jan 06, 2021 3:45 pm

sozzled wrote:
Tue Jan 05, 2021 10:28 pm
Documentation updated.
NICE !
--- http://www.Stuffdone.com ---
Wow. Doing web sites for over 25 years now. I will be 75 in March. That's 1/3 of my entire life :)


Post Reply

Return to “Forum Post Assistant (FPA)”