FPA Never Completes? Missing Confidence Box Topic is solved

This Forum board is about discussions about the FPA tool.

Moderators: General Support Moderators, General Support Moderators

Post Reply
harmsway14
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Apr 03, 2013 3:47 pm

FPA Never Completes? Missing Confidence Box

Post by harmsway14 » Sat Jun 20, 2020 4:31 am

I have 2 Joomla sites on my servers, thought I'd run FPA on both and it never shows the version of Joomla, Confidence box or anything after or below. See attached screenshot, both sites are showing the same thing.
You do not have the required permissions to view the files attached to this post.

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 6475
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: FPA Never Completes? Missing Confidence Box

Post by AMurray » Sat Jun 20, 2020 5:43 am

are you running the script in the same folder as joomla?
Regards,
--------------------------------------------------------------
A Murray
Help you I can, yes!. Post your question, you should. Keep it on topic you must!
Use the Forc....Forum Post Assistant my young Padawan!

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9999
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: FPA Never Completes? Missing Confidence Box

Post by sozzled » Sat Jun 20, 2020 6:00 am

[deleted by author]

As a test, try the previous version of the FPA (available from here >>> https://github.com/ForumPostAssistant/F ... tag/v1.5.0 <<< and post the results from that on the forum. There may be something in the earlier last version that indicates why the latest release is not working for you.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

harmsway14
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Apr 03, 2013 3:47 pm

Re: FPA Never Completes? Missing Confidence Box

Post by harmsway14 » Sat Jun 20, 2020 9:15 am

That worked! It ran!
You do not have the required permissions to view the files attached to this post.

User avatar
RussW
Joomla! Exemplar
Joomla! Exemplar
Posts: 9362
Joined: Sun Oct 22, 2006 4:42 am
Location: Sunshine Coast, Queensland, Australia
Contact:

Re: FPA Never Completes? Missing Confidence Box

Post by RussW » Sat Jun 20, 2020 10:59 am

If you feel comfortable with editing the FPA file and uploading it again, could you "uncomment" the _FPA_DIAG definition (remove the "#" sign from the front of the line) and re-run FPA and see if it produces an error on-screen?

or with the previous version of FPA (v1.5.0) is there an error shown in the FPA post content - (Click the "Show Forum Post Assistant" link and check the "Last Error" text box)
Joomla! on the fabulous Sunshine Coast...
hotmango, web & print http://www.hotmango.me/
The Styleguyz https://www.thestyleguyz.com/

User avatar
RussW
Joomla! Exemplar
Joomla! Exemplar
Posts: 9362
Joined: Sun Oct 22, 2006 4:42 am
Location: Sunshine Coast, Queensland, Australia
Contact:

Re: FPA Never Completes? Missing Confidence Box

Post by RussW » Sat Jun 20, 2020 9:51 pm

@harmsway14 If you would like to try the "currentDevelopment" FPA, we believe it may have a fix for your issue.

Download from : https://github.com/ForumPostAssistant/F ... opment.zip
Joomla! on the fabulous Sunshine Coast...
hotmango, web & print http://www.hotmango.me/
The Styleguyz https://www.thestyleguyz.com/

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9999
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: FPA Never Completes? Missing Confidence Box

Post by sozzled » Sun Jun 21, 2020 4:33 am

Confirmed: if the PHP setting allow_url_fopen is not enabled this causes FPA v1.6.0 to fail when it tries to check for the latest version of J!.

By the same token, if allow_url_fopen is not enabled, there will be other problems maintaining a J! website (e.g. using the Joomla! Update component or installing extensions with the "Install from Web" facility). The FPA problem will be fixed with a future update.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

frostmakk
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 194
Joined: Sun Dec 28, 2014 9:30 am
Location: Stavanger, Norway

Re: FPA Never Completes? Missing Confidence Box

Post by frostmakk » Sun Jun 21, 2020 1:16 pm

Bug Fix FPA v1.6.1 released.


Post Reply

Return to “Forum Post Assistant (FPA)”