FPA errors

This Forum board is about discussions about the FPA tool.

Moderators: General Support Moderators, General Support Moderators

Post Reply
User avatar
yerg
Joomla! Ace
Joomla! Ace
Posts: 1001
Joined: Thu Aug 18, 2005 12:22 pm
Location: Ballarat, Australia
Contact:

FPA errors

Post by yerg » Tue Sep 01, 2020 2:17 am

Have ERROR: AJAX Loading Error when trying to update 3.9.20 to 3.9.21

Can find no errors such as permissions etc as I have 4 installs on my server space and the other 3 updated just fine.

Ran FPA v1.6.1 and I'm now getting the following error fpa-en.php on line 5044

Code: Select all

 if ( version_compare( $instance['cmsRELEASE'], '3.8', '>=') OR version_compare( $phpenv['phpVERSION'], '7.2.0', '>=' ))   {
The report generated is totally unusable due to this.
Editing makes no change

Any ideas?


php Version: 7.3.21
J! Version 3.9.20
We cannot become what we need to be ... by remaining what we are

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13299
Joined: Thu Feb 15, 2007 5:48 am
Location: Zagreb, Croatia

Re: FPA errors

Post by toivo » Tue Sep 01, 2020 5:16 am

When the FPA displays the line of PHP code, is the actual PHP error, notice or warning also displayed?

FPA 1.6.1 works all right with PHP 7.4.8.

Any issues with the FPA should be reported at the FPA forum.
Toivo Talikka, Global Moderator

User avatar
yerg
Joomla! Ace
Joomla! Ace
Posts: 1001
Joined: Thu Aug 18, 2005 12:22 pm
Location: Ballarat, Australia
Contact:

Re: FPA errors

Post by yerg » Tue Sep 01, 2020 5:21 am

Thanks Toivo
I wasn't aware there was a forum here for that
Never came up on search
We cannot become what we need to be ... by remaining what we are

User avatar
sozzled
Joomla! Exemplar
Joomla! Exemplar
Posts: 9999
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: FPA errors

Post by sozzled » Wed Sep 02, 2020 8:50 pm

Thank you, @forum moderators, for moving this discussion to the FPA forum. :)

In some cases, the latest version of the FPA reporting tool may not work. As a workaround, you may wish to use an older version of the FPA software. I would suggest that you look at https://github.com/ForumPostAssistant/FPA/releases and try a version before v1.6 (e.g. v1.5.0 or 1.4.9). If one of these versions works then let us know (and post the FPA report here so that one of the FPA developers can examine it and work through the issues).

Thanks for your help.
https://www.kuneze.com/blog
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)


Post Reply

Return to “Forum Post Assistant (FPA)”