notification errors and media tab problem

General questions relating to Joomla! 4.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
jpflathead
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Wed Sep 15, 2010 7:52 pm

notification errors and media tab problem

Post by jpflathead » Mon Sep 13, 2021 9:12 pm

I often have these 2 problems together that in the admin site in the Home Dashboard 4 of the 5 blocks in the Notification tab are red: "Unknown Joomla...." , "Unknown extentions...." , "Error on checking overrides." and "Unknown requests...." . But "Backup up to date" is green. Yes, Akeeba is installed.
And when these 4 are red the Content -> Media tab does not display the contents of the images folder.
Sometimes, and I don't know what triggers it, these 4 Notification tabs become green and the Media tab shows the correct contents.
The site runs on a Linux host and is on version 4.0.2. Site has only text articles with embedded pictures, no extra components.
Anyone an idea where this might come from?
Because Media does not display the correct folders I cannot upload pictures.
It happened at my home and now it happens at this other place as well. I can add articles.

User avatar
ceford
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 228
Joined: Mon Feb 24, 2014 10:38 pm
Location: Edinburgh, Scotland
Contact:

Re: notification errors and media tab problem

Post by ceford » Wed Sep 15, 2021 4:58 am

There is a problem with the media component - if you attempt to edit an image and click on Save several times in quick succession the image gets corrupted and that kills the media display. See if you can find a corrupted image - I just tested and the corrupt image was only 3 bytes long - and delete it or restore from back-up. I thought this problem had been fixed but it appears not. The intermittent nature of this problem is probably because it is Javascript related. I have not met the other notification problems.

ghazal
Joomla! Explorer
Joomla! Explorer
Posts: 289
Joined: Fri Aug 19, 2005 12:12 pm
Location: Out of my mind ...sometimes

Re: notification errors and media tab problem

Post by ghazal » Wed Sep 15, 2021 7:53 am

MariaDB or MySQL ?

jpflathead
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Wed Sep 15, 2010 7:52 pm

Re: notification errors and media tab problem

Post by jpflathead » Thu Sep 16, 2021 8:26 am

The strange thing is 2 days ago I changed the backup folder of Akeeba (permission 777) and I changed the Joomla temp folder to 777 and then things worked.
The only issue that is still open, and I cannot solve because I'm not at home, is the PHP temp folder.
Next day, when I was at another place, the error was back again. (We are touring with our motorhome and I make a kind of blog with pictures). ATS says me the only thing that has changed is my IP address. I use the same laptop on the same website.
I cannot recall having this kind of error with Joomla version 3, although I'm not sure.
I'm confused.
Edit: Oh, and I am quite sure my provider uses MariaDB.
And about the notification errors: it feels like some process can't access something so it might be some privilege issue. But that is a feeling I have.
And I only upload images, never edit them. I scale them on the laptop with Tinouos to 800x600 and then upload them and then in the editor add a link to the picture in toggled mode.

ghazal
Joomla! Explorer
Joomla! Explorer
Posts: 289
Joined: Fri Aug 19, 2005 12:12 pm
Location: Out of my mind ...sometimes

Re: notification errors and media tab problem

Post by ghazal » Thu Sep 16, 2021 9:08 am

* Check if the paths are correct in :
- Global Configuration->Server->Path to Temp Folder
- Global Configuration->Logging->Path to Log Folder

* Once this done, try this, select " filesystem " in Global Configuration->System -> Session : Session Handler
Only if your server stack is using MariaDB

Thanks to @sozzled who mentioned this feature

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 7041
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: notification errors and media tab problem

Post by AMurray » Thu Sep 16, 2021 9:15 am

You shouldn't need to change any permission to 777 it should be 755.
Regards - A Murray

ghazal
Joomla! Explorer
Joomla! Explorer
Posts: 289
Joined: Fri Aug 19, 2005 12:12 pm
Location: Out of my mind ...sometimes

Re: notification errors and media tab problem

Post by ghazal » Thu Sep 16, 2021 9:17 am

AMurray wrote:
Thu Sep 16, 2021 9:15 am
You shouldn't need to change any permission to 777 it should be 755.
100% agreed.


Post Reply

Return to “General Questions/New to Joomla! 4.x”