Smart search indexing fault

General questions relating to Joomla! 4.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
Dafilla
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Oct 10, 2021 8:24 am

Smart search indexing fault

Post by Dafilla » Sun Oct 10, 2021 8:40 am

I migrated from J3 to J4. Since then the smart indexing function gives:
An Error Has Occurred
The image file does not exist.
All articles (About 100) have an intro image.

The strange this is, that when I clear the index, go to an article, hit save, then it is being indexed without problems..

Anyone suggestions?

User avatar
mjparadac
Joomla! Hero
Joomla! Hero
Posts: 2325
Joined: Mon Oct 29, 2012 3:58 pm

Re: Smart search indexing fault

Post by mjparadac » Fri Oct 15, 2021 11:59 pm

Hello Dafilla, welcome to the forum

Any problem where the update, error message or warning?

To provide more information, you could use:
https://forumpostassistant.github.io/docs/

Regards,
Joomla Community Ambassador for A2 Hosting | A2 Hosting - Our speed, your success | https://www.a2hosting.com/joomla-hosting

Dafilla
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Oct 10, 2021 8:24 am

Re: Smart search indexing fault

Post by Dafilla » Sat Oct 23, 2021 8:02 am

Thanks for the reply. No there were no problems as far as I could see. And the only thing I get on indexing is the warning with 'the image file does not exist'. I will have a look at the link you sent.

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 11196
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Smart search indexing fault

Post by sozzled » Sat Oct 23, 2021 8:20 am

There is no [English] language string in a default J! 4 installation with the value "the image file does not exist". This error must be coming from a third-party extension that you have installed.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

User avatar
ceford
Joomla! Explorer
Joomla! Explorer
Posts: 299
Joined: Mon Feb 24, 2014 10:38 pm
Location: Edinburgh, Scotland
Contact:

Re: Smart search indexing fault

Post by ceford » Sat Oct 23, 2021 12:01 pm

sozzled wrote:
Sat Oct 23, 2021 8:20 am
There is no [English] language string in a default J! 4 installation with the value "the image file does not exist". This error must be coming from a third-party extension that you have installed.
It is in plain English in libraries/src/Image/Image.php on lines 180 and 588:

Code: Select all

throw new \InvalidArgumentException('The image file does not exist.');
and is caused if the $path variable is not a file.


Post Reply

Return to “General Questions/New to Joomla! 4.x”