Custom Image Module Doesn't Match Template? Topic is solved

General questions relating to Joomla! 4.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
GRNDPNDR
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sun Jul 24, 2011 2:10 pm

Custom Image Module Doesn't Match Template?

Post by GRNDPNDR » Mon Jan 17, 2022 4:48 pm

Not sure if the title makes sense, but I have the Cassiopeia template and am trying to figure out how things work, so I've made a clone of the site.

Site A has no sample data installed.
Site B(Clone) has the sample data installed.

I'm trying to make Site A look like Site B manually so I can figure out how things work.

I created a custom "Image" module and uploaded an image(Even tried with the Cassiopeia image too), and copied the HTML from the editor over to Site A.

However Site A just has a slim banner across the top that only shows part of the image, instead of being large and showing the whole image and I can't figure out how to resize it in any way.

also, when I copy the text/html from the Site B to Site A image module the text isn't centered in the middle and it's black on Site A.

What am I missing that I can't make it look the same?

User avatar
ltheme
Joomla! Guru
Joomla! Guru
Posts: 663
Joined: Wed Dec 04, 2013 2:43 pm
Location: US
Contact:

Re: Custom Image Module Doesn't Match Template?

Post by ltheme » Tue Jan 18, 2022 4:33 am

Look like you missed some class config for modules. Can you share me site (A) URL?, so I can take a look.
Steve (Mr.) - Fan of Joomla! CMS over 10 years
https://ltheme.com/joomla-templates/ <= 120+ Joomla! templates
https://agethemes.com/free-joomla-templates/ <= Joomla! templates on marketplace
^Compatible with Joomla! 3.x and Joomla! 4

SharkyKZ
Joomla! Hero
Joomla! Hero
Posts: 2129
Joined: Fri Jul 05, 2013 10:35 am
Location: Parts Unknown

Re: Custom Image Module Doesn't Match Template?

Post by SharkyKZ » Tue Jan 18, 2022 7:01 am

Did you set the layout in module configuration to "banner"?

GRNDPNDR
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sun Jul 24, 2011 2:10 pm

Re: Custom Image Module Doesn't Match Template?

Post by GRNDPNDR » Tue Jan 18, 2022 1:53 pm

ltheme wrote:
Tue Jan 18, 2022 4:33 am
Look like you missed some class config for modules. Can you share me site (A) URL?, so I can take a look.
The sites are linked in the post, but they're overgrow.ca (Site A) and joomla.overgrow.ca (Site B)

Site B is just a clone using Installatron.

GRNDPNDR
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Sun Jul 24, 2011 2:10 pm

Re: Custom Image Module Doesn't Match Template?

Post by GRNDPNDR » Tue Jan 18, 2022 1:55 pm

SharkyKZ wrote:
Tue Jan 18, 2022 7:01 am
Did you set the layout in module configuration to "banner"?
That was the problem, thank you so much.

I guess I overlooked that setting when I went through them.


Post Reply

Return to “General Questions/New to Joomla! 4.x”