mysql warning msg Topic is solved

General questions relating to Joomla! 4.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
frannyji
Joomla! Apprentice
Joomla! Apprentice
Posts: 49
Joined: Wed Aug 21, 2013 12:19 am

mysql warning msg

Post by frannyji » Thu Dec 01, 2022 10:21 pm

I'm in the process of trying to clean up mysql db which has several duplicate tables. Clicking on one of the tables to look at it more closely I receive the following warning:

Warning: a form on this page has more than 1000 fields. On submission, some of the fields might be ignored, due to PHP's max_input_vars configuration.

What does it mean? How can I find it? How can I fix it?
Thanks in advance for any help you can suggest.
Fran

User avatar
Rondeb
Joomla! Guru
Joomla! Guru
Posts: 543
Joined: Mon Dec 02, 2013 12:14 pm
Location: Meschede - Germany
Contact:

Re: mysql warning msg

Post by Rondeb » Thu Dec 01, 2022 11:22 pm

Hi,

As the warning says, you have a form with more than 1000 fields, and it may be that not everything is included in a database export.

Maybe you can get to your PHP.ini file, then you can do the following.
https://www.[youtube].com/watch?v=kUyOC2gfr8M

And otherwise you have to ask your hosting to increase this, the question remains whether they want to do this. Most do not modify the php.ini because it is usually a sharing hosting server.

Ron :)

frannyji
Joomla! Apprentice
Joomla! Apprentice
Posts: 49
Joined: Wed Aug 21, 2013 12:19 am

Re: mysql warning msg

Post by frannyji » Thu Dec 01, 2022 11:29 pm

Thanks Ron.
I'm doing this on my pc as a localhost with J4 and rebuilding my online J3 website from scratch. So I have access to most .ini and .php files. I will go have a look at what you suggest.
I'm puzzled as to what could have more than a 1000 fields.
Fran

frannyji
Joomla! Apprentice
Joomla! Apprentice
Posts: 49
Joined: Wed Aug 21, 2013 12:19 am

Re: mysql warning msg

Post by frannyji » Fri Dec 02, 2022 1:54 am

Ron,
Thanks for your help. I was able to modify max_input_vars in my php.ini file and that has solved the prpblem.
Thanks!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 42351
Joined: Sat Apr 05, 2008 9:58 pm

Re: mysql warning msg

Post by Webdongle » Fri Dec 02, 2022 2:03 am

You could use Akeeba to move the site https://docs.joomla.org/Copying_a_Jooml ... _Method.29
Also note that with some virtual Hosts like Wamp you can select php.ini setting values rather than directly editing the file
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".


Post Reply

Return to “General Questions/New to Joomla! 4.x”