Error when trying to display site templates Topic is solved

Everything to do with Joomla! 4.x templates and templating.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
kkurtz
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jul 12, 2012 1:38 pm

Error when trying to display site templates

Post by kkurtz » Sat Dec 09, 2023 11:01 pm

I am converting templates developed in Joomla 3 to Joomla 4. Joomla 4 was installed on the J3 site. When I try to display the Site Templates I get the following error An error has occurred.
0 Call to a member function get() on bool.
The site is https://j4rforest.californiadar.org/.

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9558
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Error when trying to display site templates

Post by AMurray » Sun Dec 10, 2023 4:59 am

I don't see that error, but all I do see is an un-styled page. Are your CSS references correct?

What template are you converting to J4 (no mean feat, I would think). Are you an experienced coder?
Regards - A Murray

kkurtz
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jul 12, 2012 1:38 pm

Re: Error when trying to display site templates

Post by kkurtz » Sun Dec 10, 2023 1:48 pm

Where are you seeing an unstyled page? If you somehow logged in to the frontend you would see that the page falls apart. But it is still styled. This is a copy of the live site so I can work on the conversion. It works fine in J3. Can you send me a link?

The error I am seeing is in the backend - when I go to System and click on Site Templates.

Regarding the CSS references...the CSS files for this template are stored in a central location. I have 18 sites using this template. We store them centrally so changes can be made once, not 18 times.

As far as being an experienced coder...I have been developing and maintaining our Joomla templates for over 10 years. During that time I have had to modify CSS, HTML and PHP code. Why do you ask?

User avatar
ceford
Joomla! Hero
Joomla! Hero
Posts: 2519
Joined: Mon Feb 24, 2014 10:38 pm
Location: Edinburgh, Scotland
Contact:

Re: Error when trying to display site templates

Post by ceford » Sun Dec 10, 2023 7:32 pm

I think you are using the wrong approach. Set cassiopeia as your default template, get everything working, and then customise it to make it look like your previous template. There are several articles available describing how to do it.

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9558
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Error when trying to display site templates

Post by AMurray » Sun Dec 10, 2023 9:49 pm

The link that is "unstyled" is the one in your original post.
https://j4rforest.californiadar.org/

https://californiadar.org/ (the J3 site) works fine, that's not what I was referring to.
Regards - A Murray

kkurtz
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jul 12, 2012 1:38 pm

Re: Error when trying to display site templates

Post by kkurtz » Mon Dec 11, 2023 11:24 pm

If I click on the https://j4rforest.californiadar.org/ link in your response I get a styled page. So I am not sure what is happening when you see an unstyled page.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 43880
Joined: Sat Apr 05, 2008 9:58 pm

Re: Error when trying to display site templates

Post by Webdongle » Tue Dec 12, 2023 1:09 am

no css 01.JPG
You do not have the required permissions to view the files attached to this post.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

kkurtz
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jul 12, 2012 1:38 pm

Re: Error when trying to display site templates

Post by kkurtz » Wed Dec 13, 2023 6:23 pm

How do I post an image? Do I have to link to it or can I copy and paste?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 43880
Joined: Sat Apr 05, 2008 9:58 pm

Re: Error when trying to display site templates

Post by Webdongle » Wed Dec 13, 2023 8:25 pm

Click FullEditor and Previw
Click Attachments tab
Click Add Files
Position your cursor in the post and click Place inline
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9558
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Error when trying to display site templates

Post by AMurray » Wed Dec 13, 2023 9:12 pm

this is the unstyled page that I am seeing:
unstyled page.jpg
You do not have the required permissions to view the files attached to this post.
Regards - A Murray

kkurtz
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jul 12, 2012 1:38 pm

Re: Error when trying to display site templates

Post by kkurtz » Sat Dec 16, 2023 8:39 pm

Reply to Webdongle:
I am on the Full Editor and Preview page (this is where I am typing).
You say:
Click Attachments tab
Click Add Files
Position your cursor in the post and click Place inline

I don't see an Attachments tab. I see a button with an image icon and when I click that I get this Image. If I try to paste between the image tags nothing happens. If I click on the link button I get this .
I see buttons for bold, italics, underline, quote, code, and lists.
No attachment tab.
If I could send you a picture I would.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 43880
Joined: Sat Apr 05, 2008 9:58 pm

Re: Error when trying to display site templates

Post by Webdongle » Sat Dec 16, 2023 9:13 pm

kkurtz wrote:
Sat Dec 16, 2023 8:39 pm
...
I don't see an Attachments tab....
image 01.JPG
Click Add Files (it opens up a browser window to your computer files. I'm not showing my files)
image 02.JPG
When you selected the image and uploaded it, put the cursor where you want it and then click Place in Line
image 03.JPG
You do not have the required permissions to view the files attached to this post.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

kkurtz
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Thu Jul 12, 2012 1:38 pm

Re: Error when trying to display site templates

Post by kkurtz » Tue Dec 19, 2023 1:10 pm

Thanks Webdongle. Didn't see the button down there. My bad.
Here is what I see:
j4rforest.png
.
I don't know why you are only seeing the unstyled page.

Meanwhile, the original problem was that when I clicked Siet Templates in the backend I got an error. I solved the problem by uninstalling the template and re-installing it.

Thanks for your patience and your help. :D
You do not have the required permissions to view the files attached to this post.


Post Reply

Return to “Templates for Joomla! 4.x”