Corrupted after trying to revert Topic is solved

Need help installing Joomla! 4.x? For all Joomla! 4.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
thommango
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Mon Dec 07, 2020 1:15 am

Corrupted after trying to revert

Post by thommango » Wed Nov 23, 2022 2:34 pm

I took a full back up of my site before trying to upgrade from J3->J4. The install didn't go well, so I restored from the back up. Now, many errors are occurring. I cannot see anything under the system or extensions menu in the back end. I get a variety of messages about various classes missing.

I don't really understand how I, after a full restore, I can be in this position. I tried repeating the restore and tried restoring from earlier back-ups and the problem persists. I am sure the problem didn't exist before taking the back up. What is going on and how can I fix it?

gws
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4888
Joined: Tue Aug 23, 2005 1:56 pm
Location: South coast, UK
Contact:

Re: Corrupted after trying to revert

Post by gws » Wed Nov 23, 2022 2:50 pm

When you restore from a backup ,You must delete all files in joomla root and empty the database FIRST. Update failures change the DB and file structure.

thommango
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Mon Dec 07, 2020 1:15 am

Re: Corrupted after trying to revert

Post by thommango » Wed Nov 23, 2022 3:10 pm

Thanks. That fixed it. Seems weird to me that a full restore wouldn't also remove any extra files added since the restore, but can't argue with success. Cheers!


Post Reply

Return to “Installation Joomla! 4.x”