Joomla 4.3.4 cannot run PHP8.01

Need help installing Joomla! 4.x? For all Joomla! 4.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
westwing
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Mon May 01, 2006 7:31 pm
Location: New Zealand

Joomla 4.3.4 cannot run PHP8.01

Post by westwing » Thu Sep 28, 2023 7:55 am

A fresh install from Joomla.org and extracted to a new account on my server. Default PHP is 8.1 and on installation and opening the URL, I get the error
Sorry, your PHP version is not supported.
Your host needs to use PHP version 7.2.5 or newer to run this version of Joomla!
I revert to PHP 8.0 and the site opens with the correct Joomla Installer.

I did a fresh install from Softaculous with the same results.

However, PHP 8.2 works!

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9327
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Joomla 4.3.4 cannot run PHP8.01

Post by AMurray » Thu Sep 28, 2023 8:53 am

I'd advise not to install through Softaculous. Install Joomla the way it is intended (the proper way):
https://docs.joomla.org/J4.x:Installing_Joomla

Joomla 4 will run on PHP 7.2 upwards (regardless of 7.x being EOL) but the recommended PHP is 8.2.x
https://downloads.joomla.org/technical-requirements
Regards - A Murray

westwing
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Mon May 01, 2006 7:31 pm
Location: New Zealand

Re: Joomla 4.3.4 cannot run PHP8.01

Post by westwing » Thu Sep 28, 2023 9:29 am

Hi, if you read my post above you would see my issue was with a proper install.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 24749
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: Joomla 4.3.4 cannot run PHP8.01

Post by pe7er » Thu Sep 28, 2023 9:38 am

Joomla works on PHP 8.1.

Could you try the following:
Create a test.php file with the text

Code: Select all

<?php phpinfo()
in the root of your website.
Use your browser to open that test.php.
You should see all PHP information.

Switch to PHP 8.1 and test if it gives the right PHP version information.

Remove that test.php file after testing.
Kind Regards,
Peter Martin, Global Moderator
Company website: https://db8.nl/en/ - Joomla specialist, Nijmegen, Netherlands
The best website: https://the-best-website.com

westwing
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Mon May 01, 2006 7:31 pm
Location: New Zealand

Re: Joomla 4.3.4 cannot run PHP8.01

Post by westwing » Fri Sep 29, 2023 1:38 am

Hi Pe7er,

Did what you asked. Loaded PHP 7.4.33 and phpinfo was correct
Loaded PHP 8.0.29 and it was correct.

Loaded PHP 8.1 and it displayed PHP 7.1.33
PHP 8.2.8 was correct too.

I'm running Cloud Linux ... PHP 8.1 is obviously incorrect.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 16962
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Joomla 4.3.4 cannot run PHP8.01

Post by toivo » Fri Sep 29, 2023 2:11 am

Contact the support team of your host and they will fix the PHP configuration.
Toivo Talikka, Global Moderator

westwing
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Mon May 01, 2006 7:31 pm
Location: New Zealand

Re: Joomla 4.3.4 cannot run PHP8.01

Post by westwing » Fri Sep 29, 2023 3:11 am

Thank you toivo ... they are working on it!

westwing
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Mon May 01, 2006 7:31 pm
Location: New Zealand

Re: Joomla 4.3.4 cannot run PHP8.01

Post by westwing » Fri Sep 29, 2023 3:48 am

Their Reply ...

After further investigation. Looking further into the domain of www.ashburtononline.com. We may have found an inconsistency in the php type that is presented.

As you have identified with creating the phpinfo file, you have found some inconsistencies in the php versions being displayed as we have found that current version that is being shown for the domain www.ashburtononline.com is PHP 5.2.17

[online@lahost2 ~]$ php -v
PHP 5.2.17 (cli) (built: Aug 9 2023 09:40:31)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
with the ionCube PHP Loader v12.0.5, Copyright (c) 2002-2022, by ionCube Ltd. with SourceGuardian v12.0.0, Copyright (c) 2000-2021, by SourceGuardian Ltd. with Zend Optimizer v3.3.9, Copyright (c) 1998-2009, by Zend Technologies [online@lahost2 ~]$ ||


This was initiated by logging into the domains Cpanel account and running the php -v within the terminal and also utilizing a free online php checker https://www.updatephp.com/?checkUrl=htt ... ine.com%2F

Unfortunately, as stated earlier in this thread, as Joomla is a third party program that is outside the scope of our support. We hope that these findings may assist you or help with identifying by reaching out to Joomla for assistance with this issue.

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 24749
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: Joomla 4.3.4 cannot run PHP8.01

Post by pe7er » Fri Sep 29, 2023 3:57 am

westwing wrote:
Fri Sep 29, 2023 3:48 am
[online@lahost2 ~]$ php -v
PHP 5.2.17 (cli) (built: Aug 9 2023 09:40:31)
I don't know why your hosts mentions the PHP command line version. It's only used when you use CLI scripts of Joomla.
So you have PHP 5.2 on the command line. That's very outdated and its security support ended 12 years ago
(06 Jan 2011). https://endoflife.date/php

Joomla uses the PHP version via the web server, which is another version.

westwing wrote:
Fri Sep 29, 2023 3:48 am
Unfortunately, as stated earlier in this thread, as Joomla is a third party program that is outside the scope of our support. We hope that these findings may assist you or help with identifying by reaching out to Joomla for assistance with this issue.
Sorry, we cannot do anything about any bad configuration on your server.
If my host would not be capable in getting their environment right (and keeps running outdated software) then I would probably switch to a better provider..
Kind Regards,
Peter Martin, Global Moderator
Company website: https://db8.nl/en/ - Joomla specialist, Nijmegen, Netherlands
The best website: https://the-best-website.com

westwing
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Mon May 01, 2006 7:31 pm
Location: New Zealand

Re: Joomla 4.3.4 cannot run PHP8.01

Post by westwing » Fri Sep 29, 2023 7:46 am

Hi pe7er ... I'm running Cloud Linux and most of those PHP 5* versions were enabled years ago ... they are turned off now save 5.6 which 1 client requires for a script ... Their new site will make 5.6 redundant in the coming weeks. This will mean I'll only be using PHP 7.6 + going forward and I'll get these to PHP 8 asap.

Ironically, PHP 8.0 works on all sites (that can run it ... some are still Joomla 3), Php 8.1 on none and PHP 8.2 on some ....

I have opened a ticket with Softaculous without reply in 2 days.

gws
Joomla! Champion
Joomla! Champion
Posts: 5631
Joined: Tue Aug 23, 2005 1:56 pm
Location: South coast, UK
Contact:

Re: Joomla 4.3.4 cannot run PHP8.01

Post by gws » Fri Sep 29, 2023 7:50 am

Softaculous is known to cause problems, I strongly recommend that you install joomla properly.

westwing
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Mon May 01, 2006 7:31 pm
Location: New Zealand

Re: Joomla 4.3.4 cannot run PHP8.01

Post by westwing » Fri Sep 29, 2023 7:59 am

Thanks GWS ... but I have 60+ Joomla websites, most that were installed via Softaculous, without issues. I can change this going forward but that doesn't help me today or with my existing clients.
The rot set in with the release of PHP 8.1

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 16962
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Joomla 4.3.4 cannot run PHP8.01

Post by toivo » Fri Sep 29, 2023 8:56 am

As it has been pointed out and should have become abundantly clear, Joomla does not select or configure the version of PHP, but your host does all that. You should be able to point them to the right direction.

In case there could be more issues in the configuration of the web server, please post the results from the Forum Post Assistant (FPA), while having PHP 8.1 active, by following the instructions at https://forumpostassistant.github.io/docs/ so that the configuration can be reviewed.
Toivo Talikka, Global Moderator


Post Reply

Return to “Installation Joomla! 4.x”