Joomla generated emails never arrive Topic is solved

Need help with the Administration of your Joomla! 4.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
User avatar
dc41
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Thu Jul 27, 2006 9:16 pm

Joomla generated emails never arrive

Post by dc41 » Wed Jun 29, 2022 11:41 pm

I have a site that was upgraded to Joomla 4 (currently 4.1.5) from 3.10 about 7 weeks ago. I had not tried to have Joomla send an email message after the upgrade because the only extension that sent messages wasn't 4 compatible yet. I installed Shack Forms but never received an email notification that a form was submitted.

I confirmed email was turned on in system/global config/server. I've tried PHPMail and SendMail to multiple email accounts. Each time I click on "Send Test Email" I get the following message: "The email was sent to xxxxxt@xxxmail.com using PHP Mail. You should check that you've received the test email." So, Joomla thinks it's sending them.

I've checked junk/spam folders... nothing. Joomla acts like everything is normal, but the message is never received regardless of email account (tried Exchange, Gmail, etc.).

Could my ISP be blocking email messages from the site? Is there an error log that I can check for messages? I don't think it's Shack Form's fault, because Joomla messages are not getting through. Any suggestions would be greatly appreciated.

Thanks!

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 14774
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Joomla generated emails never arrive

Post by toivo » Thu Jun 30, 2022 12:49 am

dc41 wrote:
Wed Jun 29, 2022 11:41 pm
Each time I click on "Send Test Email" I get the following message: "The email was sent to xxxxxt@xxxmail.com using PHP Mail. You should check that you've received the test email." So, Joomla thinks it's sending them.
Joomla has sent the test emails to the mailbox defined in Global Configuration - Server - Mail - From Email. Check also the Sent folder of xxxxxt@xxxmail.com, just in case.

dc41 wrote:
Wed Jun 29, 2022 11:41 pm
Could my ISP be blocking email messages from the site?
Hosting companies often require websites to use Sendmail in the same box or an SMTP server in their network and will block external mail traffic.

Does the email domain of the mailbox in From Mail match the domain of the web site, to eliminate spam blockers stopping the emails?

dc41 wrote:
Wed Jun 29, 2022 11:41 pm
Is there an error log that I can check for messages?
The following steps will generate a detailed debug log at the SMTP protocol level from email transactions:

Go to Global Configuration - Logging and select 'Log Almost Everything'. In the tab Custom Logging enter mail into Log Categories.

Enable the plugin System - Debug and select the user group you are using in the test in 'Allowed Groups' so that other users and visitors do not see the debug output at the bottom of the page.

Send the test email and submit the forms. Download the log file from administrator/logs/everything.php and post the relevant lines here for advice.
Toivo Talikka, Global Moderator

User avatar
dc41
Joomla! Intern
Joomla! Intern
Posts: 52
Joined: Thu Jul 27, 2006 9:16 pm

Re: Joomla generated emails never arrive

Post by dc41 » Thu Jun 30, 2022 5:22 pm

Got it figured out. I dug into the Mail Delivery Reports in WHM and was able to trace the traffic. Joomla/Shack Forms was sending fine. Gmail (this client uses Google Business Suite or whatever they are calling it now) was accepting the message but then sending a return message to the server saying it considered it spam and would not deliver it. I made some tweaks to the email addresses to make Gmail happy, and it's no longer rejecting the messages.

The previous test messages to non-Gmail accounts were in the respective inboxes this morning. Must have taken an eastern European route! :)

Hope this helps someone who encounters similar problems.

Thanks!


Post Reply

Return to “Administration Joomla! 4.x”