Obsolete PHP version is not reported

Need help with the Administration of your Joomla! 4.x site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
schohmik
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Sun Feb 12, 2006 9:29 pm

Obsolete PHP version is not reported

Post by schohmik » Fri Mar 01, 2024 5:08 pm

Hi,

I am using Joomla 4 as superuser administrator. When I start the background there is no error message shown
that the PHP version is obsolete.

Thank you for help!

User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2631
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Obsolete PHP version is not reported

Post by JAVesey » Fri Mar 01, 2024 10:02 pm

schohmik wrote:
Fri Mar 01, 2024 5:08 pm
Hi,

I am using Joomla 4 as superuser administrator. When I start the background there is no error message shown
that the PHP version is obsolete.

Thank you for help!
Is there a question here? What is it that you need help with?
John V
Cardiff, Wales, UK
Joomla 5.0.3 "live" site on PHP 8.2.15 and MariaDB 10.11.7
Joomla 5.0.3 on XAMMP for OSX with PHP 8.2.4 and MariaDB 10.4.28

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 17412
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Obsolete PHP version is not reported

Post by toivo » Fri Mar 01, 2024 10:06 pm

Which version of PHP does the web server have? What does Joomla report, when you go to System - Information - System Information - PHP Information?

Go to Plugins and search for 'PHP'. Is the plugin 'Quick Icon - PHP Version Check' enabled?
Toivo Talikka, Global Moderator

schohmik
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Sun Feb 12, 2006 9:29 pm

Re: Obsolete PHP version is not reported

Post by schohmik » Sat Mar 02, 2024 9:14 am

Hi,

the plugin PHP Version Check' enabled. It seems that this plugin sets PHP to a valuable version independently of
which version the web server has. Is this interpretation correct?

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 17412
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Obsolete PHP version is not reported

Post by toivo » Sat Mar 02, 2024 9:17 am

That interpretation is not correct. The plugin reports the version of PHP that Joomla is running under, as assigned by the configuration of the web server.
Toivo Talikka, Global Moderator

schohmik
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Sun Feb 12, 2006 9:29 pm

Re: Obsolete PHP version is not reported

Post by schohmik » Sat Mar 02, 2024 12:30 pm

It's a bit curious that the webserver has PHP-version 8.0.30 (which is outdated) and the system information says 8.1.27.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 17412
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Obsolete PHP version is not reported

Post by toivo » Sat Mar 02, 2024 12:41 pm

Check the file .htaccess in the main Joomla folder. Some hosts add directives there to load a particular version of PHP.
Toivo Talikka, Global Moderator

schohmik
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Sun Feb 12, 2006 9:29 pm

Re: Obsolete PHP version is not reported

Post by schohmik » Sat Mar 02, 2024 1:46 pm

The htaccess is made by akeeba.admintools.
What shall I check in the htaccess?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 30874
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Obsolete PHP version is not reported

Post by Per Yngve Berg » Sat Mar 02, 2024 2:07 pm

You are not comparing the CLI php version with the one run by the web server? They may be different.

schohmik
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Sun Feb 12, 2006 9:29 pm

Re: Obsolete PHP version is not reported

Post by schohmik » Sat Mar 02, 2024 4:04 pm

I have deleted the .htaccess in my FTP. The result is quite the same: In backend system/system information the version of PHP is a valuable one (8.1.27) though the webserver has PHP-version 8.0.30 (which is outdated).

User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2631
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Obsolete PHP version is not reported

Post by JAVesey » Sat Mar 02, 2024 5:34 pm

schohmik wrote:
Sat Mar 02, 2024 4:04 pm
I have deleted the .htaccess in my FTP.
You will have a file called htaccess.txt in your Joomla root directory. This will be the one which came with your current Joomla version. Rename it to .htaccess otherwise your SEF URLs won’t work.

There is nothing in this htaccess.txt which will interfere with the PHP version that your site is running.

Have you checked the content of other .htaccess files, e.g. in your /administrator folder? It’s possible that there’s a directive in other .htaccess files.
John V
Cardiff, Wales, UK
Joomla 5.0.3 "live" site on PHP 8.2.15 and MariaDB 10.11.7
Joomla 5.0.3 on XAMMP for OSX with PHP 8.2.4 and MariaDB 10.4.28

schohmik
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Sun Feb 12, 2006 9:29 pm

Re: Obsolete PHP version is not reported

Post by schohmik » Sat Mar 02, 2024 6:35 pm

As I mentioned above: I have deleted the .htaccess in my FTP. The result is quite the same: In backend system/system information the version of PHP is a valuable one (8.1.27) though the webserver has PHP-version 8.0.30 (which is outdated).

User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2631
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Obsolete PHP version is not reported

Post by JAVesey » Sat Mar 02, 2024 6:46 pm

schohmik wrote:
Sat Mar 02, 2024 6:35 pm
As I mentioned above: I have deleted the .htaccess in my FTP. The result is quite the same: In backend system/system information the version of PHP is a valuable one (8.1.27) though the webserver has PHP-version 8.0.30 (which is outdated).
I think you might have misunderstood. You could have more than one .htaccess file, including one in the /administrator folder inside your Joomla root directory. It could be that the reported php version and the one that you’re running are different.
John V
Cardiff, Wales, UK
Joomla 5.0.3 "live" site on PHP 8.2.15 and MariaDB 10.11.7
Joomla 5.0.3 on XAMMP for OSX with PHP 8.2.4 and MariaDB 10.4.28

schohmik
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Sun Feb 12, 2006 9:29 pm

Re: Obsolete PHP version is not reported

Post by schohmik » Sat Mar 02, 2024 7:12 pm

I have two htaccess-files one as htaccess.txt and one as .htaccess.
Ashampoo_Snap_Samstag, 2. März 2024_20h09m25s_001_.png
You do not have the required permissions to view the files attached to this post.

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9696
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Obsolete PHP version is not reported

Post by AMurray » Sat Mar 02, 2024 10:30 pm

Delete the existing .htaccess file. Rename htaccess.txt to .htaccess which is what @JAvesey stated above.
Regards - A Murray
General Support Moderator

schohmik
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Sun Feb 12, 2006 9:29 pm

Re: Obsolete PHP version is not reported

Post by schohmik » Sun Mar 03, 2024 9:10 am

It's not working: on the webserver the version is 8.0.30 (outdated) and joomla system information says version is 8.2.16

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 30874
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Obsolete PHP version is not reported

Post by Per Yngve Berg » Sun Mar 03, 2024 9:27 am

Where do you see the 8.0.30?

schohmik
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Sun Feb 12, 2006 9:29 pm

Re: Obsolete PHP version is not reported

Post by schohmik » Sun Mar 03, 2024 10:09 am

sorry but I mentioned it just before: on the webserver the version is 8.0.30 (outdated)

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 17412
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Obsolete PHP version is not reported

Post by toivo » Sun Mar 03, 2024 10:19 am

schohmik wrote:
Sun Mar 03, 2024 10:09 am
on the webserver the version is 8.0.30
How do you know this? Did your host tell you that? Or do you have full access to the server?

If you can run a command in the shell that displays the version of PHP, it is the Command Line Interface (CLI) version of PHP, which can be different from the version of PHP installed in the web server. Joomla uses the version of PHP integrated with the web server, not the CLI version.
Toivo Talikka, Global Moderator

schohmik
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Sun Feb 12, 2006 9:29 pm

Re: Obsolete PHP version is not reported

Post by schohmik » Sun Mar 03, 2024 1:53 pm

I have full access to the server.

and can choose the PHP version:

The Joomla system information shows.
You do not have the required permissions to view the files attached to this post.

User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2631
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Obsolete PHP version is not reported

Post by JAVesey » Sun Mar 03, 2024 5:13 pm

Your site will be running under PHP 8.2.16, as Joomla reports.

What happens when you select 8.2.16 on the server?
John V
Cardiff, Wales, UK
Joomla 5.0.3 "live" site on PHP 8.2.15 and MariaDB 10.11.7
Joomla 5.0.3 on XAMMP for OSX with PHP 8.2.4 and MariaDB 10.4.28

schohmik
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Sun Feb 12, 2006 9:29 pm

Re: Obsolete PHP version is not reported

Post by schohmik » Sun Mar 03, 2024 5:46 pm

Same result.


Post Reply

Return to “Administration Joomla! 4.x”